LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-23-2006, 08:43 PM   #1
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Rep: Reputation: 0
Unable to have 1440x900 resolution


Hello,

I'm running Suse 10.0 with the Gnome window manager on a hp pavilion zd7010us that has a Nvidia Geforce 4 448 go video card. I want to update my drivers, but when I do, Gnome refuses to show any resolustion above 1280x800. Sax2 still says I'm set up for 1440x900, but nothing I do in Sax2 seems to affect anything. I changed my xorg.config to say "nv" instead of "nvidia" for the driver as another forum sugested, but then my "enable 3d acceleration" is greyed out. I can however, get a resolution of 1440x900 then. Is there a way to have the best drivers in order to have 3d acceleration and have a 1440x900 resolution?
 
Old 05-24-2006, 01:33 AM   #2
phoenix49
Member
 
Registered: Jun 2005
Location: Azerbaijan/Baku
Distribution: Fedora Core 6 "Zod"
Posts: 179

Rep: Reputation: 30
Quote:
Originally Posted by zippy4251
Hello,

I'm running Suse 10.0 with the Gnome window manager on a hp pavilion zd7010us that has a Nvidia Geforce 4 448 go video card. I want to update my drivers, but when I do, Gnome refuses to show any resolustion above 1280x800. Sax2 still says I'm set up for 1440x900, but nothing I do in Sax2 seems to affect anything. I changed my xorg.config to say "nv" instead of "nvidia" for the driver as another forum sugested, but then my "enable 3d acceleration" is greyed out. I can however, get a resolution of 1440x900 then. Is there a way to have the best drivers in order to have 3d acceleration and have a 1440x900 resolution?
If you mean "enable 3d acceleration" as XGL (3D desktop), then I think this is related to hardware, cause XGL is OpenGL desktop, just like you are playing some 3D game, or just using opengl libraries, check your nvidia documentation, on which resolution it can run 3D, anyway, this is not 100% true, but I guess
 
Old 05-24-2006, 02:36 AM   #3
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
3D acceleration greyed out:the nv driver is 2D accelerated only. For 3D (DRI) acceleration, you must use the nvidia driver. Thus the 3D options are no longer available. (A link to where you got this advice would be nice.)

Screen resolution: You have to edit your xorg.conf (or reconfigure the monitor in the gui). If you have been able to use 1440x900 previously, then it should just be a matter of setting the config properly. (Note: you may not have access to all resolutions at all refresh/sync rates and colour-depths... and with 3D acceleration.) So first - lets have a look at /etc/X11/xorg.conf
 
Old 05-24-2006, 03:10 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
First, under sax, select the closest LCD monitor selection. Then add your resolution. If that doesn't work, you could try to use the "gtf" program to generate a new modeline.
gtf 1440 900 60 x
This will generate a modeline for 1440x900 with a 60 hz refresh rate.
Add that line to the "Monitor" section. Change any reference to "1440x900" in the xorg.conf file to the new name of your modeline. I think it will be "1440x900_60" for this example.
The Horizontal and Vertical timing parts of the xorg.conf can be tricky.
Hopefully, you won't need to change the global timing entries because this part can be sensitive. Try reducing the refresh rate in gtf command first.

This is how I had to set up my ZV5000 laptop, when I used an earlier SuSE.

Since you have a laptop with a verly large lcd screen, you might want to use the 1440x900 resolution all the time. On my zv5000, the native resolution look great, but the 1024x768 resolution looks to fuzzy in comparision.

The nvidia driver that SuSE 10.0 would download in the software update didn't handle the composite extension, so I ran the nvidia installation program ( that I had saved from earlier) with the --update option to download and run the lates nvidia driver version. That added support for the composite extention but I can't use both the composite extention and openGL programs like blender. The option I found that was supposed to fix that didn't work.
 
Old 05-24-2006, 08:14 AM   #5
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I tried what you suggested jschiwal, but it didn't work. I couldn't get Sax2 to load either so I went to the command and did it there but it reverted my xorg.conf file back to it's origional state.. Sax2 always let me select 1440x900 at 70 mhz, but testing only produces 1280x800. Gnome still won't let me select 1440x900 either. I do have 3d acceleration though. Here's my xorg.conf

Section "Monitor"
DisplaySize 366 229
HorizSync 29-90
Identifier "Monitor[0]"
ModelName "1440X900@70HZ"
Option "DPMS"
VendorName "--> LCD"
VertRefresh 58-72
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1440x900" 126.98 1440 1536 1688 1936 900 901 904 937
Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
Modeline "1152x864" 96.77 1152 1224 1344 1536 864 865 868 900
Modeline "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895
Modeline "1280x768" 94.98 1280 1352 1488 1696 768 769 772 800
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
Modeline "1024x768" 76.16 1024 1080 1192 1360 768 769 772 800
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
Modeline "800x600" 45.50 800 840 920 1040 600 601 604 625
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
Modeline "768x576" 41.66 768 800 880 992 576 577 580 600
Modeline "768x576" 34.96 768 792 872 976 576 577 580 597
Modeline "640x480" 28.56 640 664 728 816 480 481 484 500
Modeline "640x480" 23.86 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1440x900" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce4 448 Go"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
#Option "NvAGP" "2"
#Option "NvAGP" "0"
#Option "NvAGP" "3"
#Option "NvAGP" "1"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
 
Old 05-24-2006, 09:44 AM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
http://www.linuxquestions.org/questi...d.php?t=363580
... there is a discussion of methods to get screen res to change properly in suse.

suse seems to use some personal xorg.conf format I'm unfamiliar with.

Looking at this, it appears that 1280x800@83.46Hz is the best you can do -

Hmmm... you could try setting horizontal sync, in the monitor section, to 29-130. I wouldn't bet on it though - this is assuming it is the dot-clock that is restricting you.

http://www.tldp.org/HOWTO/XFree86-Vi...WTO/index.html
(Out of date but informative about what those modelines are telling you.)
 
Old 05-24-2006, 11:11 AM   #7
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Hmm...intersting. Maybe I'll back things up and play around a little. I wonder if this is a Suse thing, or if it's a Nvidia thing. Going lower on the res is just too fuzzy, but not having 3d acceleration isn't an option either.
 
Old 05-24-2006, 06:52 PM   #8
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Alright, so after dinking around with it, I still cannot be in 1440x900 without using the "nv" driver that doesn't have 3d acceleration. Editing xorg.conf to only allow that resolution doesn't work. Sax2 says 1440x900 but doesn't show higher than 1280x800. Something automatically edits the configuration so it won't display anything but that resolution. Is there anyother way to configure this? Would running KDE change my chances? Updating to Suse 10.1? The latest Gnome?
 
Old 05-24-2006, 07:06 PM   #9
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
It would appear that the nvidia driver does not support the resolution you want with your video card. It would appear the card is supposed to support this resolution. It may be that upgrading the nvidia driver to the latest version will solve this.
 
Old 05-24-2006, 08:06 PM   #10
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Original Poster
Rep: Reputation: 0
First of all, I want to thank you guys for helping me this far. I did the YOU update, but evidentally it didn't work. Here's what the manual install did.

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed May 24 18:29:44 2006

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
7676). As part of installing this driver (version: 1.0-8762), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC test with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured; on Red Hat Linux systems,
for example, be sure you have the 'kernel-source' RPM installed. If you
know the correct kernel source files are installed, you may specify the
kernel source path with the '--kernel-source-path' command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.


I'm in a little over my head here and I'm not sure what to do about this.
 
Old 05-24-2006, 11:41 PM   #11
phoenix49
Member
 
Registered: Jun 2005
Location: Azerbaijan/Baku
Distribution: Fedora Core 6 "Zod"
Posts: 179

Rep: Reputation: 30
Make sure that you have correctly installed kernel source/header file. I guess you are using one of packaged kernels, so open up YaST and find kernel-devel in software management
 
Old 05-25-2006, 09:05 AM   #12
zippy4251
LQ Newbie
 
Registered: Mar 2005
Posts: 13

Original Poster
Rep: Reputation: 0
I did find kernal-devel in YaST, but it was greyed out and unchecked. Not sure what to do there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf and 1440x900 resolution mrsolo Linux - Software 6 11-15-2010 11:32 PM
1440x900 Resolution mrsolo Linux - Laptop and Netbook 3 11-15-2010 11:27 PM
I need help to get 1440x900 resolution pls whjones Fedora 1 09-13-2005 11:20 PM
1440X900 resolution mimithebrain Linux - Laptop and Netbook 3 08-29-2005 09:57 PM
Unable to get 1440x900 resolution robebe Linux - Laptop and Netbook 6 04-30-2005 09:47 PM


All times are GMT -5. The time now is 06:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration