LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to get Lucent/Agere (ORiNOCO USB Client Gold) to work in linux (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-get-lucent-agere-orinoco-usb-client-gold-to-work-in-linux-641036/)

caldorean 05-09-2008 07:30 AM

Unable to get Lucent/Agere (ORiNOCO USB Client Gold) to work in linux
 
Hi there, I recently purchased a Orinoco USB Client Gold to use as an external wireless network card for my linux dists, I have tried to follow several different guides on how to get it to work but none have given me (or I'm just plainly stupid ^^) enough information to bring it up and working.

using the lsusb command gives me
Quote:

bt ~ # lsusb
Bus 2 Device 1: ID 0000:0000
Bus 1 Device 4: ID 047e:0300 Agere Systems, Inc. (Lucent)
Bus 1 Device 3: ID 0e0f:0002
Bus 1 Device 1: ID 0000:0000
This is using the Backtrack which uses KDE (I think, not totally sure)
And the same goes for Ubuntu 6.10, 7.10 and the new 8.04.

I'm clueless of how to continue cause most of these warns when trying
to use the make command that the driver is already in the kernel?
Or something the like.

Does anyone have any ideas of how to get this darned card working in
Linux? Cause I'm out of ideas and not really sure what to look for
anymore.

Thanks for your time reading my problems through
/Caldorean

I think I just put this in the wrong part, should have been in the hardware part, well, I am a newbie, sorry for the inconvenience.

After trying to make the driver from http://www.nongnu.org/orinoco/
I'm slapped with this message

Quote:

make -C /usr/src/linux-headers-2.6.22-14-generic M=/home/caldorean/orinoco-0.15 KERNELRELEASE=2.6.22-14-generic modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-generic'
/home/caldorean/orinoco-0.15/Kbuild:34: *** Wireless extensions are not enabled. Stop.
make[1]: *** [_module_/home/caldorean/orinoco-0.15] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-generic'
make: *** [modules] Error 2
I take it there's something with the headers that is bugging about?

MS3FGX 05-09-2008 07:46 AM

Well what exactly do you mean by not working? Is the device detected, does the module load, does the interface come up, etc, etc?

caldorean 05-09-2008 07:49 AM

It sees the usb device with the lsusb, but the interface doesn't come up, the module is not loading (at least I don't think it does) and the device doesn't indicate that it is running at all (two leds not showing anything)

caldorean 05-09-2008 11:56 AM

Bah, not even getting the LED's to show a single flashing light..


All times are GMT -5. The time now is 01:39 PM.