LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-17-2010, 03:34 AM   #1
ErevRav
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Rep: Reputation: 0
unable to get internet to work


I’m new to linux

Im having trouble setting up my internet connection

I have cable internet. The laptop is connected directly to the modem (no router, no wireless).

I just installed suse 10.0 from dvd onto my laptop

When I use YAST to go network devices->network card, an Ethernet card is detected.

It said it was unconfigured so I chose to edit:

Device Type: Ethernet

Setup method: Autom. Addr. Sett (via DHCp)

Host Name and Name Serv Conf:
Checked “change host name via DHCP”
Checked “update name servers and search list via dhcp”

Routing: didn’t do anything here

Advanced-> Hardware Details: checked pcmcia

Advanced-> DHCP client options: checked request broadcast response

Advanced->Detailed Settings: selected “at boot time”; checked “user controlled”; selected “external zone”

Advanced-> Additional addresses: nothing

I have no internet, googled for solutions here and there, no luck.

I’m hoping to get some tips.

Last edited by ErevRav; 09-17-2010 at 07:23 AM.
 
Old 09-17-2010, 03:54 AM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,143
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
hi

run
Quote:
ifconfig
wats the ip you are getting?
you are getting ip or not?

run
Quote:
route -n
at the end you should get gateway ip

0.0.0.0 Some IP? 0.0.0.0 UG 0 0 0 eth0

run
Quote:
cat /etc/resolv.conf
you should get dns ip

try to ping gateway and dns ;when u get reply from ping then you have internet connection.
if you cant see ip in ifonfig,/etc/resolv.conf and gateway ip network configuration is not done properly using yast

Last edited by prayag_pjs; 09-17-2010 at 03:55 AM.
 
Old 09-17-2010, 03:58 AM   #3
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
Since it's an Ethernet card, have you tried configuring it from the command line? Try this:

Code:
ifconfig eth0 add <your address>
ifconfig eth0 hw slip <your address>
ifconfig eth0 up
 
Old 09-17-2010, 04:28 AM   #4
ErevRav
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
First off, tnx for the replies.

In Suse-> run command>ifconfig>"could not run specified command"

Same for "route -n"

Same for "cat /etc/resolv.conf

Running ipconfig on my win machinge gets me:

IP adress: 83.81.49.69
Subnet mask: 255.255.248.0
Default gateway: 83.81.48.1

cheers
 
Old 09-17-2010, 04:34 AM   #5
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 56
<removed, as I thought something that wasn't true>
 
Old 09-17-2010, 04:35 AM   #6
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
I don't know who your cable provider is and Im not sure if you done this. But most cable providers bind your mac to their network. So make sure you restart your modem to make sure thats not your problem. If you modem has a gui you may sometimes need to login to it and do a soft reset or use the physical reset button to reset it. If you do a physical reset besure that the power does not get cut off during the reset process or you can corrupt your firmware.

Last edited by jmc1987; 09-17-2010 at 04:37 AM.
 
Old 09-17-2010, 04:38 AM   #7
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
I'm not familiar with the Suse set up but in Debian I have to run both ifconfig and route as root (or use sudo). Maybe that's your problem.
ciao,
jdk
 
Old 09-17-2010, 04:41 AM   #8
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 113Reputation: 113
use sudo to run command as root

Code:
sudo ifconfig
sudo route -n
 
Old 09-17-2010, 04:42 AM   #9
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,143
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
hi

try to disable firewall and selinux using yast or yast2
 
Old 09-17-2010, 04:45 AM   #10
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7/10
Posts: 879

Rep: Reputation: 113Reputation: 113
Oh just to add you have to run like this

/sbin/ifconfig

Works for me
Quote:
james@linux-i38y:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:22:15:CA:99:85
inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::222:15ff:feca:9985/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:60 (60.0 b) TX bytes:4437 (4.3 Kb)
Interrupt:253 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:340 (340.0 b) TX bytes:340 (340.0 b)
 
Old 09-17-2010, 05:12 AM   #11
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Are you sure that your modem uses dhcp to assign your ip? Often these things use pppoe.

Evo2.
 
Old 09-17-2010, 07:00 AM   #12
ErevRav
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok.

Got ifconfig result:

Link Encap: Local Loopback
Inet addr 127.0.0.1 Mask 255.0.0.0

Route -n:
Destination 127.0.0.0
Gateway 0.0.0.0
Genmask 255.0.0.0

cat /etc/resolv.conf
search site

Tnx for the help

P.S. Tried resetting modem, no result.
P.P.S. No, I'm not sure my modem uses DHCP (not sure 'bout much of anything at the mo). Will try to find out.

Last edited by ErevRav; 09-17-2010 at 07:03 AM.
 
Old 09-17-2010, 07:13 AM   #13
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,143
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

How you access internet on windows?

From above ifconfig result of your we can conclude that your system not getting ip from ISP.
The reason may be incorrect network configuration.

If you let us know how you get internet on your windows system then we can figure out the solution for you...
 
Old 09-17-2010, 07:20 AM   #14
ErevRav
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok.

I have no router lying around. When I unplug my laptop (with suse) and plug in my win mac, i've an internet connection without doing anything else. For ipconfig result see post above.

I wanted to get to know linux, so i installed it on my laptop to play around with. If i could just get internet to run, id have a solid starting position.

I realize i'm lacking general IT (orwhathaveyou) knowledge here, but hey gotta start somewhere.

Last edited by ErevRav; 09-17-2010 at 07:22 AM.
 
Old 09-17-2010, 07:22 AM   #15
hughetorrance
Member
 
Registered: Aug 2009
Location: London North West
Distribution: x86_64 Slack 13.37 current : +others
Posts: 459

Rep: Reputation: 59
Another easy thing to check your hardware is try a live distro and see if it connects you,all the major distros are pretty good at it... !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to connect to internet veeravicky Linux - Networking 2 03-19-2010 04:20 AM
Unable to use internet, but windows shares work great.. THOR_Fedora Linux - Wireless Networking 1 01-17-2006 05:18 AM
unable to use internet with static ip aw_wolfe Linux - Newbie 6 04-20-2005 06:40 PM
Unable to access internet TBomb Linux - Networking 4 08-11-2004 10:29 AM
unable to get to internet tus Linux - Networking 2 02-14-2002 04:29 PM


All times are GMT -5. The time now is 04:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration