LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2013, 05:20 AM   #1
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Rep: Reputation: Disabled
Unable to exclude pkg while upgrading


Hi,

I am unable to exclude one package while updating.I am running the below command and getting the below dependencies issue for one pkg only other pkg munin is excluding but UltraEdit is not. I alrady tried on command with options (--exclude=UltraEdit*)

yum --exclude=*UltraEdit* --exclude=munin* update

--> Finished Dependency Resolution
UltraEdit-1.2-0.12.x86_64 from installed has depsolving problems
--> Missing Dependency: libboost_regex.so.2()(64bit) is needed by package UltraEdit-1.2-0.12.x86_64 (installed)
Error: Missing Dependency: libboost_regex.so.2()(64bit) is needed by package UltraEdit-1.2-0.12.x86_64 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Thanks,
 
Old 03-14-2013, 05:24 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you ARE excluding it, that's the point. has dependencies on other packages that will break if you upgrade those other packages too.

I'd point out though, that the error there VERY clearly tells you how to progress, with the --skip-broken option.. Please pay full attention to the error messages, they are often VERY useful.
 
Old 03-14-2013, 05:41 AM   #3
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Thanks, I tried with option --skip-broken and found below results. My moto is to patches update. Now my question is if i run the same command will be there any problem ? Any kind of issue ? Any better way to achieve this ?

Packages skipped because of dependency problems:
boost-1.39.0-9.el5.x86_64 from atrpms-stable
boost-date-time-1.39.0-9.el5.x86_64 from atrpms-stable
boost-filesystem-1.39.0-9.el5.x86_64 from atrpms-stable
boost-graph-1.39.0-9.el5.x86_64 from atrpms-stable
boost-iostreams-1.39.0-9.el5.x86_64 from atrpms-stable
boost-math-1.39.0-9.el5.x86_64 from atrpms-stable
boost-program-options-1.39.0-9.el5.x86_64 from atrpms-stable
boost-python-1.39.0-9.el5.x86_64 from atrpms-stable
boost-regex-1.39.0-9.el5.x86_64 from atrpms-stable
boost-serialization-1.39.0-9.el5.x86_64 from atrpms-stable
boost-signals-1.39.0-9.el5.x86_64 from atrpms-stable
boost-system-1.39.0-9.el5.x86_64 from atrpms-stable
boost-test-1.39.0-9.el5.x86_64 from atrpms-stable
boost-thread-1.39.0-9.el5.x86_64 from atrpms-stable
boost-wave-1.39.0-9.el5.x86_64 from atrpms-stable
munin-common-2.0.10-1.el5.noarch from epel
munin-node-2.0.10-1.el5.noarch from epel
perl-List-MoreUtils-0.33-5.el5.x86_64 from epel
perl-Net-CIDR-0.13-2.el5.noarch from epel


Thanks,
 
Old 03-14-2013, 05:44 AM   #4
project.linux.proj
Member
 
Registered: Dec 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
Below is the picture.

Packages skipped because of dependency problems:

------------------------------
------------------------------
------------------------------
------------------------------
boost-1.39.0-9.el5.x86_64 from atrpms-stable
boost-date-time-1.39.0-9.el5.x86_64 from atrpms-stable
boost-filesystem-1.39.0-9.el5.x86_64 from atrpms-stable
boost-graph-1.39.0-9.el5.x86_64 from atrpms-stable
boost-iostreams-1.39.0-9.el5.x86_64 from atrpms-stable
boost-math-1.39.0-9.el5.x86_64 from atrpms-stable
boost-program-options-1.39.0-9.el5.x86_64 from atrpms-stable
boost-python-1.39.0-9.el5.x86_64 from atrpms-stable
boost-regex-1.39.0-9.el5.x86_64 from atrpms-stable
boost-serialization-1.39.0-9.el5.x86_64 from atrpms-stable
boost-signals-1.39.0-9.el5.x86_64 from atrpms-stable
boost-system-1.39.0-9.el5.x86_64 from atrpms-stable
boost-test-1.39.0-9.el5.x86_64 from atrpms-stable
boost-thread-1.39.0-9.el5.x86_64 from atrpms-stable
boost-wave-1.39.0-9.el5.x86_64 from atrpms-stable
munin-common-2.0.10-1.el5.noarch from epel
munin-node-2.0.10-1.el5.noarch from epel
perl-List-MoreUtils-0.33-5.el5.x86_64 from epel
perl-Net-CIDR-0.13-2.el5.noarch from epel

Dependencies Resolved

==================================================================================================== ==================================================================================================
Package Arch Version Repository Size
==================================================================================================== ==================================================================================================
Installing:
setuptools noarch 0.6c11-6.el5 atrpms-stable 403 k
replacing python-setuptools.noarch 0.6c5-2.el5

Updating:
R x86_64 2.15.2-1.el5 epel 16 k
R-core x86_64 2.15.2-1.el5 epel 36 M
R-devel x86_64 2.15.2-1.el5 epel 92 k
fakeroot x86_64 1.12.4-2.el5 atrpms-stable 75 k
fakeroot-libs x86_64 1.12.4-2.el5 atrpms-stable 30 k
libRmath x86_64 2.15.2-1.el5 epel 113 k
libRmath-devel x86_64 2.15.2-1.el5 epel 21 k
libsigc++20 x86_64 2.2.2-3.el5 atrpms-stable 51 k
perl-ExtUtils-ParseXS noarch 2.2206-1.el5 epel 33 k
perl-Parse-RecDescent noarch 1.965-1.el5 epel 195 k
rar x86_64 3.9.3-4.el5 atrpms-stable 509 k
ssmtp x86_64 2.61-19.el5 epel 54 k
testdisk x86_64 6.12-1.el5 epel 491 k
unrar x86_64 3.9.9-1.el5 atrpms-stable 98 k
webmin noarch 1.620-1 Webmin 21 M
Installing for dependencies:
ntfs-3g x86_64 2:2011.4.12-5.el5 epel 301 k
Skipped (dependency problems):
boost x86_64 1.39.0-9.el5 atrpms-stable 13 k
boost-date-time x86_64 1.39.0-9.el5 atrpms-stable 54 k
boost-filesystem x86_64 1.39.0-9.el5 atrpms-stable 69 k
boost-graph x86_64 1.39.0-9.el5 atrpms-stable 239 k
boost-iostreams x86_64 1.39.0-9.el5 atrpms-stable 43 k
boost-math x86_64 1.39.0-9.el5 atrpms-stable 804 k
boost-program-options x86_64 1.39.0-9.el5 atrpms-stable 212 k
boost-python x86_64 1.39.0-9.el5 atrpms-stable 219 k
boost-regex x86_64 1.39.0-9.el5 atrpms-stable 634 k
boost-serialization x86_64 1.39.0-9.el5 atrpms-stable 422 k
boost-signals x86_64 1.39.0-9.el5 atrpms-stable 63 k
boost-system x86_64 1.39.0-9.el5 atrpms-stable 19 k
boost-test x86_64 1.39.0-9.el5 atrpms-stable 311 k
boost-thread x86_64 1.39.0-9.el5 atrpms-stable 38 k
boost-wave x86_64 1.39.0-9.el5 atrpms-stable 491 k
munin-common noarch 2.0.10-1.el5 epel 83 k
munin-node noarch 2.0.10-1.el5 epel 424 k
perl-List-MoreUtils x86_64 0.33-5.el5 epel 75 k
perl-Net-CIDR noarch 0.13-2.el5 epel 16 k

Transaction Summary
==================================================================================================== ==================================================================================================
Install 2 Package(s)
Upgrade 15 Package(s)
 
Old 03-14-2013, 05:49 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
There, all looks good. RPM dependencies can be frustrating, but they work very very well.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg-config unable to find poppler ilnli Linux - Software 2 07-13-2011 10:58 PM
Unable to exclude with tmpwatch slcoit Linux - Software 1 03-04-2009 10:47 AM
Error upgrading with pkg-get xushi Solaris / OpenSolaris 8 04-13-2006 06:51 AM
apt question: exclude certain packages from upgrading? ice99 Linux - Software 1 09-21-2005 10:18 PM
kernel Panic slackware 10.1 (sata) after upgrading to 2.6.10 pkg in /testing sund00bie Slackware 7 07-25-2005 05:59 AM


All times are GMT -5. The time now is 08:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration