LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-17-2005, 10:03 PM   #1
Barrett
LQ Newbie
 
Registered: Dec 2005
Location: Milwaukee, WI
Distribution: Kubuntu/Gutsy
Posts: 11

Rep: Reputation: 0
unable to create or delete files on fat32 partition


On the partition where I keep most of my documents, I can read and write files but unfortunately cannot create or delete files unless logged in as root. This is inconvenient :{ The computer is dual boot with XP and Mandriva 2006 64. My fstab is below. The partition in question is in the 5th line and is called 'MotherWindows.' Any ideas? Thanks much, Barrett


/dev/sdb5 / ext3 defaults 1 1
/dev/sdb9 /home ext3 defaults 1 2
/dev/sda1 /mnt/C ntfs umask=0022,nls=utf8,ro 0 0
/dev/hda1 /mnt/F ntfs umask=0022,nls=utf8,ro 0 0
/dev/sdb1 /home/barrett/mnt/MotherWindows vfat exec,iocharset=utf8,uid=500,gid=barrett,user,rw 0 0
/dev/sdd1 /home/barrett/mnt/alubox vfat exec,iocharset=utf8,uid=500,gid=barrett,user,rw 0 0
/dev/hdb /mnt/cdrom auto umask=0022,user,iocharset=utf8,noauto,ro,exec,users 0 0
/dev/hdc /mnt/cdrom2 auto umask=0022,user,iocharset=utf8,noauto,ro,exec,users 0 0
/dev/hdd /mnt/cdrom3 auto umask=0022,user,iocharset=utf8,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=utf8,sync 0 0
none /proc proc defaults 0 0
/dev/sdb10 /tmp ext3 defaults 1 2
/dev/sdb7 /usr ext3 defaults 1 2
/dev/sdb8 /var ext3 defaults 1 2
/dev/sdb6 swap swap defaults 0 0
/dev/sdc1 /mnt/256CF vfat pamconsole,exec,noauto,noatime,iocharset=utf8,managed 0 0
 
Old 12-17-2005, 10:25 PM   #2
mebrelith
Member
 
Registered: Nov 2004
Location: Torreón, Coahuila, México
Distribution: Gentoo
Posts: 342
Blog Entries: 1

Rep: Reputation: 30
Change your line for this and it should work peachy:
Code:
/dev/sdb1 /home/barrett/mnt/MotherWindows vfat user,owner,utf8,rw,umask=000 0 0
Thats pretty much how I have it at my box (well, ok diff names of folders and such ) and it works.
 
Old 12-18-2005, 03:28 PM   #3
Barrett
LQ Newbie
 
Registered: Dec 2005
Location: Milwaukee, WI
Distribution: Kubuntu/Gutsy
Posts: 11

Original Poster
Rep: Reputation: 0
Thumbs up

Sorry for my slow reply, I had to be away from my computer for a few hours. Thanks much for your help.

Your fstab line did what it was supposed to do. It turns out, though, that the problem was that some key directories had had their permissions changed. I have no idea how that happened...

barrett
 
Old 12-18-2005, 03:44 PM   #4
Hosiah
Member
 
Registered: Sep 2004
Location: Des Moines, Iowa
Distribution: Slackware, Mandriva, Debian derivatives, +BSD/ Solaris/ Minix/ plan9/ GNU/HURD...
Posts: 185

Rep: Reputation: 30
Quote:
It turns out, though, that the problem was that some key directories had had their permissions changed. I have no idea how that happened...
Oh, I get that all the time! I move files from floppy to home directory while logged in as root, then unzip and unpack them and delete the original tarball, forgetting that each of the files created in this process still belong to root. The root access is kind of "viral" that way: Anything you touch while running in root or su mode is likely to change it's ownership to root. Some systems are more zealous about this than others.
 
Old 12-18-2005, 04:24 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
This may be off topic, but FAT32 partitions do not (ie, cannot) recognize Linux file permissions
 
Old 12-20-2005, 03:08 PM   #6
Barrett
LQ Newbie
 
Registered: Dec 2005
Location: Milwaukee, WI
Distribution: Kubuntu/Gutsy
Posts: 11

Original Poster
Rep: Reputation: 0
I don't know if the file permissions were changed in XP or linux. I had installed a new router and was marking folders to be shared over my local lan. I did this in the same partition on the same PC while it was running XP and later Linux. I have since discovered that in XP the default is that shared files are read-only for network users. I am still too newbie to have a clear grasp of how badly I may have messed up in Linux. But I was able to solve the problem in Linux with something like "chmod +w Directory".
 
Old 12-20-2005, 06:02 PM   #7
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
FAT32 partitions have no permissions wether you're in Linux or Windows - the umask option on the amount tells Linux what permissions it should pretend that the FAT32 partition has. There is also the permissions of the mount point on the Linux side - ie. the directory that it is mounted in. Sometimes if they are wrong it can stop you accessing the mounted partition and that is probably what you fixed with your chmod.
 
Old 12-21-2005, 11:26 AM   #8
Barrett
LQ Newbie
 
Registered: Dec 2005
Location: Milwaukee, WI
Distribution: Kubuntu/Gutsy
Posts: 11

Original Poster
Rep: Reputation: 0
It could be that I have a vocabulary problem. When I setup file sharing in XP, there are switches for allowing or not allowing other users read-only access or read-and-write access. Is this different than 'permissions'?

I had a umask statement with a lot of zeros in fstab, and the directories will still read-only.

There is also another bit of the story, which is that the directories that mysteriously became read-only had a soft link to my linux partition, which is, I believe, an ext partition.

Thanks for your help. It's really good to learn.
 
Old 12-21-2005, 11:42 AM   #9
linuxlastslonge
Member
 
Registered: Jun 2002
Location: Franklin, IN
Distribution: Debian, CentOS, Mac OS X
Posts: 158

Rep: Reputation: 30
this may be off topic as well, but, in reply to:

Quote:
This may be off topic, but FAT32 partitions do not (ie, cannot) recognize Linux file permissions
there is a handy application that can read ext2/ext3 partition from windows:

http://uranus.it.swin.edu.au/~jn/linux/explore2fs.htm


this is useful for transfering files without the hassle
of using cd's or floppies.
 
Old 12-21-2005, 05:19 PM   #10
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Quote:
It could be that I have a vocabulary problem. When I setup file sharing in XP, there are switches for allowing or not allowing other users read-only access or read-and-write access. Is this different than 'permissions'?
It depends what you mean by 'file sharing'. Both Windows and Linux have seperate ACLs for file shares - in Windows its set on the 'Share' tab of the properties for that folder, in Linux its set in /etc/samba/smb.conf or one of the many GUI samba frontends (Swat, Webmin Samba Module etc.). Both systems also have permissions on the underlying files as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't delete folders made by XP under unbunu on fat32 partition Tristan9669 Linux - Newbie 13 08-11-2005 08:08 PM
delete and create a partition from a terminal gjo Linux - General 8 06-14-2005 02:49 PM
Trying to create a FAT32 partition... PC Wizard Linux - Newbie 2 09-17-2004 11:18 PM
Is it possible to create a new fat32 partition without reinstalling Slack or XP? blk96gt Slackware 8 08-27-2004 12:44 PM
unable to modify files on FAT32 partition thegreatgatsby Linux - Hardware 4 05-28-2004 04:14 PM


All times are GMT -5. The time now is 02:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration