LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-23-2011, 05:48 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Rep: Reputation: 33
Unable to connect wireless


Hello.

I've installed a windows driver for the wireless card in my laptop through ndiswrapper.

I guess everything went well, because now I can see all the wireless networks in the neighbourhood.

However, when I try to connect with my own wifi network, it fails.
The wifi network is protected with WPA2-psk.

This what /var/log/messages tells me :

Code:
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) starting connection 'Auto telenet-4CA0A'
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): device state change: 3 -> 4
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): device state change: 4 -> 5
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0/wireless): access point 'Auto telenet-4CA0A' has security, but secrets are required.
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): device state change: 5 -> 6
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): device state change: 6 -> 4
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): device state change: 4 -> 5
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0/wireless): connection 'Auto telenet-4CA0A' has security, and secrets exist.  No new secrets needed.

May 21 17:45:02 eddy NetworkManager: <info>  Config: added 'ssid' value 'telenet-4CA0A'
May 21 17:45:02 eddy NetworkManager: <info>  Config: added 'scan_ssid' value '1'
May 21 17:45:02 eddy NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'
May 21 17:45:02 eddy NetworkManager: <info>  Config: added 'psk' value '<omitted>'
May 21 17:45:02 eddy NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> disconnected
May 21 17:45:02 eddy NetworkManager: <info>  Config: set interface ap_scan to 1
May 21 17:45:02 eddy NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning

May 21 17:45:07 eddy NetworkManager: <info>  (wlan0): supplicant connection state:  scanning -> associating
May 21 17:45:07 eddy kernel: ndiswrapper (iw_set_freq:332): setting configuration failed (C0010015)
May 21 17:45:18 eddy NetworkManager: <info>  wlan0: link timed out.
May 21 17:45:27 eddy NetworkManager: <info>  (wlan0): supplicant connection state:  associating -> disconnected
May 21 17:45:28 eddy NetworkManager: <info>  Activation (wlan0/wireless): association took too long.
May 21 17:45:28 eddy NetworkManager: <info>  (wlan0): device state change: 5 -> 6
May 21 17:45:28 eddy NetworkManager: <info>  Activation (wlan0/wireless): asking for new secrets
May 21 17:45:29 eddy NetworkManager: <info>  (wlan0): supplicant connection state:  disconnected -> scanning
May 21 17:45:29 eddy NetworkManager: <WARN>  get_secrets_cb(): Couldn't get connection secrets: applet-device-wifi.c.1539 (get_secrets_dialog_response_cb): canceled.
May 21 17:45:29 eddy NetworkManager: <info>  (wlan0): device state change: 6 -> 9
May 21 17:45:29 eddy NetworkManager: <info>  Activation (wlan0) failed for access point (telenet-4CA0A)
May 21 17:45:29 eddy NetworkManager: <info>  Marking connection 'Auto telenet-4CA0A' invalid.
May 21 17:45:29 eddy NetworkManager: <info>  Activation (wlan0) failed.
May 21 17:45:29 eddy NetworkManager: <info>  (wlan0): device state change: 9 -> 3
May 21 17:45:29 eddy NetworkManager: <info>  (wlan0): deactivating device (reason: 0).
The service wpa_supplicant is running. These are the messages I get when I try to restart the service (it fails) :

Code:
May 21 17:45:41 eddy kernel: ndiswrapper (iw_set_ap_address:573): setting AP mac address failed (C0010015)
May 21 17:45:41 eddy NetworkManager: <info>  (wlan0): supplicant manager state:  idle -> down
May 21 17:45:41 eddy NetworkManager: <info>  (wlan0): device state change: 3 -> 2
May 21 17:45:41 eddy NetworkManager: <info>  (wlan0): deactivating device (reason: 10).
May 21 17:45:41 eddy NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed
May 21 17:45:41 eddy NetworkManager: <info>  Trying to start the supplicant...
May 21 17:45:41 eddy NetworkManager: <info>  (wlan0): supplicant manager state:  down -> idle
May 21 17:45:41 eddy NetworkManager: <info>  (wlan0): device state change: 2 -> 3
May 21 17:45:41 eddy kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
May 21 17:45:42 eddy NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Any idea what's wrong ?
 
Old 05-23-2011, 02:57 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,569

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
It needs your wpa password. The trick is, it needs it in /etc/wpa_supplicant/wpa_supplicant.conf

read man wpa_passphrase, use it, and try again. Nobody ever tells you about wpa_passphrase :-/.
Also make sure the /etc/rc.d/init.d/network script is _not_ run. It's either/or with networkmanager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect my wireless eth1(Intel PRO/Wireless 2200 Network connetion) antonio fernandez Linux - Wireless Networking 7 01-05-2011 04:24 PM
Wire network is ok but unable to connect to wireless and wireless card is not detect vitalstrike82 SUSE / openSUSE 4 11-01-2007 07:56 AM
I can't connect to my wireless AP in FC5, why am I unable to activate my wireless. ruggersway Linux - Wireless Networking 1 05-09-2006 04:58 PM


All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration