LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2013, 06:20 AM   #1
raosr020
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Rep: Reputation: Disabled
Lightbulb Unable to connect to Server machine from a client machine using ftp service


Hi,

Could you please help me with the below issue..

I'm running RHEL6 OS on both server (192.168.0.10) and client machines (192.168.0.1).

I'm trying to connect to server from the client machine using ftp service.

I have installed vsftpd daemon on both the machines.

I'm getting the below error. Please help me with the below issues.

500 OOPS: cannot change directory:/home/server
Login failed.
ftp> ls
421 Service not available, remote server has closed connection
Passive mode refused.


[root@Client ~]# ftp 192.168.0.10
Connected to 192.168.0.10 (192.168.0.10).
220 (vsFTPd 2.2.2)
Name (192.168.0.10:root): server
331 Please specify the password.
Password:
500 OOPS: cannot change directory:/home/server
Login failed.
ftp> ls
421 Service not available, remote server has closed connection
Passive mode refused.
ftp>

Last edited by raosr020; 03-26-2013 at 06:21 AM.
 
Old 03-26-2013, 06:58 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 9,172

Rep: Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672
not enough to install vsftpd, you also need to configure it. What have you made? Do you have firewall?
 
Old 03-26-2013, 10:26 AM   #3
eklavya
Member
 
Registered: Mar 2013
Posts: 619

Rep: Reputation: 136Reputation: 136
The error
Code:
500 OOPS: cannot change directory:/home/server
Login failed.
is appeared when SELinux is enabled. Disable SElinux first using
Code:
$ setenforce 0
Restart vsftpd and try to connect again.
 
1 members found this post helpful.
Old 03-26-2013, 11:14 AM   #4
mddnix
Member
 
Registered: Mar 2013
Distribution: Redhat, Ubuntu
Posts: 525

Rep: Reputation: 141Reputation: 141
Quote:
Originally Posted by raosr020 View Post
500 OOPS: cannot change directory:/home/server
Login failed.
# system-config-firewall
and check "FTP" service

# setsebool -P ftp_home_dir on

you are done.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure client machine to connect to LDAP server decenter Linux - Newbie 4 11-26-2012 03:44 AM
Local machine trying to enable service:FaxServerServiceGroup...Could not connect to r mavijitr Linux - Newbie 0 10-11-2012 02:36 AM
[SOLVED] unable to connect to nginx server from other machine dhairya Linux - Newbie 7 07-31-2011 11:50 PM
how to use ftp to connect to remote machine vinaytp Linux - Newbie 11 04-29-2009 08:04 PM
Configuring a transparent proxy on a client machine ONLY instead of a server machine. clinux_rulz Linux - Networking 1 05-31-2006 02:53 AM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration