LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-03-2011, 10:08 AM   #1
ravi_nandula
Member
 
Registered: Sep 2011
Posts: 81

Rep: Reputation: Disabled
Unable to connect internet in ubuntu


Hi everybody.....I have installed latest version of UBUNTU in my laptop successfully and able to handle some commands too...the problem is I am not able to connect internet in ubuntu.....
My internet connect is local provide which is a LAN connection......connected through a cable.....
Help out me to connect net.....
Thanks in advance..........
 
Old 09-03-2011, 10:57 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,132

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Please post the output from the following commands.

sudo ifconfig

sudo netstat -r

cat /etc/resolv.conf

Open a konsole, run each command, copy and paste the results into this thread.

The first command will give us the IP address you are using, if there is one set.

The second command will show if you have a default gateway defined.

The third will show if you have defined DNS addresses. You need all this to defined to work.
 
Old 09-03-2011, 11:22 AM   #3
ravi_nandula
Member
 
Registered: Sep 2011
Posts: 81

Original Poster
Rep: Reputation: Disabled
For the sudo ifconfig command....I got
eth0 Link encap:Ethernet HWaddr 70:5a:b6:5b:e3:f5
inet6 addr: fe80::725a:b6ff:fe5b:e3f5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:308 errors:0 dropped:0 overruns:0 frame:0
TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22217 (22.2 KB) TX bytes:7373 (7.3 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

For sudo netstat -r i got........

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface

And for cat/etc/resolv.conf..
bash: cat/etc/resolv.conf: No such file or directory
 
Old 09-03-2011, 11:37 AM   #4
ac_kumar
Member
 
Registered: Aug 2011
Distribution: Ubuntu, Fedora
Posts: 175

Rep: Reputation: 9
is internet is connecting in windows
when u r plugging in lan wire in ubuntu is it showing any notification as network connection established.

Last edited by ac_kumar; 09-03-2011 at 12:04 PM.
 
0 members found this post helpful.
Old 09-03-2011, 03:03 PM   #5
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,132

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Quote:
cat/etc/resolv.conf..
This is a command, cat /etc/resolv.conf there has to be a space between cat the command and /etc/resolv.conf. resolv.conf is the file, in the /etc directory. Please run the command, copy and paste. Use the editing tools on the reply screen to format the output.

Quote:
For sudo netstat -r i got........
and what did this show? It should look something like this...

Quote:
netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
localnet * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default cisco 0.0.0.0 UG 0 0 0 eth0
I need to see if you have a default route set. Mine says 'cisco' for you there should be an
ip address there.
 
Old 09-06-2011, 02:29 AM   #6
salemeni
Member
 
Registered: Aug 2011
Posts: 64

Rep: Reputation: Disabled
Edit file /etc/network/interfaces
Code:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
        address 192.168.X.X
        netmask 255.255.255.0
        gateway 192.168.X.254
Edit /etc/resolv.conf put ip of your DNS
Code:
nameserver X.X.X.X
Restart network
Code:
$ sudo /etc/init.d/netorking restart
java socket

Last edited by salemeni; 01-26-2012 at 07:27 AM.
 
Old 09-06-2011, 03:46 PM   #7
sandwormusmc
Member
 
Registered: Nov 2006
Distribution: Fedora 15 x86_64
Posts: 76

Rep: Reputation: 24
Looks like your network card is "up", but doesn't have an IP ... try the following:

Code:
sudo dhclient eth0
 
Old 09-06-2011, 04:40 PM   #8
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
Quote:
Originally Posted by ravi_nandula View Post
For the sudo ifconfig command....I got
eth0 Link encap:Ethernet HWaddr 70:5a:b6:5b:e3:f5
inet6 addr: fe80::725a:b6ff:fe5b:e3f5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:308 errors:0 dropped:0 overruns:0 frame:0
TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:22217 (22.2 KB) TX bytes:7373 (7.3 KB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

For sudo netstat -r i got........

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface

And for cat/etc/resolv.conf..
bash: cat/etc/resolv.conf: No such file or directory

Do you use a static IP on windows? (Have you configured any ip for it manually or it gets dynamically?)

if dhcp server assigns an ip on your network:

issue the following command in terminal :

Code:
sudo gedit /etc/network/interfaces &
and put
Code:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
else, put

Code:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
        address "your ip address"
        netmask 255.255.255.0
        gateway "you gateway ip"
save file and close.


now restart network with

Code:
sudo /etc/init.d/networking restart
I think your network doesn't use dhcp for ip assignment.

Cheers!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to connect to internet from ubuntu sree_ec Linux - Networking 15 10-02-2010 12:48 PM
Tried to connect to internet through Wvdial in Ubuntu 10.04 unable to get connection dalfish Ubuntu 6 06-20-2010 07:29 PM
I have installed the Ubuntu os on my XP computer , but unable to connect to internet. rob007clarke Linux - Newbie 2 07-30-2009 07:47 PM
Able to connect to default Gateway, Unable to connect to internet Dumb.Coder Linux - Newbie 11 04-14-2009 04:22 AM
how do i connect my blue tooth headset to Ubuntu, it is unable to connect. salfuser Linux - Hardware 2 01-12-2009 10:28 AM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration