LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unable to configure pygobject-2.21.0 (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-configure-pygobject-2-21-0-a-788142/)

sunitverma 02-10-2010 12:39 AM

unable to configure pygobject-2.21.0
 
I've installed glib-2.2.1 on ubuntu 8.04 with the typical
./configure --prefix=/usr/; make ; make install process ,everything appeared to go fine. When running the configure script in
the pygobject-2.21.0 , it stops on an error looking for glib.

checking for GLIB - version >= 2.22.4... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: maybe you want the pygobject-2-4 branch?


how should glib be installed. I have already installed older version of glib. Will it be overwrited with new version ?

How do i suppose to overcome from the above problem ?

Please help.


Regards,

sunit verma

knudfl 02-10-2010 05:53 AM

'pygobject-2.21.0' .. .. Ubuntu 8.04.1 Hardy
 
Installing an alien glib may trash all gnome, gtk : 500 applications.

I prefer to do :
http://ftp.gnome.org/pub/GNOME/sources/glib/2.22/
> LATEST-IS-2.22.4
sudo mkdir /usr/local/glib2224/

cd glib-2.22.4/
./configure --prefix=/usr/local/glib2224/
make && sudo make install



http://ftp.gnome.org/pub/GNOME/sources/pygobject/2.21/
> pygobject-2.21.0.tar.bz2

cd pygobject-2.21.0
export LD_LIBRARY_PATH=/usr/local/glib2224/lib
./configure PKG_CONFIG_PATH=/usr/local/glib2224/lib/pkgconfig/
( + --prefix=/usr/ , if you prefer.)
make && sudo make install

No errors on Ubuntu 8.04.1 Hardy.
.....

P.S. : apt-get install python-gobject python-gobject-dev
.. will install version 2.14.1 .
http://packages.ubuntu.com/hardy/python-gobject-dev
.....

sunitverma 02-11-2010 12:42 AM

I followed the same procedure as you adviced,but still that error is occuring.

One thing i noticed,that i have installed pkg-config-0.23 which is the latest. When i browsed in it i found glib-1.2.10 which is the old version. Now the error i am getting is :

checking for GLIB - version >= 2.22.4... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: maybe you want the pygobject-2-4 branch?

Which shows that glib's version is still less than the needed, which could be possible that pkg-config still runinng with glib-1.2.10.

Can you please help me in this matter ?


Regards,

sunit verma

knudfl 02-11-2010 04:33 AM

No need to change pkg-config. The default "0.22" is OK.
May be : 1) cd pkg-config-0.23/
2) sudo make uninstall
And reinstall 0.22 with Synaptic.


Please explain, why you are not installing :
python-gobject + python-gobject-dev
.. with Synaptic.


And do not expect everything to work, when you install
non system files to a location meant for system files only.


About glib1.2 : There are two branches of glib :
a) glib1.2 > libglib1.2ldbl = old style.
b) glib2.0 > libglib2.0-0 = new style.
Both can be installed at the same time on all Linux.
.....

If you want to compile pygobject-2.21.0 : Follow the procedure
in post # 2 strictly, and you should have no problems.
Unless all those alien files in /usr/lib/ are completely
disturbing your system. I would not expect everything to work
correctly with glib-2.22.4 files in /usr/lib/.
.....


All times are GMT -5. The time now is 04:28 AM.