LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2012, 12:56 PM   #1
KnowGovCTO
LQ Newbie
 
Registered: Feb 2012
Location: Manassas, VA
Distribution: Ubuntu 11.04
Posts: 2

Rep: Reputation: Disabled
Unable to configure postgres 9.1 for remote access on Ubuntu 11.10 (GNU/Linux 3.0.0-1


I have a dedicated 32bit Ubuntu server setup with the Nuxeo Document management platform installed with the Postgres 9.1 DB. All installs were done with apt-get.

Based upon all of my research, Postgres installs working with localhost. This is fine for Nuxeo, however, I want to do some table and trigger work and as such have been trying to configure postgres to be accessed remotely.

I have installed pgadmin III (thinking this might add additional libraries on the server and ran all updates on postgresql.

Server on my network is 192.168.1.11
am attempting to connect to it with pgAdmin from a Windows 7 desktop from ip 192.168.1.22.

all of the various solutions regarding enabling access to postgres discuss modifying two files:
postgresql.conf (adding listening addresses)
pg_hba.conf (adding authentication parameters)

I have followed all of the tutorials regarding the modifications, even resorting to the "all open" approach to get it working. However, when EVER I modify the postgresql.conf (e.g. listen addresses = '*') and attempt to restart the server (through webmin 1.580), it reports "fail", however, Nuxeo is unaffected and operates correctly. Apparently Nuxeo has a subdir under postgresql and has its own conf files of which the only difference is it uses 5433 as its port..

Please note, that when I restore the conf file to its original form, it starts correctly (or at least reports no errors).

In either case, no matter what I do, I cannot get pgadmin on windows to connect to my database server.

the files I am modifying are in: /etc/postgresql/9.1/main
nuxeo has its configurations in /etc/postgresql/9.1/nuxeo


Now to my question:
Is there a "synchronization" issue between the two different conf files?? meaning, because they are not consistent it is failing??
Of course the obvious question is, am I doing something stoopid or missing something?

Regards,

Don
 
Old 02-19-2012, 06:05 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
If you attempt to start postgres from the command line do you get any more information than "fail" ?
 
Old 02-19-2012, 06:25 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,931

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Have you configured the firewall if running to allow traffic on 5432 assuming your still using the default port?

Modifying pg_hba.conf should be all that is required for access on your network. I assume that you have restarted postgresql after making changes.
 
Old 02-19-2012, 07:57 PM   #4
KnowGovCTO
LQ Newbie
 
Registered: Feb 2012
Location: Manassas, VA
Distribution: Ubuntu 11.04
Posts: 2

Original Poster
Rep: Reputation: Disabled
I thought I had it resolved (and was going to post my solution), but I had to shut everything down to do floors in the house and it is NOT working. I am just now getting back up. I will research your (kbp and michaelk) suggestions and get back.
Thanks for responding.

Regards,

Don
 
Old 02-20-2012, 01:34 PM   #5
cheesus
Member
 
Registered: Jan 2005
Location: Munich, Germany
Distribution: SuSE
Posts: 184

Rep: Reputation: 25
First of all, check if postgres is really listenting on the port you think:
# netstat -ln | grep 5432 | grep tcp
tcp 0 0 0.0.0.0:5432 0.0.0.0:* LISTEN
tcp 0 0 :::5432 :::* LISTEN

If not: postgres must be started with "-i" option to listen to remote connections at all.
(most distros come with this pre-configured of course, but it's worth checking...)

Cheers, Tom.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure Iptables to accept remote http & ftp access m_abdelfattah Linux - Newbie 3 08-04-2008 06:36 AM
LXer: How To Configure Remote Access To Your Ubuntu Desktop LXer Syndicated Linux News 0 02-14-2008 04:20 PM
How to configure Remote Access Server using Red Hat Linux 7.2 suraj Linux - Networking 1 07-22-2002 04:08 AM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration