LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-07-2010, 02:40 AM   #1
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Rep: Reputation: 16
unable to configure /boot/grub/menu.lst


I tried making some changes to /boot/grub/menu.lst file by logging in thru su but it throws following error:





[root@localhost avi]# /boot/grub/menu/lst | gedit

(gedit:4874): GnomeUI-WARNING **:

While connecting to session manager:
Authentication Rejected, reason : None of the

authentication protocols specified are supported and host-based authentication

failed.
bash: /boot/grub/menu/lst: No such file or directory

help me with the reason and solution.

Thanks in advance!
 
Old 05-07-2010, 02:56 AM   #2
Argief
LQ Newbie
 
Registered: Mar 2010
Location: South Africa
Distribution: Undecided
Posts: 28

Rep: Reputation: 0
Quote:
Originally Posted by avee137 View Post
[root@localhost avi]# /boot/grub/menu/lst | gedit
Should you not be typing /boot/grub/menu.lst

/menu/lst refers to file lst in directory /menu
 
Old 05-07-2010, 03:03 AM   #3
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Argief View Post
Should you not be typing /boot/grub/menu.lst

/menu/lst refers to file lst in directory /menu
yeah thats correct...ll try out...thanks!
 
Old 05-07-2010, 03:05 AM   #4
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Quote:
Originally Posted by avee137 View Post
I tried making some changes to /boot/grub/menu.lst file by logging in thru su but it throws following error:





[root@localhost avi]# /boot/grub/menu/lst | gedit

(gedit:4874): GnomeUI-WARNING **:

While connecting to session manager:
Authentication Rejected, reason : None of the

authentication protocols specified are supported and host-based authentication

failed.
bash: /boot/grub/menu/lst: No such file or directory

help me with the reason and solution.

Thanks in advance!
What distribution and desktop are you using?

Always give as much information when asking for help so we're more likely to be able to help with the problem.

Looking back, I see you're using Gnome which I'm not familiar with. Maybe someone with Gnome knowledge can help you.
 
Old 05-07-2010, 03:19 AM   #5
ultimate_linux
Member
 
Registered: Mar 2010
Distribution: Ubuntu 10.04,opensolaris
Posts: 30
Blog Entries: 3

Rep: Reputation: 0
sudo gedit /boot/grub/menu.lst
 
Old 05-07-2010, 04:24 AM   #6
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by tommyttt View Post
What distribution and desktop are you using?

Always give as much information when asking for help so we're more likely to be able to help with the problem.

Looking back, I see you're using Gnome which I'm not familiar with. Maybe someone with Gnome knowledge can help you.
yeah m using GNOME.could u please explain this part in the error mesg.:

"While connecting to session manager:
Authentication Rejected, reason : None of the

authentication protocols specified are supported and host-based authentication

failed"
 
Old 05-07-2010, 04:46 AM   #7
lunitix
LQ Newbie
 
Registered: Apr 2010
Distribution: Debian
Posts: 16

Rep: Reputation: 2
You are trying to open a gui app while being root .
 
Old 05-07-2010, 04:56 AM   #8
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
With distro are you using ?
With GRUB are you using GRUB 1 ore GRUB 2 ?
You see GRUB 2 do not have a menu.lst but a GRUB.cfg
Editing GRUB.cfg is not recommended .
 
Old 05-07-2010, 04:58 AM   #9
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by lunitix View Post
You are trying to open a gui app while being root .
is that forbidden?
how can i edit /boot/grub/menu.lst on CentOS?(i gt the abv error while trying the same task)
 
Old 05-07-2010, 10:23 AM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Try this:
Code:
gksu gedit /boot/grub/menu.lst
 
Old 05-07-2010, 12:18 PM   #11
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,165

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
In Fedora, I get a screenful of error messages if I try the equivalent
su
gedit /boot/grub/grub.conf
but Gedit does eventually start. The same thing happens if I try to launch Nautilus. The Ubuntu version of the Gnome session manager is obviously fussier than the Fedora one.

The obvious solution for you is not to use Gedit: try nano instead.
 
Old 05-07-2010, 12:22 PM   #12
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by ronlau9 View Post
With distro are you using ?
With GRUB are you using GRUB 1 ore GRUB 2 ?
You see GRUB 2 do not have a menu.lst but a GRUB.cfg
Editing GRUB.cfg is not recommended .
I am using win7,ubuntu and CentOS in multiboot.I have restored the ubuntu's GRUB-2 but now its not listing CentOS in the boot options.Could you please suggest the tweaks to get the same?
 
Old 05-07-2010, 02:03 PM   #13
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by avee137 View Post
I am using win7,ubuntu and CentOS in multiboot.I have restored the ubuntu's GRUB-2 but now its not listing CentOS in the boot options.Could you please suggest the tweaks to get the same?
Try in terminal the command sudo su update-grub
If it does not work post again
Restart you're computer to see if it works

Last edited by ronlau9; 05-07-2010 at 02:10 PM.
 
Old 05-07-2010, 05:30 PM   #14
pottzie
Member
 
Registered: Aug 2009
Posts: 150

Rep: Reputation: 15
Is it grub 1 or grub2?

I had a similar problem. In my situation grub2 was running from Mint and wouldn't recognize that Fedora was on my hard drive. The Fedroa forum worked on it for about a week.

http://forums.fedoraforum.org/showthread.php?t=242038

The answer came when someone realized there was a way to get grub to do the dirty work from the comand line. And yes, you can't/don't want to edit grub2!
The short, sweet and brutal solution:

"there is something called Startup Manager for Ubuntu. Maybe a graphical representation of what you want to do? Point and click menu editing? Just a thought while I was reading through my GRUB2 notes."

And that did the trick! After about a week of agonizing by what seemed like all of Fedora's team. When I ran it, Fedora was listed. It's at the last page of a post that's longer than most books in the bible!
 
Old 05-08-2010, 12:56 AM   #15
avee137
Member
 
Registered: Apr 2010
Location: bangalore,india
Distribution: ubuntu 9.10,CentOS 5
Posts: 120

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pottzie View Post
I had a similar problem. In my situation grub2 was running from Mint and wouldn't recognize that Fedora was on my hard drive. The Fedroa forum worked on it for about a week.

http://forums.fedoraforum.org/showthread.php?t=242038

The answer came when someone realized there was a way to get grub to do the dirty work from the comand line. And yes, you can't/don't want to edit grub2!
The short, sweet and brutal solution:

"there is something called Startup Manager for Ubuntu. Maybe a graphical representation of what you want to do? Point and click menu editing? Just a thought while I was reading through my GRUB2 not

And that did the trick! After about a week of agonizing by what seemed like all of Fedora's team. When I ran it, Fedora was listed. It's at the last page of a post that's longer than most books in the bible!

thanks a lot!
lemme c if it works fr me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub 1.97 beta3 , if no /boot/grub/menu.lst frenchn00b Linux - General 15 12-09-2009 02:47 AM
Why /boot/grub/grub.conf is symlinked to /boot/grub/menu.lst raj_hcl1986@rediffma Linux - Newbie 2 10-19-2008 03:19 AM
grub menu.lst Won't boot Windows XP tschima Solaris / OpenSolaris 2 07-23-2008 09:35 PM
Right way to edit /boot/grub/menu.lst ? eeried Linux - Software 2 02-07-2007 09:59 AM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 12:45 PM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration