LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to boot on vmware workstation 6.5. kernel panic (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-boot-on-vmware-workstation-6-5-kernel-panic-824851/)

kirangss 08-07-2010 08:54 PM

Unable to boot on vmware workstation 6.5. kernel panic
 
Hi everybody,
i'm unable to boot the LFS-6.6 which i've built on a vmware workstation 6.5. i had no trouble in installing all the packages and have managed to run all the test suites successfully w.r.t stable LFS-6.6. while booting i get 'kernel panic' and it says unknown device /dev/sda1 and unknow block (0,0). i've only one primary partition without any swap partition. i've a label assigned to /dev/sda1 and have included it in my fstab file. device.map shows 2 entries:
one for the floppy and the other for my harddisk which is- hd0 /dev/sda. this is for the 2nd time i'm stuck at a point after perfectly installing all the stuff as mentioned in the LFS-6.6 book. i've also noticed on this website the many users have similar type of issue. it would be great if somebody could help me.
note: while configuring the linux, i've inbuilt everything required for my system, including support for ramfs and other required filesystems, scsi driver etc.
my host machine is on a intel core 2 duo processor. my virtual scsi hard disk is 3 GB in size and is a ext3 fs. scsi is configured with LSI Logic which is recommended by vmware while adding an hard-disk.
live curious,
Kiran.

r3sistance 08-08-2010 02:26 AM

Sorry, is this a Guest OS? If so it might be worth seeing if you can boot the virtual machine in a recovery mode, single user mode or with a live distribution and seeing just how the underlying /dev/ appears to assign the hard drive. It's not always a case of the host OS assigning the virtual disc image as /dev/sdaX (I know xen for example uses /dev/xvdaX by default) so that would be my first suggestion.

kirangss 08-09-2010 05:50 AM

2 Attachment(s)
Quote:

Originally Posted by r3sistance (Post 4059530)
Sorry, is this a Guest OS? If so it might be worth seeing if you can boot the virtual machine in a recovery mode, single user mode or with a live distribution and seeing just how the underlying /dev/ appears to assign the hard drive. It's not always a case of the host OS assigning the virtual disc image as /dev/sdaX (I know xen for example uses /dev/xvdaX by default) so that would be my first suggestion.

Thank you for your reply. I've tired booting in recovery mode, but it doesn't help. I'm using the lfslivecd-x86-6.3-r2160.iso as my host.
under the host system, sda is under /dev. My host system has no problem in booting up. Pls view the snapshot 'recovery-mode' under attachments which is the result tring recovery mode.
Let me be more clearer this time:
VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root-" boot options; ...

Please refer to the screenshot attached 'while booting.kernel.panic' under attachments.
THIS IS HOW MY /etc/fstab file look like:
# Begin /etc/fstab

# file system mount-point type options dump fsck order
# ============ =========== ===== ======= ==== =========
/dev/sda1 / ext3 defaults 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devpts /dev/pts devpts gid=4,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0

# End /etc/fstab


Under 'file system' I've tried various options like using the LABEL=<label> and UUID=<uuid> but doesn't help.


'blkid':
/dev/loop0: UUID="0e10971e-e20f-4638-b5bf-9010e22bd034" TYPE="ext2"
/dev/loop1: TYPE="DM_snapshot_cow"
/dev/sda1: LABEL="bootme" UUID="1e8fb2a4-2841-4044-89a8-c2a413e011d2" TYPE="ext3"
/dev/mapper/lfs-cd: UUID="0e10971e-e20f-4638-b5bf-9010e22bd034" TYPE="ext2"
/dev/sdc1: SEC_TYPE="msdos" LABEL="SK" UUID="F8CE-C51E" TYPE="vfat"

/boot/grub/grub.cfg file contains:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
set default=0
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "GNU/Linux, with Linux 2.6.34.1-lfs-6.6" {
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 1e8fb2a4-2841-4044-89a8-c2a413e011d2
linux /boot/vmlinux-2.6.34.1-lfs-6.6 root=/dev/sda1 ro
}
menuentry "GNU/Linux, with Linux 2.6.34.1-lfs-6.6 (recovery mode)" {
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set 1e8fb2a4-2841-4044-89a8-c2a413e011d2
linux /boot/vmlinux-2.6.34.1-lfs-6.6 root=/dev/sda1 ro single
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###


contents of device.map:
(fd0) /dev/fd0
(hd0) /dev/sda


contents of /etc/inittab:
# Begin /etc/inittab

id:3:initdefault:

si::sysinit:/etc/rc.d/init.d/rc sysinit

10:0:wait:/etc/rc.d/init.d/rc 0
11:S1:wait:/etc/rc.d/init.d/rc 1
12:2:wait:/etc/rc.d/init.d/rc 2
13:3:wait:/etc/rc.d/init.d/rc 3
14:4:wait:/etc/rc.d/init.d/rc 4
15:5:wait:/etc/rc.d/init.d/rc 5
16:6:wait:/etc/rc.d/init.d/rc 6

ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

su:S016:once:/sbin/sulogin

1:2345:respawn:/sbin/agetty tty1 9600
2:2345:respawn:/sbin/agetty tty2 9600
3:2345:respawn:/sbin/agetty tty3 9600
4:2345:respawn:/sbin/agetty tty4 9600
5:2345:respawn:/sbin/agetty tty5 9600
6:2345:respawn:/sbin/agetty tty6 9600

# End /etc/inittab



ANY HELP??

kirangss 08-10-2010 08:01 PM

issue with vmware
 
I had to change my harddisk type to IDE as vmware wasn't detecting a SCSI hard disk. The issue was also with the bzimage or vmlinux, the linux kernel image. i went through the .config file of a working linux os and made the require changes. now my LFS-6.6 is bootable and independent :). now looking forward for BLFS.
live curious,
Kiran.

rhajdaj 11-25-2011 01:55 AM

To fix this without changing to an IDE disk (keep SCSI), make sure the following options are enabled in the kernel config:

Device Drivers --->[*] Fusion MPT device support --->
<*> Fusion MPT ScsiHost drivers for SPI
<*> Fusion MPT ScsiHost drivers for FC
<*> Fusion MPT ScsiHost drivers for SAS

If you enable these on top of the "make defconfig" kernel, it should work.
Note that I'm using VMWare Player 3.1.4 and Linux 2.6.37.2.


All times are GMT -5. The time now is 11:02 AM.