LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to boot into Windows after installing Fedora 10. (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-boot-into-windows-after-installing-fedora-10-a-701330/)

hijacktheleft 01-31-2009 05:30 PM

Unable to boot into Windows after installing Fedora 10.
 
After installing Fedora, I am able to get to my Windows C:\ and see all my files. After I created the free space for Fedora but before I installed it, I was able to reboot and get into Windows. Now I can't. Fedora's boot screen gives me the option to boot into either Fedora or Other, with Other being my system restore partition. Fedora and Windows are on different partitions on the same hard drive, so when I use my BIOS boot options, it still just goes right to Fedora. Now, like I said, I can see all the files on my Windows partition, so I know I didn't format over it, but it's like something rendered the Windows partition non-bootable.






Here's my menu.lst info:


# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.12-170.2.5.fc10.i686)
root (hd0,2)
kernel /vmlinuz-2.6.27.12-170.2.5.fc10.i686 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.27.12-170.2.5.fc10.i686.img
title Fedora (2.6.27.5-117.fc10.i686)
root (hd0,2)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=e761a689-9c50-4b37-95a4-c6d0db1af070 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img
title Other
rootnoverify (hd0,1)
chainloader +1






and here's my partition info

Code:

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x14cb14cb

Device Boot Start End Blocks Id System
/dev/sda1 * 574 33039 260783145 7 HPFS/NTFS
/dev/sda2 1 573 4602591 b W95 FAT32
/dev/sda3 33040 33064 200812+ 83 Linux
/dev/sda4 33065 38913 46982092+ 5 Extended
/dev/sda5 33065 38913 46982061 8e Linux LVM

Partition table entries are not in disk order

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xceb2ceb2

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 19457 156288321 7 HPFS/NTFS





Windows is on the sda1. I tried changing the rootnoverify in the menu.lst to (hd0,0) but that only gave me another Linux option in the boot menu. I'm not sure where to go from here. It wouldn't really be THAT big of a deal, if it wasn't for my other problems I'm having... which are in different posts. Thank you in advance for your help.

syg00 01-31-2009 06:01 PM

Quote:

Originally Posted by hijacktheleft (Post 3427669)
Windows is on the sda1. I tried changing the rootnoverify in the menu.lst to (hd0,0) but that only gave me another Linux option in the boot menu.

Explain this statement - exactly. Does it add another entry to the initial boot menu, or bring up another (separate) boot menu ?.
Changing the rootnoverify should have worked providing you didn't (accidently) "hit" the windoze partition.

hijacktheleft 01-31-2009 06:21 PM

Once I changed the rootnoverify value, I got:

Fedora (2.6.27.12-170.2.5.fc10.i686)
Fedora (2.6.27.5-117.fc10.i686)
Other

in the boot menu. I can't tell the difference between the two Linux options, and the Other option still takes me to the System Restore partition.

r3sistance 01-31-2009 06:36 PM

I am betting Windows will be on (0,0). Since Windows likes to steal this posistion. Just add an entry like...

title Windows
root (0,0)

I can't check if that's exactly as this should be as I am not at home where I have a system with this set-up.

yancek 01-31-2009 07:09 PM

Your first post shows the menu.lst entry for windows as (hd0,1) which is the same as sda2, your restore partition. Since you indicate windows is on sda1, you need to change that entry to "rootnoverify (hd0,0).

hijacktheleft 01-31-2009 09:50 PM

I did change it to (hd0,0) and that's when I got:

Fedora (2.6.27.12-170.2.5.fc10.i686)
Fedora (2.6.27.5-117.fc10.i686)
Other

with Other still being the System Restore for XP.



I managed to get into Windows. I went into the Yum extender and uninstalled Alsa based on somebody else's recommendation, and that removed a bunch of other stuff too, which rendered Fedora almost useless. Every time I tried to do anything, I kept getting error messages. I couldn't open anything. I couldn't even press ctrl-alt-del. So I hard booted, and the machine booted right into Windows. No Fedora menu or anything.

That's not really the result I had hoped for, but with the other issues I was having, I guess it works for now. I think I'm going to reformat my Linux partition and reinstall Fedora. Since I'm not the only user of this system, I wanted to go with Ubuntu since it's a little more user friendly... and I have sound with it, but my mouse only likes to work for a minute or so with that, as opposed to the hour I get with Fedora.

I have a couple other posts about those issues, which are the more important ones to me. I really appreciate your help, and any help I could get with the mouse and audio issues would be awesome.

Thanks!

tommcd 02-01-2009 12:57 AM

Try changing your Windows entry in grub's menu.lst to this:
Code:

title          Microsoft Windows
root            (hd0,0)
savedefault
makeactive
chainloader    +1

This is from Ubuntu's grub on my computer. Windows is on the first partition /dev/sda1 on my computer. If your Windows is on /dev/sda1 (as indicated by the output of fdisk you gave in your first post) it should work.


All times are GMT -5. The time now is 10:36 PM.