LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2014, 11:30 PM   #31
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled

Yes, with 2 problems: It appears to be mounted as a removeable drive, rather than a permanent 2nd drive. The "Devices" list shows it once as a removeable drive, and again as a permenant drive, but it won't let me in here. I can access the folders and files in the entry that shows the Eject button next to it, except the Lost & Found folder. this shows a padlock and says I don't have permissions to access it. I've never set up any sort of lock, so why the lock is there is a mystery to me. I expect when I reboot, I will again have to mount the drive manually.

This is progress, and I'm grateful for your time.
 
Old 03-16-2014, 08:46 AM   #32
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
Yes, I'm able to get to these folders & files. except the "Lost & Found" which says I don't have permissions to access. That's the folder where the system said it was putting my recovered Windows apps & files. After I rebooted, however, I'm still having to manually mount the 2nd drive again. Much of this fiasco started with me trying to get the system to mount it automatically. Each time I boot up, I get an error screen saying it is unable to mount /media/win and asking to skip or manually mount. If I choose the manual option, it gives me a command prompt of root@douglas, but then I don't know what command to use there, so I just Skip it. I'm able to manually mount it with the Disk Utility, but that's a bit of a pain.
At one point you referenced "how" but it wasn't in context. What I was trying to say is I wanted to post a screen shot of what I'm seeing. I'm able to do the PrtSc OK, but cannot paste it here. Either I'm missing a step as I don't usually use that function, or screen shots aren't allowed here. One of these was the Gparted graphical datayou asked for earlier.
 
Old 03-16-2014, 04:38 PM   #33
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
I'm able to do the PrtSc OK, but cannot paste it here. Either I'm missing a step as I don't usually use that function, or screen shots aren't allowed here.
In my system it saves to desktop, but yours may save to photos or documents use the filemanager to find it, when you know it's location you choose upload option on LQ Go Advanced option.
 
Old 03-16-2014, 06:01 PM   #34
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
For ColorPurple, thanks to Eddy1's help, here are the screen shots I think will help. Again, I'm able to mount the drive, but only as a removeable drive (e.g. /media/win) . I'd like to have it always available when the system boots up, under My Computer, along with the primary drive (Home). Then the next question would be how to unlock the Lost & Found folder. Thanks.
Attached Thumbnails
Click image for larger version

Name:	Screenshot from 2014-03-15 17:38:55.png
Views:	13
Size:	25.2 KB
ID:	14982   Click image for larger version

Name:	Screenshot from 2014-03-15 17:34:41.png
Views:	11
Size:	54.0 KB
ID:	14983  
 
Old 03-16-2014, 06:25 PM   #35
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Have you added it to your /etc/fstab?
Show output of
Quote:
cat /etc/fstab
 
Old 03-16-2014, 09:47 PM   #36
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
No, I haven't done that. As a novice to Linux, I'm learning, little by little, how this system and the commands work. Here is the output you asked for:
douglas@Douglas:~$ cat /etc/fstab
UUID=83881945-3aac-49b2-8244-7d38924f6bee / ext4 errors=remount-ro 0 1
UUID=7b4d1d1e-c64a-4397-9ecf-3d7893a2b661 swap swap sw 0 0
UUID=c8ba8858-1929-4ac6-9b46-63abb6d1c2da /media/Win ntfs-3g user,users,gid=users,umask=002 0 0
douglas@Douglas:~$

By whatever method is correct for this, I want to change the 3rd line so the 2nd (Win) drive mounts like the main (Home) drive, not as removeable media. I tried to fix this myself a couple of months ago and messed it up, so I'm a bit gun-shy to try on my own again.

As with Gold Finger and ColorPurple, I appreciate your efforts to help me.
 
Old 03-16-2014, 11:15 PM   #37
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Do you have 2 wins drives, because 1 is showing in fstab
 
Old 03-17-2014, 05:56 AM   #38
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
No, jut 2 drives. Both are are Western Digital 1T, the 1st being the main "Home", boot drive & the other is a 2nd internal drive with all my old stuff copied from my XP box. ubuntu recovered the windows stuff and put it into a Lost & Found folder, then locked it and won't let me at it. That folder losk is the next problem to tackle. I'd like the 2nd drive to mount automatically, just like the Home, boot drive, so I don't have to go through a manual mount every time I boot up.

Thanks for being willing to help.
 
Old 03-17-2014, 03:57 PM   #39
gold_finger
Member
 
Registered: Jan 2014
Distribution: Mint Xfce, Voyager, SolydK
Posts: 50

Rep: Reputation: 12
Not trying to ruffle anyone's feathers by re-entering thread, but I think I may be able to help.

Focusing solely now on your second disk with Windows data.

Originally, you had 2 lines in /etc/fstab for automounting -- which was wrong. Also, because of labeling of mount point, I (we) thought it was an NTFS filesystem, but was being mounted as Ext4. You explained why here:
Quote:
Originally Posted by DPNoyes
Your observation about the Win Data label is mostly correct. Firstly, I should have mentioned that this is a 2nd internal drive. Both are 1TB. The 2nd Drive was my Windows backup drive, so it has all my Windows data from the old computer. Using a utility of which I've forgotten the name, I changed its format to ext4, in the belief that ubuntu would be able to find it. I simply titled it Win Data for my reference. That may have been an error on my part, but I was able to manually mount it after that. Another utility ran and found all the files on it and put them into a locked folder called Lost & Found, that I can't get into, but that's a problem down the list.
[There was no need to convert from NTFS because Linux can read/write NTFS filesystems w/o issue; but too late now -- it was converted and files (apparently) recovered to "Lost & Found".]

Then, you corrected /etc/fstab entry causing boot problem and replaced the two prior entries for the Windows data drive with the following:
Code:
UUID=c8ba8858-1929-4ac6-63abb6d1c2da /media/Win ntfs-3g user,users,gid=users,umask=0002 0 0
However, that applies to NTFS not Ext4 (which is what you had converted drive to), leading to the result:
Quote:
Originally Posted by DPNoyes
It worked, but with error messages. There was a screen about being unable to mount the 2nd drive asking whether to skip or mount manually.
Your output from fdisk and gdisk commands then showed that the partition was now showing up as an ESP (EFI System Partition). How that happened, I have no idea! (An ESP is a boot partition for GPT partitioned disks on computers using UEFI firmware and is typically only 200-550MiB's in size.)

From what you have stated after this point, it appears that (luckily) the filesystem on that drive was not converted from Ext4 to something else (FAT32 on ESP's) which would possibly have caused loss of data.


Here's my thoughts now on what may solve problem. Anyone else have a better idea, feel free to post it. Pick whoever's solution you want, DPNoyes.

Get rid of that new entry in /etc/fstab, then reboot computer to make sure don't get any mounting error messages -- the 2nd drive should no longer be automounted. DO NOT click on any drive icons/listings to manually mount it during following instructions. (To eliminate possible typo's, just copy/paste commands from here into terminal.)

Open /etc/fstab and delete line noted above for the data partition
Code:
gksudo gedit /etc/fstab
Delete line for the data partition, save file, close gedit and terminal, then reboot.

You shouldn't have any error messages on bootup now. (If you do, report back with details before proceeding.)

Open terminal and run this command just to confirm that the data partition (sdb1) is not mounted anywhere:
Code:
lsblk
Make sure it shows nothing under "MOUNTPOINT" column next to /dev/sdb1. If it does, stop and report back with that output.

Since you want the data on that partition to be more easily found, get rid of the old mount point and make a new one for the partition under your home directory. (Substitute your actual username where I have "username" below.)

Remove old mount
Code:
sudo rmdir /media/Win
Make a new one
Code:
mkdir /home/username/Windows
Mount the partition to the new mount point
Code:
sudo mount /dev/sdb1 /home/username/Windows
Make sure everything set to you as owner instead of root
Code:
sudo chown -R username:username /home/username/Windows

Now open /etc/fstab again and make a new entry for the partition to automount on startup.

Just to be sure, run blkid command and make sure the UUID matches what I have below. (If not, change mine to what is shown from blkid command for sdb1.)
Code:
sudo blkid
Open /etc/fstab file
Code:
gksudo gedit /etc/fstab
Add these lines to the end substituting your username where appropriate.
Code:
# Mount Windows data partition to /home/username/Windows
UUID=c8ba8858-1929-4ac6-63abb6d1c2da /home/username/Windows           ext4    defaults        0       2
Save file and close gedit.

Close terminal and reboot computer.

Open your home directory and you should find contents of data partition in "Windows" folder. I'm not familiar with Ubuntu's Unity interface and Nautilus file manager, but would imagine you can drag and drop the folder onto "Places" to have it also show there if you want.

Good luck.
 
Old 03-17-2014, 04:43 PM   #40
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,905

Rep: Reputation: 262Reputation: 262Reputation: 262
@ gold_finger, your suggestion works for me.
 
Old 03-17-2014, 06:55 PM   #41
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
Thank You, Gold Finger for rejoining. Don't worry about ruffling my feathers. I figure I'm being a thorn to you guys, for your efforts walking me through this process. Your first thought was spot on. The mounting error screen vanished. As a "Just In Case", I commented out the 3rd line about the 2nd drive with a #, and it worked. I did fine following your instructions, up to the point of changing the ownership if the drive (chown). It doesn't want to accept that. I tried a couple of times, but it wouldn't have it, nor has the fstab file changed.

Tell me what you need to see, and I'll get it posted ASAP.
 
Old 03-17-2014, 06:58 PM   #42
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
I forgot to mention (due to an interrupting phone call) that it's not out of the question for me to move this files to the primary drive, reformat the secondary as Ext4 and move them back, if you think that might simplify things. At this point, at least, I have plenty of drive space to work with, until I start getting more work projects running.
 
Old 03-17-2014, 07:55 PM   #43
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,905

Rep: Reputation: 262Reputation: 262Reputation: 262
What was the error message when you ran chown?
 
Old 03-17-2014, 08:18 PM   #44
DPNoyes
Member
 
Registered: Jan 2014
Location: St. Paul, MN
Distribution: ubuntu 12.04 w/Cinnamon
Posts: 30

Original Poster
Rep: Reputation: Disabled
I had a few typos in this, so it's partly my fault, but near the bottom, I believe I got i t right. For some of this, it simply didn't respond. Here's the Terminal Window data, complete with my typos:
douglas@Douglas:~$ gksudo gedit /etc/fstab
sudo chown -R douglas:douglas /home/douglas/Windows
douglas@Douglas:~$ sudo chown -R douglas:douglas /home/douglas/Windows
gkeditdouglas@Douglas:~$ gkedit gedit /etc/fstab
No command 'gkedit' found, did you mean:
Command 'gredit' from package 'routeplanner-gnome' (universe)
Command 'gedit' from package 'gedit' (main)
gkedit: command not found
douglas@Douglas:~$ gedit /etc/fstab

** (gedit:2574): WARNING **: Could not load theme icon gtk-home: Icon 'gtk-home' not present in theme
sudo chown -R douglasouglas /home/douglas/Windows
douglas@Douglas:~$ sudo chown -R douglasouglas /home/douglas/Windows
chown: invalid group: `douglasouglas'
douglas@Douglas:~$
 
Old 03-17-2014, 10:22 PM   #45
gold_finger
Member
 
Registered: Jan 2014
Distribution: Mint Xfce, Voyager, SolydK
Posts: 50

Rep: Reputation: 12
Not sure what you did, but suspect your /etc/fstab file is now messed up. If you have not shut down the computer -- good! If you have and it now won't reboot, use your live USB/DVD to boot and post back when you're ready. DO NOT try to follow steps below if booted from live USB/DVD. (You'll need to start with different steps for that.)

You need to go slowly and follow the steps in the proper order. Have feeling you went out of order on one or more steps and now have a completely useless /etc/fstab file. Assuming you're still booted into the system and haven't shut it down, let's back-track a bit and go step by step.

Open your file manager and make sure you are in /home/douglas.

Do you see a folder called "Windows" (no quote marks) there?

If "yes, I do have a Windows folder", double-click on it to open it.
Are your files listed inside Windows folder?
If "no", close the file manager. Open a terminal and execute the umount command below; then go to step #1 below
If "yes", close the file manager and go to step #2 below
If "no, I don't have a Windows folder", you need to make the Windows directory. Close the file manager, then open a terminal and enter:
Code:
mkdir /home/douglas/Windows
Now, just in case you mounted it somewhere else, enter command to un-mount the partition. (Ignore error message if it wasn't mounted anywhere already.)
Code:
sudo umount /dev/sdb1

STEPS AFTER ABOVE PRELIMINARIES:

1. Mount the data partition at the Windows directory you created.
Code:
sudo mount /dev/sdb1 /home/douglas/Windows
2. Make sure you are the owner of everything under that mount point.
Code:
sudo chown -R douglas:douglas /home/douglas/Windows
3. Make a backup copy of /etc/fstab that you have now
Code:
sudo mv /etc/fstab /etc/fstab.old
4. Create a brand new one. This will start gedit showing a blank page with the filename "/etc/fstab".
Code:
gksu gedit /etc/fstab
5. Copy/Paste all of this at once into the file and hit the save button along top of gedit interface.
Code:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# Mount root partition
UUID=83881945-3aac-49b2-8244-7d38924f6bee / ext4 errors=remount-ro 0 1
# Mount swap
UUID=7b4d1d1e-c64a-4397-9ecf-3d7893a2b661 swap swap sw 0 0
# Mount Windows data partition to /home/douglas/Windows
UUID=c8ba8858-1929-4ac6-63abb6d1c2da /home/douglas/Windows  ext4  defaults  0  2
6. Close gedit. Then close the terminal. Then reboot computer.

Everything should work now.

Last edited by gold_finger; 03-17-2014 at 10:33 PM. Reason: Added one more qualification to a step. And one minor correction.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot boot into Ubuntu after installation of windows on 2nd hdd azteka22 Ubuntu 2 12-03-2009 10:37 PM
Encrypt 2nd drive without 2nd boot time passphrase: How? gargamel Slackware - Installation 15 05-30-2009 03:50 PM
how do i connect my blue tooth headset to Ubuntu, it is unable to connect. salfuser Linux - Hardware 2 01-12-2009 11:28 AM
Installed OpenSuse 11.1 on my 2nd hard drive, unable to boot cyborg939 Linux - General 3 01-11-2009 04:09 PM
Lost ubuntu on 2nd drive-how to remove boot loader? BACTRATE Ubuntu 2 06-06-2008 04:26 PM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration