LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-28-2007, 05:53 PM   #1
santhosh23
Member
 
Registered: Oct 2006
Posts: 40

Rep: Reputation: 15
unable install atk-1.9.0


Hi.

I am trying to install atk-1.9.0 pkg but i am getting an error :

checking for GLIB - version >= 2.5.7...
*** 'pkg-config --modversion glib-2.0' returned 2.12.9, but GLIB (2.12.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

I get the above error...could some tell me how to fix this.

Note :

[root@localhost /]# env
HOSTNAME=localhost.localdomain
SHELL=/bin/bash
TERM=xterm
HISTSIZE=1000
SSH_CLIENT=192.168.1.147 1626 22
OLDPWD=/usr/local/include
SSH_TTY=/dev/pts/0
USER=root
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi= 01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00 ;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz =00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;3 5:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
MAIL=/var/spool/mail/root
PWD=/
INPUTRC=/etc/inputrc
LANG=en_US.UTF-8
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
HOME=/root
SHLVL=2
LOGNAME=root
SSH_CONNECTION=192.168.1.147 1626 192.168.1.46 22
LESSOPEN=|/usr/bin/lesspipe.sh %s
PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
G_BROKEN_FILENAMES=1
_=/bin/env


[root@localhost /]# find / -name pkgconfig
/usr/share/pkgconfig
/usr/local/lib/pkgconfig
/usr/lib/pkgconfig


[root@localhost /]# find / -name glib
/usr/local/share/gtk-doc/html/glib
/usr/local/include/glib-2.0/glib
/download/glib-2.12.9/glib
/download/glib-2.12.9/docs/reference/glib


Can someone help me in fixing it.


I got this fixed.


##############################################################################################


I successfully atk pkg but when i tried to install gtk pkg...

i get the following error:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met:

No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.


could please suggest me on this issue.

Note : [root@localhost gtk+-2.10.9]# rpm -qa |grep pango
pango-1.14.8-1.fc6


[root@localhost gtk+-2.10.9]# rpm -qa |grep cairo
cairo-1.2.6-1.fc6
pycairo-1.2.0-1.1



could please suggest me on this issue.

Last edited by santhosh23; 01-28-2007 at 06:54 PM.
 
Old 01-28-2007, 10:54 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
You have to install the development packages for cairo and pango. They'll end with -dev or -devel. But, if you're using a package manager, why not just use rpm to install Gtk2?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help; can't install atk-1.9.0 for gnomad, glib problem avidwriter Linux - Software 14 04-17-2005 09:19 PM
Help!!! How to install GLib, GTK, ATK and Pango, just to get Firefox running. LOL RJARRRPCGP Linux - Newbie 7 11-20-2004 06:42 PM
ATK programming goelvish Linux - Software 0 08-25-2004 03:38 AM
atk problem pasalacqua128 Linux - Software 0 06-01-2004 06:57 PM
glib and atk chrismiceli Linux - General 2 02-08-2003 02:10 AM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration