LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-24-2007, 10:43 PM   #1
On2ndThought
LQ Newbie
 
Registered: Apr 2007
Posts: 13

Rep: Reputation: 0
Un-Installing Grub?


First and foremost, please allow me to apologize if this is in the wrong forum. I *did* read the suggestions on which types of posts should go in which forums, but since this question involves Grub (which I'd never seen or heard of before installing Linux), I thought perhaps this may be an appropriate forum.

OK, now some background.

This past weekend I went to a LUG, intending to install any suggested distro on my Compaq Presario system. Unfortunately, after 5 different distros crashed while trying to load the installer, we became a bit desperate. That's when someone came up with a paid-for enterprise version of SUSE (SUSE Linux Enterprise 10.2) To our excitement, it installed the full distro. Unfortunately, it then crashed when trying to reboot into Linux. So, at the time I left, I had a distro installed, but nothing working. I also (stupid me) failed to get any phone numbers or email addresses to follow up with.

Next, I should explain that the Compaq was configured with 2 drives. The first (master) was 80GB, including Win XP, and 3 other misc partitions. The second (slave) was an old 10GB, and that was were I installed SUSE.

Once I got home, I yanked both drives out of the Compaq, and installed them into an older (much slower) computer that I had laying around. Much to my delight, everything booted up perfectly! I had a few anxious moments while yast asked me questions relating to how to configure the installation, but I just used what made sense, and soon I had it up and running. <Yea!!>

Next, I yanked out the 80GB drive, and that was my first exposure to Grub barfing when the hardware did not match the configuration on which the distro was installed. But, I persevered. I reinstalled the 80GB, and Googled around until I found some instructions that made sense. The result, I found and edited Grub's menu.lst file, and voila, up came my 10GB without the 80GB anywhere in site. (Yea!) Nothing like the feel of solving your own problems!

Ok, so far this is a success story. But here's the problem. When I went to re-install the 80GB back into it's original machine, up came Grub and locked up the boot. I've Googled around and found utilities like Grub4Dos, and WinGrub, but things aren't just real clear about how I'd use these to solve my problem. As of now, the only way I can boot back into Windoze, is to combine the two drives again into one machine, and use the Grub menu.

In reading around, I get the feeling that when SUSE was installed, Grub might have done something with the MBR on both drives. That might explain why the 80GB craps out while trying to start up solo. I'm guessing the MBR on the 80GB is looking for menu.lst on the 10GB, and when it doesn't find it, it just hangs. Maybe I haven't looked hard enough, but so far, in the looking around that I've done to find out more about Grub, I've not found anything that helps me to un-install it from the MBR.

For what it's worth, I'm not dead set on totally removing Grub from the 80GB. I can think of several reasons I might want to keep it handy. But as things sit now, I'm afraid that I simply lack the knowledge of how to make Grub work *for* me on the 80GB rather than against me. I worry that, due to simple ignorance and lack of experience, I may corrupt the MBR, and then I'm really FUBAR'd, cuz I don't have a Windoze install disk, and ultimately I might have to reformat the HD and lose all my stuff.

So, now that I've explained what I've done, and what I want (the two drives booting properly in their separate machines), I wonder if there is ANYONE who can either tell me exactly what to do to my 80GB, or, point me to a resource that explains it in simple terms for newbies? (Yes, I agree, formating and riding it of Windoze *is* a "simple" solution, but not one I can use for now. )

My apologies again if this is posted in the wrong forum. And also sorry if I've been a bit long winded. But I wanted to explain why I ended up at the point where I am now, and why I don't have anyone locally I can call.

Thanks in advance for any advice and suggestions.

Brian

Last edited by On2ndThought; 04-24-2007 at 10:48 PM.
 
Old 04-24-2007, 11:41 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,000
Blog Entries: 11

Rep: Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892Reputation: 892
To get rid of grub in the MBR just go and boot of a DOS
disk and do fdisk /mbr ... if you only newer windows boot
disks a fdisk /newmbr should do the trick.


Cheers,
Tink

P.S.: Welcome to LQ, and you sound like a good candidate
to hang on to Linux ;} thirst for knowledge and perseverance
are excellent drivers to come a long way with Linux.
 
Old 04-25-2007, 01:14 AM   #3
On2ndThought
LQ Newbie
 
Registered: Apr 2007
Posts: 13

Original Poster
Rep: Reputation: 0
Talking Newbie, heal thyself!

Thanks for the suggestion Tink.

Unfortunately, in some ways I'm way underprepared for doing even the simplest things. I picked this Compaq up at a clearance sale. Bought it "as-is". No Windoze install disk. Not even a keyboard or mouse when I bought it. So I didn't get anything like a bootable disk. Nor do I (yet) know how to create one. The machine has no floppy drive, and although it has a CD+-RW, I'm clueless on how to create a boot CD. Nevertheless, I really appreciate you taking the time to offer a solution.

On the plus side though, after posting my question, I Googled around some more, and then had a brainstorm. Went to download.com, searched for "MBR Repair", and found the file MBRFix. Read the comments posted by others (funny thing, several had virtually the same problem with wanting to get rid of Grub after removing Linux from their computer), downloaded it, backed up my MBR, and typed in the following:

mbrfix /drive 0 fixmbr

It did the job in about a half a second. Then I powered down, removed the 10GB, and the 80GB came up like a champ! No More Grub! <Yea!>

So, for those who may have a similar problem in the future, I offer this link.

http://www.download.com/MbrFix/3000-...ml?tag=lst-0-1

And, of course, the standard disclaimer, use at your own risk. Always back up important data before attempting to mess with your MBR. Don't sue me or LinuxQuestions if you lose everything. And of course, your milage may vary.

Hope this info helps someone in the future!

Last edited by On2ndThought; 04-25-2007 at 12:15 PM.
 
  


Reply

Tags
dual boot, grub config, suse10, winxp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing GRUB 2, grub-install problem r00tb33r Linux - Software 1 02-26-2007 10:42 PM
Installing my own GRUB - HELP PLEASE!!! stevesk Linux - Software 2 12-17-2004 12:20 PM
Why grub prompt after installing Grub inder Debian woody 3.0r2? velan Debian 1 04-20-2004 05:55 AM
installing grub amatin Linux - Software 5 12-04-2003 12:45 PM
Installing Grub Itzac Linux - Software 3 06-18-2003 02:42 AM


All times are GMT -5. The time now is 03:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration