LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2003, 02:47 PM   #1
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Rep: Reputation: 15
Talking Uhuu... finally got my 1st Kernel working but


I'm a fresh newbie... so happy to have succeeded in compiling and loading my first kernel and moving from RH 2.4.18 to 2.4.21 (tar file) after many many deceiving attempts

Now, when I enter "df -all", I notice that my /boot is no longer there (it used to be mounted on /dev/hda2 while using RH 2.4.18)

And entering "ls /boot", returns ONLY one file "kernel.h". I'm wondering where all those files such as "System.map" & "vmlinuz" went.

Did I forget to add a line in my "grub.conf"?

But my root "/" is properly mounted on /dev/hda3 though

Any tips?


Thx!
 
Old 08-28-2003, 03:34 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
What filesystem do you use for /boot? Maybe its support is not compiled into the kernel? Look into starting logs, there should be something here (I understand you have /boot in /etc/fstab).
 
Old 08-28-2003, 08:02 PM   #3
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Original Poster
Rep: Reputation: 15
Yes you're right, I didn't have the EXT3 journal compiled in the kernel. It works now!

Thanks a bunch!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wlan finally working, but... andy_lee Linux - Wireless Networking 2 08-25-2005 10:31 AM
2.6.12 kernel compiled and working... finally! CPUFreak91 Linux - General 2 08-10-2005 10:42 PM
FINALLY compiled a working kernel! darksmiley LinuxQuestions.org Member Success Stories 3 10-12-2004 07:16 PM
got 2.6 working.. finally zigmund555 Slackware 0 10-17-2003 08:28 PM
Finally got most things working, but a couple of Qs... Rand Linux - Newbie 3 12-14-2002 02:57 AM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration