LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-21-2012, 07:08 PM   #1
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Rep: Reputation: 1
UDEV rule for AVR Dragon in Fedora 16


Hi!

I am trying to make a rule for the avr dragon, in order to be able to use avrdude without being root.

After a bit of googeling i found that this rule worked in Fedora 10

/etc/udev/rules.d/20-avrdragon.rules
Code:
SUBSYSTEM=="usb", ATTR{idVendor}=="03eb", ATTR{idProduct}=="2107", GROUP="users", MODE:="666"
and then restart udev
Code:
udevadm control --reload-rules
But this doesent work in Fedora 16.

Does anone know how to fix this?

//John
 
Old 02-21-2012, 07:36 PM   #2
liberalchrist
Member
 
Registered: Jun 2011
Location: Chester, SC
Distribution: Slackware Current
Posts: 123

Rep: Reputation: 26
Try the command "lsusb" in a terminal and see if the idVendor and idProduct numbers match. The tutorial you looked at may have been a little old and these may have changed.
 
Old 02-21-2012, 10:29 PM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,576
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
lsusb output format is Bus <number> Device <number>: ID <idVendor>:<idProduct> <description>
 
Old 02-22-2012, 03:47 AM   #4
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Original Poster
Rep: Reputation: 1
Nope... They seem to match.

Bus 003 Device 004: ID 03eb:2107 Atmel Corp. AVR Dragon
 
Old 02-22-2012, 03:51 AM   #5
john_erlandsson
Member
 
Registered: Jul 2009
Location: Sweden
Distribution: Fedora
Posts: 70

Original Poster
Rep: Reputation: 1
Found the problem.

I have recently been programming a PLC system in structured text, which made me do this mistake

SUBSYSTEM=="usb", ATTR{idVendor}=="03eb", ATTR{idProduct}=="2107", GROUP="users", MODE:="666"



It works now. Sorry for wasting your time

//John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with udev rule on fedora 15 blue_bob Linux - Hardware 5 05-10-2012 07:55 PM
First UDEV Rule, Not quite there ... orbit Slackware 7 02-22-2009 10:08 PM
udev rule: need help DPenguin Linux - Hardware 0 08-04-2008 07:29 PM
Udev Rule Help Please Toods Slackware 1 11-23-2007 08:55 AM
need help with udev rule hussam Linux - Software 2 12-05-2006 03:30 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration