LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-04-2014, 07:19 PM   #1
0men
Member
 
Registered: Mar 2011
Location: Gold Coast, Australia
Distribution: saline, centos, freeBSD, slackware
Posts: 182

Rep: Reputation: 22
Ubuntu13.10 HP laptop install. UEFI/graphics problem ?


Hey guys,

I've recently purchased a laptop for college this coming semester. Its a HP pavilion 15. AMD quad core, 8 gig ram with radeon graphics.

I've installed ubuntu and a number of other distrubutions plenty of times but i'm stuck with this one. I've tried just about every result on google for the first 3 pages and still nothing.

Downloaded Ubunutu, use unetbootin to convert to bootable iso. Ubuntu boots perfectly connect to internet, surf around check what services are running, just getting a feel for the distro. Time to install, everything goes well. Please restart your computer.... do that..... trouble.

First of all i see GRUB, it gives me three options.
Code:
1.  Ubuntu
2.  Advanced options for Ubuntu
3.  System setup
I hit Ubunutu, get a black screen, displays two lines.
Code:
    KVM: disabled by BIOS
    KVM: disabled by BIOS
Then i get dropped into a black screen with a login prompt
Code:
 omenscomputer Login:
Before i can type anything a notice appears.
Code:
[drm:radeon_acpi[init] * ERROR cannot find backlight controller
Then to a Ubuntu screen
Code:
    The system is running in low graphics mode. ((Get 4 random options   that dont do anything anyways.)))

This is my BIOS settting

Code:
Network Boot Protcol == IPV4 + IPV6 UEFI
Legacy Support == disables
Secure boot == enabled

UEFI BOOT ORDER
Internal CD/DVD drive
USB cd/dvd rom drive
usb diskette ...
OS boot manager
! network adaptor.

I'm not sure if this is a UEFI problem, but i have a feeling from what i've written above its got something todo with the radeon graphics ? The reason i didnt think it was radeon is because, before the install Ubuntu was working fine :/

If anyone has any help to offer that'd be great right now, as my new PC is compltely unusable. Note: that i dont run windows, although the PC came with Windows 8(kill me) i want to wipe that completely and just run Ubuntu.

Thanks again.
 
Old 01-05-2014, 12:40 PM   #2
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Disable secure boot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
UEFI won't boot LiveCDs on my laptop launchpadtt Linux - Laptop and Netbook 11 01-14-2014 08:41 PM
[SOLVED] I can't run a CD from a UEFI laptop mrlogick Linux - Laptop and Netbook 4 12-27-2013 02:47 PM
Help Creating UEFI A MENU For My Bootable (BIOS/UEFI) CDROM ssenuta Linux - Hardware 0 08-27-2012 09:11 PM
UEFI framebuffer and graphics card linuxbird Linux - Hardware 9 07-01-2012 04:38 AM
how to tell my graphics board driver in linux? ## return from suspend laptop problem# mkultra329 Linux - Newbie 2 02-13-2010 08:54 AM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration