LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-06-2009, 02:21 PM   #1
humberto
LQ Newbie
 
Registered: Nov 2009
Posts: 7

Rep: Reputation: 0
Ubuntu runs too slow, please help me


hi,
I installed ubuntu 9.1 last night , it runs slow if I open a box or menu but specially when I try
to open a website. I am running epiphany web browser. It will work even slower if I use firefox. I am using an HP laptop which runs fine with windows XP. I will aprecciate your help.
 
Old 11-06-2009, 03:34 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 69
The first think I'd check is to see if the hard disk light is flashing while the computer is running slowly; if it is then it could indicate that the computer is swapping, which can cause slowness.

We need to find out why the computer is slow: it could be a RAM or CPU problem, or some program you don't need that's gobbling up your resources.

Can you please open the file /proc/meminfo and copy and paste it into this thread?
Can you also open a terminal and type "top -n 1", then select the text and paste that as well?
 
Old 11-06-2009, 03:37 PM   #3
jamwaffles
Member
 
Registered: Mar 2008
Distribution: Ubuntu Lucid
Posts: 131

Rep: Reputation: 19
would you mind if you posted your hardware specs?

Thanks

James

ps it SHOULD run very nicely if XP works smoothly on it
 
Old 11-06-2009, 04:21 PM   #4
humberto
LQ Newbie
 
Registered: Nov 2009
Posts: 7

Original Poster
Rep: Reputation: 0
specs:
1.6 GHz AMD processor
1G RAM

top - 16:13:41 up 12 min, 2 users, load average: 0.16, 0.20, 0.18
Tasks: 145 total, 1 running, 144 sleeping, 0 stopped, 0 zombie
Cpu(s): 8.0%us, 2.6%sy, 0.4%ni, 85.6%id, 3.3%wa, 0.1%hi, 0.0%si, 0.0%st
Mem: 993208k total, 384288k used, 608920k free, 23076k buffers
Swap: 602396k total, 0k used, 602396k free, 148692k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
1686 humberto 20 0 145m 59m 21m S 21 6.2 1:12.87 epiphany-browse
1810 humberto 20 0 2464 1060 784 R 4 0.1 0:00.03 top
1 root 20 0 2528 1500 1120 S 0 0.2 0:01.08 init
2 root 15 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0 0.0 0:00.02 ksoftirqd/0
5 root RT -5 0 0 0 S 0 0.0 0:00.00 watchdog/0
6 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/1
7 root 15 -5 0 0 0 S 0 0.0 0:00.00 ksoftirqd/1
8 root RT -5 0 0 0 S 0 0.0 0:00.00 watchdog/1
9 root 15 -5 0 0 0 S 0 0.0 0:00.02 events/0
10 root 15 -5 0 0 0 S 0 0.0 0:00.02 events/1
11 root 15 -5 0 0 0 S 0 0.0 0:00.00 cpuset
12 root 15 -5 0 0 0 S 0 0.0 0:00.00 khelper
13 root 15 -5 0 0 0 S 0 0.0 0:00.00 netns
14 root 15 -5 0 0 0 S 0 0.0 0:00.00 async/mgr
15 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/0

meminfo:
MemTotal: 993208 kB
MemFree: 633984 kB
Buffers: 22380 kB
Cached: 145704 kB
SwapCached: 0 kB
Active: 207540 kB
Inactive: 116928 kB
Active(anon): 161368 kB
Inactive(anon): 0 kB
Active(file): 46172 kB
Inactive(file): 116928 kB
Unevictable: 0 kB
Mlocked: 0 kB
HighTotal: 105480 kB
HighFree: 224 kB
LowTotal: 887728 kB
LowFree: 633760 kB
SwapTotal: 602396 kB
SwapFree: 602396 kB
Dirty: 248 kB
Writeback: 0 kB
AnonPages: 156544 kB
Mapped: 56616 kB
Slab: 19948 kB
SReclaimable: 11200 kB
SUnreclaim: 8748 kB
PageTables: 4136 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 1099000 kB
Committed_AS: 534780 kB
VmallocTotal: 122880 kB
VmallocUsed: 2364 kB
VmallocChunk: 118060 kB
HugePages_Total: 0
HugePages_Free: 0
HugePages_Rsvd: 0
HugePages_Surp: 0
Hugepagesize: 4096 kB
DirectMap4k: 12280 kB
DirectMap4M: 897024 kB
 
Old 11-07-2009, 05:14 AM   #5
jamwaffles
Member
 
Registered: Mar 2008
Distribution: Ubuntu Lucid
Posts: 131

Rep: Reputation: 19
Hmmm this is strange... Epiphany is taking up 145MB of ram, but the rest of your system seems fine... 85% idle time.

Would you mind posting the output of those two commands again, but running firefox instead of Epiphany

Also, you could try the venerable Opera browser and see what performance
you get with that.

Another thing (lol) is your AMD 64 bit or 32 bit? because if youre running 32 bit on 64 it *COULD* slow thnigs down diabolically, but i dont know for sure (can someone back me up or correct me please)

Regards

James
 
Old 11-07-2009, 06:01 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Is your HDD's DMA enabled?
Code:
root@vaio:~# hdparm -I /dev/sda

/dev/sda:

ATA device, with non-removable media
        Model Number:       HTS421280H9AT00
        Serial Number:      HKA510AMGHLL6B
        Firmware Revision:  HA3OA70G
Standards:
        Used: ATA/ATAPI-7 T13 1532D revision 1
        Supported: 7 6 5 4
Configuration:
        Logical         max     current
        cylinders       16383   16383
        heads           16      16
        sectors/track   63      63
        --
        CHS current addressable sectors:   16514064
        LBA    user addressable sectors:  156301488
        LBA48  user addressable sectors:  156301488
        device size with M = 1024*1024:       76319 MBytes
        device size with M = 1000*1000:       80026 MBytes (80 GB)
Capabilities:
        LBA, IORDY(can be disabled)
        Standby timer values: spec'd by Vendor, no device specific minimum
        R/W multiple sector transfer: Max = 16  Current = 16
        Advanced power management level: 254
        Recommended acoustic management value: 128, current value: 254
        DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=240ns  IORDY flow control=120ns
Commands/features:
        Enabled Supported:
           *    SMART feature set
                Security Mode feature set
           *    Power Management feature set
           *    Write cache
           *    Look-ahead
           *    Host Protected Area feature set
           *    WRITE_BUFFER command
           *    READ_BUFFER command
           *    NOP cmd
           *    DOWNLOAD_MICROCODE
           *    Advanced Power Management feature set
                Power-Up In Standby feature set
           *    SET_FEATURES required to spinup after power up
                Address Offset Reserved Area Boot
                SET_MAX security extension
           *    Automatic Acoustic Management feature set
           *    48-bit Address feature set
           *    Device Configuration Overlay feature set
           *    Mandatory FLUSH_CACHE
           *    FLUSH_CACHE_EXT
           *    SMART error logging
           *    SMART self-test
           *    General Purpose Logging feature set
           *    WRITE_{DMA|MULTIPLE}_FUA_EXT
           *    64-bit World wide name
           *    IDLE_IMMEDIATE with UNLOAD
Security:
        Master password revision code = 65534
                supported
        not     enabled
        not     locked
                frozen
        not     expired: security count
        not     supported: enhanced erase
        62min for SECURITY ERASE UNIT.
Logical Unit WWN Device Identifier: 5000cca51c71757
        NAA             : 5
        IEEE OUI        : cca
        Unique ID       : 51c71757
HW reset results:
        CBLID- above Vih
        Device num = 0 determined by the jumper
Checksum: correct
 
Old 11-07-2009, 06:23 AM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
What is the content of your
Code:
/etc/hosts
In your browser, try to disable ipv6
Code:
about:config => search ipv6 =>network.dns.disableIPV6=>set it to true
To disable ipv6 globaly
http://www.ubuntugeek.com/how-to-dis...in-ubuntu.html

Is your DNS configured correctly?
What s the output from
Code:
cat /etc/resolv.conf

Last edited by repo; 11-07-2009 at 06:25 AM.
 
Old 11-07-2009, 02:47 PM   #8
humberto
LQ Newbie
 
Registered: Nov 2009
Posts: 7

Original Poster
Rep: Reputation: 0
this is I got after typing hdparm:

humberto@humberto-laptop:~$ hdparm -I /dev/sda
/dev/sda: Permission denied

after cat /etc/resolv.conf

humberto@humberto-laptop:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain Belkin
search Belkin
nameserver 192.168.2.1
nameserver 68.87.68.166
nameserver 68.87.74.166

/etc/hosts <= I dont have any subdirectory called "hosts"

I did not find a way to disable ipv6 in my browser , please give me more details.
 
Old 11-07-2009, 02:54 PM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Quote:
this is I got after typing hdparm:
/dev/sda: Permission denied
That's because (if you look at my post carefully you'll see that) you need to run that command as root.

Try sudo hdparm -I /dev/sda

Quote:
/etc/hosts <= I dont have any subdirectory called "hosts"
It's not a subdirectory, it is a file.
Try cat /etc/hosts
 
Old 11-07-2009, 03:02 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
I did not find a way to disable ipv6 in my browser , please give me more details.
http://en.opensuse.org/Disable_IPv6_for_Firefox

Google is a great source :-)
 
Old 11-09-2009, 07:23 PM   #11
humberto
LQ Newbie
 
Registered: Nov 2009
Posts: 7

Original Poster
Rep: Reputation: 0
This is what I got, please let me know if anything is wrong.

/dev/sda:

ATA device, with non-removable media
Model Number: FUJITSU MHV2100BH PL
Serial Number: NW9YT692BY7N
Firmware Revision: 892C
Standards:
Used: ATA/ATAPI-7 T13 1532D revision 4a
Supported: 7 6 5 4 & some of 8
Configuration:
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63
--
CHS current addressable sectors: 16514064
LBA user addressable sectors: 195371568
LBA48 user addressable sectors: 195371568
Logical Sector size: 512 bytes
Physical Sector size: 512 bytes
device size with M = 1024*1024: 95396 MBytes
device size with M = 1000*1000: 100030 MBytes (100 GB)
cache/buffer size = 8192 KBytes (type=DualPortCache)
Capabilities:
LBA, IORDY(can be disabled)
Standby timer values: spec'd by Standard, no device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Advanced power management level: disabled
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* SMART feature set
Security Mode feature set
* Power Management feature set
* Write cache
* Look-ahead
* WRITE_BUFFER command
* READ_BUFFER command
* DOWNLOAD_MICROCODE
Advanced Power Management feature set
* 48-bit Address feature set
* Device Configuration Overlay feature set
* Mandatory FLUSH_CACHE
* FLUSH_CACHE_EXT
* SMART error logging
* SMART self-test
* General Purpose Logging feature set
* IDLE_IMMEDIATE with UNLOAD
* Gen1 signaling speed (1.5Gb/s)
* Host-initiated interface power management
* Phy event counters
Device-initiated interface power management
* Software settings preservation
* SMART Command Transport (SCT) feature set
* SCT LBA Segment Access (AC2)
* SCT Error Recovery Control (AC3)
* SCT Features Control (AC4)
* SCT Data Tables (AC5)
Security:
Master password revision code = 65534
supported
not enabled
not locked
frozen
not expired: security count
supported: enhanced erase
78min for SECURITY ERASE UNIT. 78min for ENHANCED SECURITY ERASE UNIT.
Checksum: correct
 
Old 11-10-2009, 05:16 AM   #12
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
That looks fine, DMA is active, but what about the output of cat /etc/hosts ?
 
Old 11-11-2009, 02:04 AM   #13
humberto
LQ Newbie
 
Registered: Nov 2009
Posts: 7

Original Poster
Rep: Reputation: 0
humberto@humberto-laptop:~$ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 humberto-laptop

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
humberto@humberto-laptop:~$

I tried with Opera and it works even worse than epiphany
This laptop has an AMD turion 64x 2 CPU and if it runs like a champ in windows I reckon it should work even better with ubuntu.
 
Old 11-11-2009, 06:18 AM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
replace
Quote:
127.0.0.1 localhost
with
Quote:
127.0.0.1 localhost.localdomain localhost
 
Old 11-11-2009, 07:03 AM   #15
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
And it looks like you still have IPv6 enabled. This can waste a lot of time as it waits for the IPv6 connection to time out before trying IPv4 (which, generally, it should have used in the first place).

To disable IPv6:

Open the file /etc/modprobe.d/aliases and scroll down to this bit.

Code:
# alias net-pf-10 ipv6 disable ipv6
alias net-pf-10 off
alias ipv6 off
And make it look like the above. Save the file.

Then reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 7.10 Runs Very Slow HP Pavilion dv6000 kerryblue19 Linux - Newbie 3 12-19-2007 06:43 PM
fc3 runs slow! syztem_krash Linux - Laptop and Netbook 9 12-13-2004 08:55 PM
Broodwar runs very slow... NeCewl Linux - Games 2 07-29-2004 06:42 PM
ET runs slow. shadowhunter Linux - Games 4 06-15-2004 10:27 PM
it runs so slow neverender Linux - General 1 01-14-2004 07:43 AM


All times are GMT -5. The time now is 06:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration