LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 09-29-2009, 06:05 AM   #1
Changes
Member
 
Registered: Oct 2008
Posts: 165

Rep: Reputation: 16
Ubuntu recovery mode asks for root password


I installed the fglrx ATI drivers on my notebook (Toshiba M30X) running CrunchBang 9.04.1, and they messed the system up so bad X doesn't even boot - it seems to crash with a sort of weird multicolored display on which you can't do a thing.
Apparently, they aren't supported in 9.04.1 - gee, that would sure have been nice to know before attempting this, thanks a bunch AMD.

So I reboot, get to the grub menu, select recovery mode, and it boots into the recovery menu. From here I select "root - drop to root shell prompt"... and I get a password request for the root account (no, not the user account; I tried that already). Ubuntu doesn't HAVE a root account, and so doesn't have a root password. Result: can't access rescue console to remove the deity-damned fglrx drivers.

I've googled, but every mention of the recovery mode says it should drop you to root without asking for the password. Which is logical, except mine doesn't.

What now? *sigh*
 
Old 09-29-2009, 06:22 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
Root is the default account on the Linux and most UNIX systems. Just the on Ubuntu, root password is not set by default and you need to set it.
 
Old 09-29-2009, 06:32 AM   #3
lutusp
Member
 
Registered: Sep 2009
Distribution: Fedora
Posts: 835

Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by Changes View Post
I installed the fglrx ATI drivers on my notebook (Toshiba M30X) running CrunchBang 9.04.1, and they messed the system up so bad X doesn't even boot - it seems to crash with a sort of weird multicolored display on which you can't do a thing.
Apparently, they aren't supported in 9.04.1 - gee, that would sure have been nice to know before attempting this, thanks a bunch AMD.

So I reboot, get to the grub menu, select recovery mode, and it boots into the recovery menu. From here I select "root - drop to root shell prompt"... and I get a password request for the root account (no, not the user account; I tried that already). Ubuntu doesn't HAVE a root account, and so doesn't have a root password. Result: can't access rescue console to remove the deity-damned fglrx drivers.

I've googled, but every mention of the recovery mode says it should drop you to root without asking for the password. Which is logical, except mine doesn't.

What now? *sigh*
May favorite part of your post is this: "Ubuntu doesn't HAVE a root account". This remark should go down in posterity, along with "Oh, the humanity" (Hindenburg disaster, 1937) and "Houston, we have a problem" (Apollo 13, 1970).

1. All Unices have a root account. This is (among other things) because Unices are not Windows.

2. If you believe your Linux version doesn't have a root account, and if you have not bothered to learn how to access it and establish/learn its access password, you need a crash program of cybernetic re-education. This post is the first step toward that goal.

3. Erase your short-term memory, and I do not mean your system RAM. Accept that your system has a root account, learn its password, and learn how to access it.

Knowledge can make you free. The next time you're absolutely sure you're right about something, resist the temptation to post your views in a public discussion forum.
 
Old 09-29-2009, 07:02 AM   #4
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Although linuxlover.chaitanya and lutusp are technically correct (there is a root user), it does not help.

You can try to boot your system normally and when it's fully booted, press <ctrl><alt><F1>. You should be taken to a console where you can login as the normal user and take it from there.
Alternatively, do a search how to recover a root password (e.g. using a live CD).
 
Old 09-29-2009, 07:26 AM   #5
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Or you can just do "sudo su" and then change/set the root password with "passwd" command after switching to antoher console (with <ctrl>+<alt>+<F1>) and logging in with your own username. After that you can user the root prompt from the recovery mode with your newly set root password.

Last edited by alienDog; 09-29-2009 at 07:28 AM.
 
Old 09-29-2009, 07:31 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
You can login with your normal account and then use sudo passwd root to change the root password. You will be asked for your account password. This is the same password that you logged on with.
 
Old 09-29-2009, 07:47 AM   #7
Changes
Member
 
Registered: Oct 2008
Posts: 165

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by lutusp View Post
May favorite part of your post is this: "Ubuntu doesn't HAVE a root account". This remark should go down in posterity, along with "Oh, the humanity" (Hindenburg disaster, 1937) and "Houston, we have a problem" (Apollo 13, 1970).
Really? Wow, I didn't think it was such an important statement. But hey, if it gets me into history, then I'll make sure to repeat it as often as I can.

Quote:
2. If you believe your Linux version doesn't have a root account, and if you have not bothered to learn how to access it and establish/learn its access password, you need a crash program of cybernetic re-education. This post is the first step toward that goal.
I'm guessing you've already taken your crash course in "patronizing speech"?
I'm familiar with root access; I gave a go at Mandrake a few years ago (it didn't last too long). Ubuntu, however, doesn't require me to bother with root, so I didn't. How was I to know it'd one day want a password which it never asked me to set before?

Quote:
Knowledge can make you free. The next time you're absolutely sure you're right about something, resist the temptation to post your views in a public discussion forum.
Oh for Pete's sake, if I were absolutely sure of stuff I wouldn't be posting in forums at all, I'd just work from the encyclopedic knowledge of everything that I'd have in my gargantuan brain.

I have news for you: people are occasionally wrong. This does not automatically make them idiots. Yes, I know, you're shocked and flabbergasted by this revelation, but trust me, that's how it works.
Now that you know that, is there any chance you could step down from your altar and help us miserable mortals solve our troubles? Thanks.

To all the others: I cannot login at all, or I'd have already apt-get-removed the fglrx drivers from the console. When the weird coloured screen appears, the computer seems to understand no input. I already tried ctrl-alt-f1, and I also tried banging like a monkey on ctrl-alt-backspace while it was loading in the hope it stopped X before it got to the part where it gets confused; nothing works. I get the weird screen, and that's that.

Is there any way to get it to skip automatically loading X at boot that doesn't require being logged in to set (so presumably from grub)?
 
Old 09-29-2009, 07:53 AM   #8
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Use a Live CD then mount your root partition.
 
Old 09-29-2009, 07:57 AM   #9
Changes
Member
 
Registered: Oct 2008
Posts: 165

Original Poster
Rep: Reputation: 16
Doing just that.
Then what?

Edit: oh, ok, then I should be able to set a root pwd and boot rescue console.

Thanks, I'll give it a go.
 
Old 09-29-2009, 09:04 AM   #10
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Err...? No...? You will not be able to set the root password that way. At least not with passwd command. However, you could change the default runlevel of the system to a one that doesn't autostart X. Unfortunately I have no idea of the Ubuntu runlevels, so I don't know which one you should choose. Anybody else? The runlevel is set in /etc/event.d/rc-default. The default runlevel is 2 (the line that says telinit 2).

-- edit --

Or you could also temporarily remove the execute bit of the X server:

chmod a-x /usr/X11R6/bin/X

That ought to prevent it from starting up > Not sure if it will work though.

Also, remember to take care that you edit correct files when you're working with live-CD. I.e. because / is the root directory of the Live CD, you must make changes in [mountpoint]/etc and [mountpoint]/usr/X11R6/bin, in which mountpoint is the directory where you mounted your harddisk.

--edit--

Ok, I found this description of the Ubuntu runlevels:

* 0 System Halt
* 1 Single user
* 2 Full multi-user mode (Default)
* 3-5 Same as 2
* 6 System Reboot

So there is no runlevel without X in Ubuntu (3-5 are the same as 2)?! How stupid. There is no point in changing the runlevel, it won't make any difference. Apparently this is the "correct" way to disable X in Ubuntu:

sudo update-rc.d -f gdm remove

With live-CD you can just do: "rm [mountpoint]/etc/rc2.d/S30gdm" that'll remove GDM for runlevel 2.

You can restore X with this command:

sudo update-rc.d gdm defaults

Last edited by alienDog; 09-29-2009 at 09:20 AM.
 
Old 09-29-2009, 09:06 AM   #11
Changes
Member
 
Registered: Oct 2008
Posts: 165

Original Poster
Rep: Reputation: 16
I managed to rescue the system. I edited /etc/X11/default-display-manager and commented out the "/usr/sbin/gdm" line, then rebooted and it went to text mode. Apt-get-removed the fglrx drivers from there, restored the commented line and now it works.

Thanks
 
Old 09-29-2009, 09:26 AM   #12
alienDog
Member
 
Registered: Apr 2004
Location: Europe
Distribution: Debian, Slackware
Posts: 505

Rep: Reputation: 46
Nice to know you got it working. I do recommend setting the root password for your system anyway. That way you can at least get the system to a single user mode without X if something goes wrong.
 
Old 09-30-2009, 12:11 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
Good to know about it. As far as our responses go, most of them were in assumption that you can boot the system but you do not know the root password. And this what your first post gives the feeling.
And if you feel that you have solved the issue just mark it done. This will help others with similar issue search better.
 
Old 09-30-2009, 12:24 AM   #14
lutusp
Member
 
Registered: Sep 2009
Distribution: Fedora
Posts: 835

Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by Changes View Post
I have news for you: people are occasionally wrong. This does not automatically make them idiots.
I never said you were -- I would never take that position. I did say you should be asking questions, not making statements of fact. Your premise and your certainty (that Ubuntu desn't have a root account) was the problem to be overcome.

Many people have system problems. They ask questions and get answers. Yours wasn't a system problem, it was a belief problem.
 
Old 10-12-2009, 01:26 AM   #15
nzroller
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
lutusp's dickness aside, setting the root password is a violation of Ubuntu security policy, where it is disabled by default. So consequently this is a bug, unless the root password was set previously.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install skype on acer one. Asks for root password. don't know where to get this congercod Linux - Newbie 4 02-13-2009 08:08 AM
Password Recovery in Edubuntu 7.04 - In Terminal, Root Login : su , password : ????? farhannaeem13 Linux - Security 3 11-30-2007 09:59 AM
Windows -> Ubuntu asks for Password.. RetepNamenots Linux - Networking 6 03-25-2007 12:38 PM
SUSE asks for root password at logoff (how do I shut this off?) monkeyboy73 Linux - Desktop 4 12-14-2006 09:28 PM
Redhat 8 asks for root password before dialling head8k Linux - Newbie 9 02-21-2003 04:52 PM


All times are GMT -5. The time now is 10:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration