LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2015, 02:37 AM   #1
rc49
LQ Newbie
 
Registered: May 2015
Posts: 25

Rep: Reputation: Disabled
ubuntu--openGL


i m trying to install a package which needs openGL
my system is ubuntu 12.04 LTS 32bit
i installed all the packages it need to run but still it gives error while configuring it

bash: ./configure: /bin/sh^M: bad interpreter: No such file or directory

what is ubuntu openGL
i m new to linux and not able differentiate theses terms
any response will be appreciated
 
Old 09-22-2015, 04:39 PM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Distribution: SLES 12
Posts: 1,573

Rep: Reputation: 106Reputation: 106
bash: ./configure: /bin/sh^M: bad interpreter: No such file or directory

This line does not make any sense.
 
Old 09-22-2015, 05:10 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Quote:
what is ubuntu openGL
$ sudo apt-get update && sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev


Quote:
bash: ./configure
? Are you sure that the software you want to build has a script by name configure ?

** There are ~10 other ways to configure / building from source, see post #10 here
http://www.linuxquestions.org/questi...rce-826421/#10


? Which software is it about ?


-
 
Old 09-23-2015, 02:48 AM   #4
rc49
LQ Newbie
 
Registered: May 2015
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
$ sudo apt-get update && sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev



? Are you sure that the software you want to build has a script by name configure ?

** There are ~10 other ways to configure / building from source, see post #10 here
http://www.linuxquestions.org/questi...rce-826421/#10


? Which software is it about ?


-
yes sir ,,,it has configure file and install file too in its package
configure runs successfully and make too,, i follow all installation instructions mentioned dere
but when i run it gives error mention earlier---bash!!!

""? Which software is it about ?""

i was trying to run iNSpect
visualization tool for wireless/adhoc networks for ns2
i request it from http://toilers.mines.edu/Public/Code/Nsinspect.html
webpage also mentions some information regarding operating systems(linux OS) it was tested succefully and supports (i googled them too),,but m very new to those terms..
 
Old 09-23-2015, 05:38 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Re #4.
Quote:
I was trying to run iNSpect
OK. That's a "post #1" information. Please read :
. http://www.linuxquestions.org/linux/...Ask_a_Question
. http://www.catb.org/~esr/faqs/smart-questions.html

iNSpect :
$ sudo apt-get install libgl1-mesa-dev libglu1-mesa-dev freeglut3-dev libgtkglext1-dev

About iNSpect/configure : configure should have 7278 lines.
You have a corrupt configure file.
Is a known error with iNSpect. Difficult to unpack.

Solution 1) Try again, in different directories : $ tar xvf iNSpect***
... And a couple of times with your 'Archive Manager'.
? With some luck you will get a complete "iNSpect/".

Solution 2) You can unpack the binary 'iNSpect' anywhere : iNSpect-bin-4.tar.gz
https://drive.google.com/file/d/0B7S...ew?usp=sharing
.... and you don't have to build anything. Just run $ ./iNSpect
( The executable 'iNSpect' was built here `Mar 21 - 2011', with PCLinuxOS.)


-

Last edited by knudfl; 09-23-2015 at 05:59 AM.
 
Old 09-23-2015, 08:47 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Re #5.

iNSpect, solution 3) : A new source package, iNSpect_4_beta_3-src.tar.gz .
... Is the original source, from my `Aug 2011' backup cdrom.
Cleaned up, and the files now have the right permissions.
.. And no issues with Ubuntu 12.04 - 32.

Download link :
https://drive.google.com/file/d/0B7S...ew?usp=sharing


-
 
  


Reply

Tags
inspect4, ns2, opengl, ubuntu 12.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL in Ubuntu kalimat Programming 14 12-06-2010 10:23 AM
OpenGL in Ubuntu Linux 8.04 afa_linux Linux - General 2 12-15-2008 11:22 PM
OpenGL in Ubuntu under VirtualBox jmite Linux - Newbie 1 11-13-2008 07:09 PM
Installing OpenGL in Ubuntu 7.10 mmsprinter Linux - Software 3 01-08-2008 06:41 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration