LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ubuntu Natty 64 internal mic not working on lenovo x120e (http://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-natty-64-internal-mic-not-working-on-lenovo-x120e-892849/)

mightymiff 07-20-2011 11:59 PM

Ubuntu Natty 64 internal mic not working on lenovo x120e
 
Alright, I'm new to linux, I've googled for days, but I can't for the life of me get my internal mic working. It doesn't register sound in the sound preferences menu, it is not muted.

I have the x120e with the E-350. New install of Ubuntu 11.04 64-bit.

Where to start?

Thanks for the help.

alfredo10 07-21-2011 08:29 AM

Hi!
First I would try: Terminal:
Code:

alsamixer
hit F6, choose sound card and adjust channels.
alfredo

Edit:
Terminal
Quote:

cat /proc/asound/card0/codec#* | grep Codec
should show the card.
If not: some commands need root rights - it depends on the distribution, then you must
run:
"sudo cat /proc/asound/card0/codec#* | grep Codec" without " "

mightymiff 07-21-2011 10:58 AM

Hi alfredo, thanks for taking the time to reply.

Codec is: ATI 6xx HDMI

alsamixer is displaying 3 possible sound cards, like this:
0 HD-Audio Generic
1 HDA ATI SB
29 ThinkPad Console Audio

Only HDA ATI SB displays any controls.
I hit F5 to display all controls. I maxed all of them including L R Capture to 100<>100.
Analog Mic Boost up to 40db.

The first time I opened sound preferences after this I noticed some movement on the input level meter. It seemed to climb and drop a bit before climbing to max. It stopped moving after that, and now I'm not sure if it is at 0 or 100. In any case, I have played around with the capture toggle (trying various levels and mic boost db levels) and my skype test call is still silent and the sound recording will not begin recording, leading me to believe I have not fixed my mic.

Something I did incorrectly or something else to try? Thanks...

alfredo10 07-21-2011 11:48 AM

Hi!
Next idea:
Code:

pavucontrol
I suppose it is not installed, but you will get a hint (like "sudo apt-get install pavucontrol").
When you start it, it is possible that you get an error message - ignore that and go on.
alfredo

yodabug 07-21-2011 11:51 AM

Not sure if this will help or not but I think it might.

https://help.ubuntu.com/community/HdaIntelSoundHowto

There is a ton of information in that thread and links to more.

Good Luck.

yodabug 07-21-2011 11:55 AM

Or, more to the point:

http://crunchbanglinux.org/forums/to...nd-working-in/

Good Luck again. I really have no idea's, just pretty good search results:-)

Cheers!

barmaglot 12-20-2011 12:35 AM

Solved for Linux Mint (Ubuntu derivative) by updating to the latest ALSA drivers from Ubuntu Audio Dev team.

Code:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-2.6.38-8-generic

replace the kernel version in the last comand with yours.

jmlm_1970 03-26-2012 06:15 PM

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).


All times are GMT -5. The time now is 12:58 AM.