LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-14-2008, 01:30 PM   #1
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Rep: Reputation: 15
Ubuntu minimal and Fluxbox problem.


So I installed Ubuntu with minimal settings. It installed fine and in console I installed fluxbox with this command :
"sudo aptitude install fluxbox xorg xdm"
Installed everything fine, but when I try to start X-server it gives this error:

Code:
The XKEYBOARD keymap compiler (xkbcomp) reports :
> Warning :	Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>		Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
enable montype: 1
enable montype: 1

waiting for X server to shut down disable monotype: 1 
disable montype: 1
finished PLL2
finished PLL1
Entering Restore TV
Restore TV PLL
Restore TVHV
Restore TV Restarts
Restore Timing Tables
Restore TV standard
Leaving Restore TV
FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 
1; fixing.
That's all I can see. (I dont know how to go up in console )

Do I have some missing parts of xorg or what is the problem?

Here is my xorg.conf :

Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"se"
	Option		"XkbOptions"	"lv3:ralt_switch"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"stylus"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"eraser"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"cursor"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc RV350 AP [Radeon 9600]"
	Driver		"ati"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"IBM E74"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc RV350 AP [Radeon 9600]"
	Monitor		"IBM E74"
	DefaultDepth	24
	SubSection "Display"
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

# Uncomment if you have a wacom tablet
#	InputDevice     "stylus"	"SendCoreEvents"
#	InputDevice     "cursor"	"SendCoreEvents"
#	InputDevice     "eraser"	"SendCoreEvents"
EndSection


Thank you
~Z

Last edited by zaqwe; 02-14-2008 at 02:44 PM.
 
Old 02-14-2008, 02:12 PM   #2
Lepakko
Member
 
Registered: Feb 2008
Location: Mannheim, Germany
Distribution: Debian Etch
Posts: 44

Rep: Reputation: 16
You can go up in the console with Shift+PageUp. Have you tried "sudo dpkg-reconfigure xserver-xorg"? Did you try starting X with "startx"? You can also see if "sudo /etc/init.d/xdm start" works better.
 
Old 02-14-2008, 02:30 PM   #3
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Original Poster
Rep: Reputation: 15
Yes I started fluxbox with startx and that error comes up. Is there somewhere error log or something like that? Or do I have to write all of it down?
Xdm works, the Debian thing comes where I log, but when I input correct information it just flashes the fluxbox mouse and returns to login screen.


I tried reconfiguring xorg, but no difference. Still same error comes.
Doesn't it say something about fonts and montype?

Thank you.
~Z

Last edited by zaqwe; 02-14-2008 at 02:44 PM.
 
Old 02-15-2008, 02:32 AM   #4
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Original Poster
Rep: Reputation: 15
Any ideas? :/
 
Old 02-15-2008, 04:29 AM   #5
Lepakko
Member
 
Registered: Feb 2008
Location: Mannheim, Germany
Distribution: Debian Etch
Posts: 44

Rep: Reputation: 16
You can see the Xorg log with "cat /var/log/Xorg.0.log". With "cat /var/log/Xorg.0.log | grep EE" only errors are shown. There are also other files that configure X on startup, such as xinitrc (at ~/.xinitrc or /etc/X11/xinit/xinitrc) and /etc/X11/Xsession (which is actually a script run on X startup), but I don't know if fooling around with them will help you much. They may help you locate the problem, though.
 
Old 02-15-2008, 07:23 AM   #6
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks. So here's the error log :

Code:
(II) Loading extension MIT-SCREEN-SAVER
(EE) RADEON(0): [dri] DRIScreenInit failed. Disabling DRI.
(EE) AIGLX: Screen 0 is not DRI capable.

Last edited by zaqwe; 02-15-2008 at 07:38 AM.
 
Old 02-16-2008, 09:05 AM   #7
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Original Poster
Rep: Reputation: 15
I tried disabling AIGLX, but no difference.

Last edited by zaqwe; 02-16-2008 at 02:00 PM.
 
Old 02-16-2008, 02:00 PM   #8
zaqwe
Member
 
Registered: Aug 2007
Distribution: Ubuntu 7.10
Posts: 43

Original Poster
Rep: Reputation: 15
Any ideas? :s
 
Old 02-16-2008, 05:17 PM   #9
Lepakko
Member
 
Registered: Feb 2008
Location: Mannheim, Germany
Distribution: Debian Etch
Posts: 44

Rep: Reputation: 16
Hmm, so, if you start Xdm then X is running without problems? In that case it sounds like a fluxbox problem. You may want to check out Fluxbox documentation, maybe you can find something there. Or try out another WM (like Openbox for example) and see if that works better. All in all, it seems quite mysterious to me...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu minimal and Fluxbox. zaqwe Ubuntu 1 02-15-2008 04:54 AM
Minimal install, apt fluxbox issue Zaskar Debian 1 01-30-2008 09:53 AM
Install Ubuntu with minimal software lallous Linux - Desktop 3 12-07-2007 02:13 AM
minimal linux - fluxbox how to make it work lnthai2002 Debian 4 05-12-2007 10:09 PM
fluxbox-debian/ubuntu xterm problem generallimptoes Linux - Software 1 10-02-2005 10:36 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration