LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2011, 09:27 PM   #1
RamitDas
LQ Newbie
 
Registered: Aug 2011
Location: Behala.. kolkata..west bengal..India
Distribution: ubuntu
Posts: 4

Rep: Reputation: Disabled
Ubuntu installation on an external harddrive not working properly


I had this beautiful idea of being able to carry my os around with me..plug an ext hd into any computer and be able to work on my platform from any other machine. i followed the ubuntu installation procedures and evrything for loading ubuntu on a partition created in my 2tb external harddrive. The problem that i'm facing is that in some computers,netbooks and laptops the booting from external hard drive is leading me to a black screen that says
Error:No such partition found.
grubrescue>
the strange thing is that it also does work on certain computers!!since it is not working on my netbook i am deeply troubled. i would be grateful if u guys could help me out on this one!
 
Old 08-15-2011, 10:33 PM   #2
bcyork
LQ Newbie
 
Registered: Dec 2010
Location: Chicago, IL
Distribution: Linux Mint 11 / Debian 6
Posts: 29

Rep: Reputation: 1
Did you check the bios setting and ensure that booting from an external is setup correctly?
 
Old 08-16-2011, 03:14 AM   #3
RamitDas
LQ Newbie
 
Registered: Aug 2011
Location: Behala.. kolkata..west bengal..India
Distribution: ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
i went to d bios of my netbook.. there was dis boot device options.. i had changed d boot device priority to signal that the ext hd detected should b the first to be loaded from.
 
Old 08-16-2011, 03:27 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Can you boot ubuntu in the verbose ?
So we can see all the system messages .
What is the contain of you're fstab
 
Old 08-16-2011, 08:53 AM   #5
RamitDas
LQ Newbie
 
Registered: Aug 2011
Location: Behala.. kolkata..west bengal..India
Distribution: ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
hey i am totally new with this!.. please tell me how to boot ubuntu in the verbose. when i try to boot from my external hardrive on my netbook all i get to see is the error message with the cursor waiting after grubrescue> prompt...
 
Old 08-16-2011, 03:48 PM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Press the escape key and hold it down before the booting started
You will be presented with a few option choose the recovery mode
 
Old 08-16-2011, 09:16 PM   #7
RamitDas
LQ Newbie
 
Registered: Aug 2011
Location: Behala.. kolkata..west bengal..India
Distribution: ubuntu
Posts: 4

Original Poster
Rep: Reputation: Disabled
I tried that but to no avail. The esc key didn't yield any menu with recovery option infact it yielded nothing! I have a hp mini 1109TU hope this helps!Yesterday i had taken my external harddrive to one of my friend's house to check out if the booting from an external hard drive works. And it worked!!!.. I got to the loading screen menu where u can choose from ubuntu and ubuntu in recovery mode etc! selected ubuntu and it worked fine!! It really gets frustrating to see the thing work on others computers save mine!! :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz water effect not working properly on Ubuntu 10.04 LinuxFTW Linux - Desktop 2 01-05-2011 05:02 AM
External harddrive not working Esahp Linux - General 6 04-30-2008 12:25 AM
Trackpoint scrolling not working properly - Thinkpad and Ubuntu Mountain Linux - Hardware 3 03-25-2008 01:25 AM
Mouse not working properly on linspire and ubuntu aytida.xavierite Linux - Newbie 1 02-08-2008 09:53 PM
Sound not working properly in Ubuntu Icetec Linux - Hardware 1 04-16-2005 12:28 AM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration