LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-03-2008, 06:31 AM   #1
theahbab
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Rep: Reputation: 0
Exclamation Ubuntu Hardy Heron 8.04 Having Some Newbie Problems


Hello every Linux User,

First of all, I always wanted to have a Linux OS and somehow i tried once before Ubuntu but it was too complicated for me as a windows user. Approximately two months ago I have met the Ubuntu the latest v. 8.04 Hardy Heron and during that time I have it on my Pc with Vista. I can truely say that except my game issue it is perfect. I have all I need. I generally do 3d graphics and picturing things and internet searching. I use 3d max for years and now i explored the Blender which is absolutely fre and trying to learn it with Gimp also. I can also say it is something more than my expectations. During these 2 months I use Ubuntu and try to learn it by my self just by checking the things i need in case like softwares, using terminal, games and drivers time to time. Til today, I delayed my real problem about Ubuntu in case if I can find a solution just by following the forums without leaving any message but whatever I tried I couldnt solve it.

My real problem is my vga card driver. At first hand with Envy i installed the driver which is 8.6 ati (it shows it like that)and with compiz i have no problem but with videos and with some games it is blinking. Especially in google earth if i dont move the mouse it is just black screen and when i contuiningly move the mouse i can see the map but still blinking. I frequently pursue the drivers for my vga and Ati has the latest one as always each moth but i cant install it.

My system is;

AMD 6400+ Dual Core
4x1 Gb DDR2 800Mhz Ram
250 Gb Sata 2 HDD
Ubuntu HArdy Heron 64bit
Ati Sapphire HD 3870 256bit 512 Mb Vga Card

I think it is enough to see to help for my problems

Briefly, I would like to hear some help to show me how to show as a newbie understands ;

*How I am gonna install the latest driver or what is my blinking problem. (when i tried to install it it says i need to be a super user and i think i am a super user with my password) I saw some commands about entering with password but i didnt change anytihing. I really need to hear somethings step by step. I really like my Linux System but i cant rule it there now.

*The second one is blinking in the videos. I dont wanna jump to vista to watch a movie because of i cant handle of blinking problem. Also the subtitles cant work well even with Vlc Player. I watch the same video and see the subtitles in vista but in Ubuntu it doesnt work properly. I have the codex and different players as the other users advice but the same problem. If i have a driver probolem I coulndt be playing games as Americas Army and some other 3d Games. I really dont know what is my problem.

*The third one is when you tube was closed from my country i tried to change the dns numbers with the ones given from forums and i did indeed but now i cant erase those 2 dns from the list. Even I delete them the next open they are there. This is also my matter eventhough it has not a priority. How can I turn to my default dns settings?

*The last one for now is about updating Ubuntu, currently i have 2 things in my update list but Ubuntu cant be succesfull of updating them and they are always there. It doesnt donwload and install them.

I use the latest kernel i think it is 2.26 something but the same problem was with the first kernel. I have an 50 gb place for ubuntu and also a store like 100 gb.

Except those problems given above I have no serious matters except discovering the new things on Ubuntu.

Hope there will be a remedy for me with your helpful comments. I would like to also have some friends to show me somethings on amsn in case describing the things very quickly.

Thank you so much for your helps for now, hope i can solve my issues.

Have a nice and full of enjoy with Linux

Thank you....

The Ahbab

Last edited by theahbab; 10-03-2008 at 06:38 AM.
 
Old 10-03-2008, 07:46 AM   #2
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
Welcome to LQ!

Even though you post is somewhat long, it's organized and descriptive. It's refreshing to see a new user doing such a post. Anyway, let's try to sort your problems out.

Hopefully there are couple of things you could try before you install new drivers.

Quote:
Originally Posted by theahbab
when i tried to install it it says i need to be a super user and i think i am a super user with my password
You can run commands/programs/scripts with Super User privileges with sudo command. For example to run 'ifconfig' command with privileges, try "sudo ifconfig". When prompted for password, give your password.

Quote:
Originally Posted by theahbab
The second one is blinking in the videos.
Well, this can be due a to a few reasons. The most common being you have to enable 'TexturedVideo' option in your X settings. You can do this by editing the file /etc/X11/xorg.conf

1. Open the file /etc/X11/xorg.conf with a text editor. Eg: $ sudo gedit /etc/X11/xorg.conf
(note that you need super user rights for this too)
2. Then go to the section where you have your card drivers. It would be in a section like
Section "Device"
Under that section add this:
Option "TexturedVideo" "on"

You'll need to restart the X server (a logout-login will do) to apply the changes.

In my experience (not everyone has this problem), the video still flickers in window mode. But once you switch to full screen, everything is fine. (Note: I'm using MPlayer). Sometimes flickering came back, but could be resolved with a reboot.

There should be a better way, I know. However these problems are due to the quality of ATI driver for Linux usually. That's why ATI is busy building better and Open Source drivers now.

In the case of a failure with 'TexturedVideo':

In such case try these two lines instead of TexturedVideo
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"


Quote:
Originally Posted by theahbab
How can I turn to my default dns settings?
Go to System > Administration > Network in the menu, unlock the dialog box with your password, then do the changes.

If you are still getting those IPs after this, check whether you are using DHCP (automatic/dynamic IP). If this is the case make sure the IPs are removed from DHCP server's DNS section.

Quote:
Originally Posted by theahbab
It doesnt donwload and install them
It's not clear what happening, so I'm not sure. But try this as a start.
1. First open a terminal and give "sudo apt-get update"
2. Then try installing the updates


Glad to know your interest in Linux and Open Source software. It's always good to have new adopters.
 
Old 10-04-2008, 06:34 AM   #3
theahbab
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Dear SkyEye,

Thank your for your kind and quick reply to my request. I try to make it well organized because of being understood easly then I can get the answers step by step and I also would like to thank you for your specific and clear explanations.

Here we go,


* About beging Super-User; I heard "sudo" command but stil i cant use it by installing the latest driver of Ati 8.9 . It does not working with my system.


* About blinking; I tried as you have given the line Option "TexturedVideo" "on" and logout and login I firstly tried Google Earth and then a Divx Movie again the problem remains
As I ve seen in the X11 I have already Option "VideoOverlay" "on" and Option "OpenGLOverlay" "off"

In case to use Option "TexturedVideo" line I didnt get if I should use Option "VideoOverlay" "on" and Option "OpenGLOverlay" "off" or all 3 lines together. I will try it too.

It comes to me I think I need to find a way to install the latest driver of Ati but I cant do it. Hope you can help me also installing this driver. I downloaded it in the day it released. I am really a good follower of my hardware drivers.


* About update failure; I have got these warnings and the updater says "because of a network connection it cant download it after checking network try it again by specifying your last update was 33 days ago...

Failure List

Failed to fetch http://download.skype.com/linux/repo...64/Packages.gz 404 Not Found
Failed to fetch http://falcon.landure.fr/dists/hardy/Release Unable to find expected entry amsn/binary-amd64/Packages in Meta-index file (malformed Release file?)
Failed to fetch http://repoubuntusoftware.info/dists...64/Packages.gz 404 Not Found
Some index files failed to download, they have been ignored, or old ones used instead.

* About DNS Changing; I did already what you said but the result was same for long. Interestingly with the DNSs' I entered by hand are working for Youtube and when I erased them I cant enter Youtube with the dafault DNS. After Logging Out the other comes again and I can enter the Youtube site. I heard that they make the Youtube open again in my country but they changed the Ip's. Eventhough in Vista I can enter with my default Ip in Linux there still a warning on the page as this site is forbidden with a decision of Turkish Laws.
Note : My DNS now is ok as I wish eventhough I cant enter Youtube I think it is all about the way of changing it. I just erase other DNSs' and just close the panel. That s it

I dont know what to do it by now but in time i can find out and try to handle Ubuntu with your helps. To use a ready Os is boring all the time. I believe if I can get the logic of evetyting about Linux it will be so pleasure for me in case of doing somethings with my PC.

Thank you for your ineterest and reply. Hope I will be better in time with your helps. At first I used Ubuntu as windows cause it helped me with a interface like windows but everyday I am getting better and better. For now those are my main problems which are waiting to be solved if I can handle them I will be have more willing to be in Ubuntu.

I think the results are gonna help you to see my position. I really would like to hear more and more from you.

Thank you...

Last edited by theahbab; 10-04-2008 at 07:13 AM. Reason: About Dns Setting
 
Old 10-15-2008, 08:27 AM   #4
theahbab
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Hi everybody again,

I finally installed the latest ati driver 8.9 for my HD3870 but my blinking problem still goes on with videos and with some programs as google earth. In youtube or online videos I have no problem I can watch them properly but when i try to watch a vide file like divx or mpeg4 it blinks. In VLC player when i make it full screen it is ok but currently i installed a new software called Cinelerra and Kino and the problems remains with those programs too.

I tried many ways as are described in forums but they couldnt handle my problem. With the new 8.9 driver i handled some colour problem with some games (they were so bright but now with the real colours) but especially i do graphic works and when i have this blinking problemi m not ok. Ofcourse there must be a way to fix it and I really loved Ubuntu.

ıf some of you can help me to fix this problem i will be so glad.

Ps: After I installed 8.9 it made my desktop all white and by entering "aticonfig --initial -f command in recovery mod it fixed it but why i dont know but my ati catalyst control center doesnt work. when i click it it doesnt run. If you also leave some comments about it will be so great.

thank you very much
 
Old 11-12-2008, 04:08 PM   #5
john.hedestig
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
I had the same problem with video flickering in VLC. Setting X11 as the output model fixed it. In VLC, under Tools > Preferences > Video, change the output model to X11 and restart VLC.
 
Old 01-09-2009, 05:01 AM   #6
meinhard
LQ Newbie
 
Registered: Jan 2009
Posts: 2

Rep: Reputation: 1
Video flickering disappeared for me after deactivating visual desktop effects in Ubuntu:

System > Preferences > Appearance > Visual Effects > None
 
  


Reply

Tags
ati, blinking, driver, games, graphic, programs, ubuntu, videos


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant install Linux multi media software on ubuntu hardy heron ubuntu 8.0.4 gnome Jazz44 Linux - General 3 09-15-2008 10:17 AM
LXer: Installing Xen On An Ubuntu 8.04 (Hardy Heron) Server From The Ubuntu Repositor LXer Syndicated Linux News 0 05-08-2008 02:10 PM
Ubuntu 8.04 Hardy Heron greengrocer Ubuntu 3 05-03-2008 09:05 PM
LXer: Upgrade Ubuntu 7.10 (Gutsy Gibbon) to Ubuntu 8.04 LTS (Hardy Heron) Beta LXer Syndicated Linux News 0 03-26-2008 07:30 PM


All times are GMT -5. The time now is 02:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration