LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ubuntu gutsy with atheros wireless.....can't configure.....have read previous posts (http://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-gutsy-with-atheros-wireless-cant-configure-have-read-previous-posts-610654/)

idleBrain 01-02-2008 03:40 PM

ubuntu gutsy with atheros wireless.....can't configure.....have read previous posts
 
Hello,

I have just installed Ubuntu 7.10 on my desktop which has an Atheros ethernet controller. But I am not being able to configure my wireless. I use the network manager to configure it. Most of the times it shows connected as the blue icon appears in the panel. However, I can't connect to any webpage. In addition, when I right click on the wireless icon to view the Connection Information, it shows all zeroes.

I had been going thorough the following thread by "tredegar": linuxquestions.org/questions/linux-laptop-and-handheld-25/wireless-not-working-ubuntu-gutsy-7.10-597188/
but still couldn't setup my wireless.

Will give the output of the following commands FYI:
sudo iwlist scanning
cat /etc/network/interfaces
ifconfig


output for "sudo iwlist scanning":
----------------------------------------------------
lo Interface doesn't support scanning.

wifi0 Interface doesn't support scanning.

ath0 Scan completed :

Cell 01 - Address: 00:03:93:EF:4A:F0
ESSID:"douglas town"
Mode:Master
Frequency:2.412 GHz (Channel 1)
Quality=6/70 Signal level=-89 dBm Noise level=-95 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100

Cell 02 - Address: 00:14:95:20:D3:F9
ESSID:"2WIRE072"
Mode:Master
Frequency:2.437 GHz (Channel 6)
Quality=4/70 Signal level=-91 dBm Noise level=-95 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100

Cell 03 - Address: 00:19:E3:33:B3:3C
ESSID:"thereon"
Mode:Master
Frequency:2.462 GHz (Channel 11)
Quality=24/70 Signal level=-71 dBm Noise level=-95 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : none TKIP
Pairwise Ciphers (2) : TKIP WEP-40
Authentication Suites (1) : PSK
IE: WPA Version 1
Group Cipher : none TKIP
Pairwise Ciphers (1) : WEP-40
Authentication Suites (1) : PSK
Extra:wme_ie=dd180050f2020101010003a4000027a4000042435e0062322f00
----------------------------------------------------
=> my home network is "thereon"


output for "cat /etc/network/interfaces":
----------------------------------------------------
auto lo
iface lo inet loopback
----------------------------------------------------



output for "ifconfig":
----------------------------------------------------
ath0 Link encap:Ethernet HWaddr 00:15:E9:89:8A:05
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:2 dropped:2 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:678 (678.0 b) TX bytes:180 (180.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:764 (764.0 b) TX bytes:764 (764.0 b)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-89-8A-05-00-00-00-00-00-00-00-00-00-00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:35101 errors:0 dropped:0 overruns:0 frame:36409
TX packets:4853 errors:0 dropped:2 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:5803643 (5.5 MB) TX bytes:243349 (237.6 KB)
Interrupt:10
----------------------------------------------------


In addition, as mentioned at the end of the aforementioned post, when I give commands like sudo ifdown and sudo ifup, it gives the following output:
sudo ifdown ath0:
----------------
ifdown: interface ath0 not configured

sudo ifup ath0:
----------------
Ignoring unknown interface ath0=ath0

But I believe I have configured ath0 using ndiswrapper(I followed the info in this link: beginlinux.com/index.php/desktop_training/ubuntu/ubnet_m/ub_wirless, because when I enter the /usr/ndiswrapper-1.51/utils directory and give

the command: sudo ./ndiswrapper -l
I get output:
net5211: driver installed
device (168c:001A) present (alternate driver ath_pci)
---------------------------------------------------------------

I get the same number when I do lspci and lspci -n:
lspci output => 02.0c.0 Ethernet Controller: Atheros Communications Inc. AR2413 802.11 bg NIC (Rev 01)
lspci -n output => 02.0c.0 0200: 168c:001A (rev 01)
---------------------------------------------------------------

I don't have a clue what else to do so that my wireless is up and running :scratch: Any help would be greatly appreciated.

Wish you all a happy and prosperous new year : :) :

pentode 01-02-2008 06:25 PM

I think you may have two drivers installed for the same wireless NIC. If madwifi will work for this NIC, I'd get rid of ndiswrapper by blacklisting it. If you have madwifi, you don't need or want ndiswrapper.

Beyond that, is your router using WEP or WPA security? If so, you'll need to configure that for your wireless interface.

check man iwconfig for the relevant commands. For WPA, I think you'll need wpa-supplicant, but it may already be installed in Ubuntu.

It looks like your wireless NIC is working and sees the router. So it could be just a matter of getting the security settings correct. You also need to assign an IP address or run dhclient to get one via dhcp.

Normally, it is simplest to turn off security briefly on the router and see if you can get connected in the clear. That reduces the problem set considerably, then you can focus on the security setup.

geek1234 01-02-2008 07:34 PM

Just my two cents considering I just installed a madwifi based wireless card on gutsy last week. Madwifi is pretty easy to install. just go to madwifi and follow instructions.

modprobe ath_pci will help you load the driver after the install. You should first remove any other drivers as #rmmod driver_name

#lsmod

will show you all drivers you have.


Another point, ifup ath0 generally says it is not configured when there is no entry of ath0 in network manager. If there is an entry, ensure there is a tick agains it. If you have just confugred it, it might come into action only after a boot.

HTH

G

idleBrain 01-02-2008 07:38 PM

Hi pentode,

Thanks to your reply. But mine seems to be an chicken and egg problem. I need to install wpa_supplicant but again I need internet for that. I will try disable the security feature and will try again. I have also blacklisted the ndiswrapper.
Further suggestions/pointer would be very helpful.

Thanks,
Avishek

idleBrain 01-02-2008 07:43 PM

Hi Geek,

Thanks a lot.
Could a give a more step-by-step explanation on how to proceed ?
I have been trying a lot of things of late and things have got a bit messy.

Keep pouring in with your two cents :)


All times are GMT -5. The time now is 01:54 AM.