LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2007, 02:29 AM   #1
cmndrkeen
LQ Newbie
 
Registered: Mar 2007
Location: West Hartford, CT
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Question Ubuntu - Getting on-board audio to work? (also .run files)


Today I assembled my first 64-bit computer and installed Linux for the first time, specifically "Edgy Fit" Ubuntu. Everything works except for my motherboard's integrated audio, it is an Asus M2N-E SLI. The CD that was included with the motherboard does include 64-bit Linux drivers but these do not seem to be for anything audio (I have no experience using integrated audio so I am unsure if drivers are even necessary). Since I am used to Windows, I am unsure of how I can configure drivers in Ubuntu; could someone explain this? However, it seems that I am not allowed to install the drivers anyway which brings me to my second problem.

I cannot seem to be able to use .run files. I assume that for those sorts I can just double-click in GNOME and it will install/run on its own but instead nothing seems to happen. I tried this for attempts at installing the drivers which came on the disc for my ATI video card, drivers for my printer, and the drivers included on my motherboard CD. None of them work and they are definitely for 64-bit. How are they supposed to be used? Installing things through the terminal does not seem to work for me either. The "Add/Remove" thing is very nice for finding and installing new software but it appears there is no way for me to install things from an alternate means in Ubuntu?
 
Old 03-29-2007, 03:05 AM   #2
guruwammabe
LQ Newbie
 
Registered: Mar 2007
Location: Osaka
Distribution: Slackware 11.0, Kubuntu Edgy
Posts: 15

Rep: Reputation: 0
Have you added yourself to the "audio" group and have you run alsaconfig?
I'm pretty sure that if you do it should work(of course I don't run a 64bit system so I'm guessing on that but still...)
This should fix your audio problems, the other problem, I don't know .

 
Old 03-29-2007, 03:35 AM   #3
guruwammabe
LQ Newbie
 
Registered: Mar 2007
Location: Osaka
Distribution: Slackware 11.0, Kubuntu Edgy
Posts: 15

Rep: Reputation: 0
sorry alsaconf not config... sorry if it caused confusion
 
Old 03-29-2007, 04:39 AM   #4
dasy2k1
Member
 
Registered: Oct 2005
Location: 127.0.0.1
Distribution: Ubuntu 12.04 X86_64
Posts: 958

Rep: Reputation: 35
try, sh blahdeblah.run in a terminal of some kind...

most .run files are really some form of shell script, normally with a binary part


thats how my nvidia drivers installed...
 
Old 03-29-2007, 10:53 AM   #5
cmndrkeen
LQ Newbie
 
Registered: Mar 2007
Location: West Hartford, CT
Distribution: Ubuntu
Posts: 5

Original Poster
Rep: Reputation: 0
When I try to run a .run from the terminal it just says "can't run filename.run"

As for the audio, how do I add myself to the "audio" group? I tried running alsaconf following instructions found on another forum but there is still no sound.
 
Old 03-30-2007, 02:38 AM   #6
cmndrkeen
LQ Newbie
 
Registered: Mar 2007
Location: West Hartford, CT
Distribution: Ubuntu
Posts: 5

Original Poster
Rep: Reputation: 0
Red face

I just tried using a different sound card and it works fine, I suppose it was the board. I am glad to have sound now though. ^_^
 
Old 03-30-2007, 05:56 AM   #7
ouaki
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Comment Je Peux Commencer A Lire Linux
 
Old 03-30-2007, 04:15 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
To ouaki: posts should be in English. That allows all members to participate in discussion.
 
Old 04-01-2007, 07:29 PM   #9
oudemansiella
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
Post SImpler than expected answer.

The defaults are for an auto-detection of audio out. Fix this by selecting USB Audio for the right settings in:

System > Preferences > Sound >

Sound Events
Sound Playback > USB Audio

Music and Movies
Sound Playback > USB Audio

Audio Conferencing
Sound Playback > USB Audio


> As for the audio, how do I add myself to the "audio" group? I tried
> running alsaconf following instructions found on another forum but
> there is still no sound.

The "audio group" does not exist. What was meant was meant was User Privileges for "Use audio devices" found in:

System > Administration > Users and Groups > Users Settings > Select your account and click on Properties > select the tab "User Privileges" and ensure there is a check in the box for "Use audio devices".

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
playing mp3 audio files in ubuntu! randell6564 Ubuntu 36 05-29-2006 04:41 AM
Audio-Soundmax On board not detected arubin Linux - Hardware 13 05-18-2006 03:46 AM
[ubuntu] Audio did work, but not anymore (AC"97) tijdbom Linux - Hardware 2 01-30-2006 04:46 AM
[ubuntu] how to run files? shokora Linux - Newbie 7 09-23-2005 06:14 PM
on board audio NSKL Linux - Software 3 02-02-2002 01:24 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration