LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-20-2007, 03:51 AM   #1
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Rep: Reputation: 15
Ubuntu+compiz-fusion up and running...how about the sound now!


After about 12 hours...I finally have my very own Linux Ubuntu distro up and running with my nvidia driver and compiz-fusion! Last on my to-do list(for now) is to get my sound working. Any quick fixes for this? I'm using an nvidia 650i motherboard(i think?) and a microsoft Live 3000-x Headset(USB headset).

Last edited by ItsTimeToMoveOn; 11-20-2007 at 04:05 AM.
 
Old 11-20-2007, 04:44 AM   #2
andrews-mark
Member
 
Registered: Feb 2007
Location: London
Distribution: debian
Posts: 108

Rep: Reputation: 15
I don't know of any "quick fix" for getting sound working, but here is how I would proceed...
Do you have alsa installed (on debian, I would so "dpkg -l alsa*" to see what alsa packages I have installed. not sure if that is the best way to do it in ubuntu though)?
If you do have alsa, do some checks by following the advice at
http://www.alsa-project.org/main/ind...undcardTesting

You might be in luck, and everything might be working.

If it is not, i would
1) install alsa
2) find out what your soundcard is (use lspci to list pci devices)
3) find out if it is supported by linux
http://www.alsa-project.org/main/index.php/Matrix:Main
(even if the soundcard is not fully supported, you could still be able to use some generic drivers for it)
4) find the right drivers
5) install the right drivers
6) make sure other drivers are not in conflict with the right drivers.

the last two steps could get hairy if you are unlucky. but cross that bridge if and when you get to it.

you might find it helpful to try to boot from a live cd like knoppix and see if sound is working there automagically (kde often makes a lot of bell and whistle noises, so if you hear them, then you're in good shape). using "lsmod" on the command line could help you track down the sound drivers that are being successfully used.

and so....hardly a "quick fix" and more like a "trial and error, hope for the best, plan for the worst" approach.

-m
 
Old 11-20-2007, 05:04 AM   #3
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Original Poster
Rep: Reputation: 15
lost me...in the beginning...could you explain it step by step for someone thats new(12 hours of use)to linux? muchos gracias senor!
 
Old 11-20-2007, 05:43 AM   #4
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Original Poster
Rep: Reputation: 15
Ok let's see...

System -> Prefs -> Sound
Select USB Audio and hit Test...can hear the beep(scared me half to death the first time because I had the sound all the way up. i think im legally deaf now) Still can't hear any sound from youtube or anything of the like. When I restart my comp and go back into the sound prefs, it says USB Audio(not connected) but I haven't even touched it. I can change it to USB Audio(which is has the USB Audio and USB Audio(not connected) at the same time) but still nothing. It's not muted and I hear the beep when i test it...any clues?

Edit: I can hear music playing from rhythmbox! Guess it's just youtube...any idea there? missing plugin or something?

Last edited by ItsTimeToMoveOn; 11-20-2007 at 05:46 AM.
 
Old 11-20-2007, 05:48 AM   #5
KrahnacK
Member
 
Registered: Nov 2007
Location: /dev/volcano
Posts: 70

Rep: Reputation: 15
what andrews-mark wanted to say to you is to install alsa (advanced linux sound architecture). to do so, you have to type :

sudo apt-get install alsa-base alsa-utils

in a terminal. It's strange though, i thought it was installed by default in ubuntu...(so it isn't a problem if the command above say alsa is already installed)

once we're sure alsa is installed, you can type alsamixer in a terminal, and there you can adjust the sounds volume.
If you don't hear anything when trying to play a music, i advice you to set all theses settings to the max (forgetting the microphone, if you have one), and re-try to play a sound with your headphones at a low-level, then increase the headphones volume until you hear something.

i just saw you said you have an USB headset. Haven't used this sort of thing, but it'll be a little more complicated if you haven't any cable connected to the sounds port of your motherboard (these are the round, colored ones, near the place you've connected your keyboard and mouse)... it's a quite unusual thing to make the sound signal go through USB, and i don't know how to configure it, sorry
 
Old 11-20-2007, 05:56 AM   #6
KrahnacK
Member
 
Registered: Nov 2007
Location: /dev/volcano
Posts: 70

Rep: Reputation: 15
you're quicker than me!

okay, just forget about my last post, then! ^^

youtube has its own volume control, may be you want to turn it to max?
there shouldn't be any difference with the sound from rhytmbox and the sound from firefox....
youtube requires only flash plugin, so if you see the video, you should hear something too
 
Old 11-20-2007, 01:55 PM   #7
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Original Poster
Rep: Reputation: 15
yea thats what i thought but no sound i popped a CD in and i can hear sound as well.
@Krahnack
- The sounds all the way up on youtube im at a complete loss of what to do! Must refrain from rebooting with vista...must...not...anyone have any ideas?
 
Old 11-20-2007, 04:26 PM   #8
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Original Poster
Rep: Reputation: 15
hmm...i seem to be able to hear music from everywhere but firefox. i installed XMMS and just switched the output to my headset and it works fine. my friend suggested trying epiphany but that didnt help either. im so confused!
 
Old 11-20-2007, 04:50 PM   #9
KrahnacK
Member
 
Registered: Nov 2007
Location: /dev/volcano
Posts: 70

Rep: Reputation: 15
hmmmm....may be the browsers don't use the same audio channel (which could be muted in this case...)

did you try to launch alsamixer and turn on all the volumes you could ?
 
Old 11-20-2007, 05:07 PM   #10
ItsTimeToMoveOn
LQ Newbie
 
Registered: Nov 2007
Distribution: Ubuntu
Posts: 28

Original Poster
Rep: Reputation: 15
as in alt+f2 -> alsamixer? cause when i do that, nothing happens. the run box goes away and nothing opens.

i just tried my normal speakers(single green in the back) and they work for my music and everything as well. but still no music/sound from any website. im stumped!

Last edited by ItsTimeToMoveOn; 11-20-2007 at 05:47 PM.
 
Old 11-20-2007, 06:03 PM   #11
KrahnacK
Member
 
Registered: Nov 2007
Location: /dev/volcano
Posts: 70

Rep: Reputation: 15
i don't see what you mean be alt+f2, but when i said launching alsamixer, i meant
open a terminal (in the gnome menu, accessories)
and then type alsamixer
you'll see a ncurses interface to manage your sound card's volumes
there you want to see if there's any volume at minimum, or muted, and if so put them to an audible value
(use left and right arrows to jump to the next and previous volumes, and up and down arrows to adjust the current volume, quit using esc key will save settings)
 
Old 11-22-2007, 09:01 AM   #12
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Rep: Reputation: 15
I'm in about the same place as this. I can use sound, but not in a browser. I could before I started using USB speakers. But for some reason, firefox and other browsers don't seem to like sending sound to the speakers. Fiddling with alsa settings hasn't helped me yet, and I've been working on it (a bit) for months!
 
Old 01-19-2008, 03:12 PM   #13
simbobo
LQ Newbie
 
Registered: Jan 2006
Location: Hampshire, UK
Distribution: Debian Lenny - it may be testing, but XP is a lot more testing!
Posts: 27

Rep: Reputation: 15
OK. This one's solveable. I believe the problem is that Flash, which plays the sound in youtube and loads of other net stuff, does not use the Alsa sound system. What you need to do is
1 install pulseaudio
2 install git and git-core
3 go to http://www.pulseaudio.org/wiki/FlashPlayer9Solution and follow the instructions. The line in the instructions beginning "git clone http://git..." should start "git-clone" with a hyphen.

At last I have sound in Firefox: thank you all involved in pulseaudio!!!
 
  


Reply

Tags
audio, firefox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Enabling Compiz Fusion On An Ubuntu 7.10 Desktop (ATI Mobility Radeon 9200) LXer Syndicated Linux News 0 11-16-2007 03:20 PM
How to enable full compiz-fusion on Ubuntu Gustsy _bu1ld3r_ Linux - Desktop 1 11-08-2007 04:40 AM
Help with Compiz Fusion 3d cube on Ubuntu Gutsy Gibbon AndromedaStrain Linux - Software 16 11-04-2007 12:40 AM
Compiz Fusion will work in SUSE 10.3 but not in Ubuntu 7.10 (lag) Jason21 Linux - Newbie 1 10-29-2007 07:15 PM
Compiz Fusion problem under Ubuntu 7.04 Zeratul Linux - Desktop 0 08-06-2007 10:44 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration