LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-14-2009, 09:14 PM   #1
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Rep: Reputation: 31
Question Ubuntu 9 How to automount NTFS drive?


Okay, so I'm comming back to linux, so I'm going through all the pains I did before, except this time around it seems everything autoconfigs alot better, ntfs is supported by default, graphics drivers auto install etc etc. But, now that this is the case, my old instructions for automounting my ntfs drives dont seem to make much sense. How should I go about doing this now?


Thanks
MJ
 
Old 07-14-2009, 09:21 PM   #2
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
checkout fstab
 
Old 07-14-2009, 09:36 PM   #3
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
MY FSTAB is:
Quote:
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdb6 during installation
UUID=f3a3f1b6-902d-4004-9817-1e3a0caf322c / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sdb5 during installation
UUID=9d7899a4-9739-40d5-8c6a-3a7f75fc192e none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0
and my device appears to be mounting on /media/Data,

so what are the paramaters that I should add to make it auto mount? ... I'm not seing an sda# in my /dev folder...

Thanks for any help... MJ
 
Old 07-14-2009, 10:00 PM   #4
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally Posted by mitchell7man View Post
MY FSTAB is:
and my device appears to be mounting on /media/Data
Where are you seeing this? I don't see "/media/Data" in your fstab.

The parameters are auto (I think this is default) instead of noauto. The whole entry should look something like:
Code:
/dev/diskid /media/data  ntfs-3g  auto 0 0
Of course with your disk ID and mount point created (/media/data)

Last edited by micxz; 07-14-2009 at 10:02 PM.
 
Old 07-14-2009, 10:05 PM   #5
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
I'm talking about when I just double click on the disk from 'Places' which uses whatever ubuntu comes with by default. That is why it is not in the fstab. I need to add it to the fstab, do I need to go about creating a directory and all that? Also, how do I find out where it is in /dev?

Thanks again,
MJ
 
Old 07-14-2009, 10:10 PM   #6
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
How about trying this:
- Double click it as you did.
- Then run the command "mount"
- take what you've learned from mount and apply it to fstab
 
Old 07-14-2009, 10:12 PM   #7
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally Posted by mitchell7man View Post
go about creating a directory and all that? Also, how do I find out where it is in /dev?

Thanks again,
MJ
You will se when you run mount to dev name of the drive and just create a mount point by making a folder:
mkdir /media/data
 
Old 07-14-2009, 10:22 PM   #8
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
Okay thanks, does this look right?

Quote:
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdb6 during installation
UUID=f3a3f1b6-902d-4004-9817-1e3a0caf322c / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sdb5 during installation
UUID=9d7899a4-9739-40d5-8c6a-3a7f75fc192e none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sdb1 /media/Data type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
 
Old 07-14-2009, 10:28 PM   #9
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Looks good to me. Just make sure /media/Data (Capitol D exists) and without the "()" around the options'

Last edited by micxz; 07-14-2009 at 11:12 PM.
 
Old 07-15-2009, 12:53 AM   #10
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
Okay, should work. Installing XP on Virtual Box so wont be able to reboot until thats done.
Thanks
 
Old 07-15-2009, 01:21 AM   #11
micxz
Senior Member
 
Registered: Sep 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally Posted by mitchell7man View Post
Okay, should work. Installing XP on Virtual Box so wont be able to reboot until thats done.
Thanks
XP blah' Aight' hope it works out'
 
Old 07-16-2009, 02:24 AM   #12
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
Okay, works perfect, but had to change the line a bit, i had type in there, its working witht his line
Quote:
/dev/sdb1 /media/Data auto rw,nosuid,nodev,allow_other,blksize=4096
Thanks!
 
  


Reply

Tags
automount, drives, ntfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to automount NTFS as NTFS-3G ? (with udev ?) michauko Linux - Software 6 04-09-2011 03:54 PM
NTFS, sharing hard drive between Windows, Ubuntu john_es Linux - Hardware 1 03-13-2009 05:05 AM
Problem booting ubuntu after mounting ntfs drive syphos Linux - Newbie 3 02-27-2008 03:32 AM
Automount Network NTFS drive--Slackware a1flecke Linux - Newbie 2 05-03-2004 07:33 PM


All times are GMT -5. The time now is 01:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration