LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ubuntu 9.10 upgrade no network connection (http://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-9-10-upgrade-no-network-connection-782757/)

Ant1972 01-17-2010 08:11 AM

ubuntu 9.10 upgrade no network connection
 
hello all
i have a wired connection thru a netgear router wgr614, i am running a window machine fine , but ubuntu machine say no connection . i have look around seems to be a common problem . but no simple fix . Network manager is bad , do i uninstall or change thru terminal or ...... lost pls help
Tks anthony

Simon Bridge 01-17-2010 08:28 AM

How are you trying to make a connection? (There are several ways.)
Is this supposed to be DHCP or static?
Have you ever been able to connect - say with a previous Ubuntu 9.04?
What is your ethernet card?

Googling around, most problems with this card come from the ethernet card needing extra firmware.

Ant1972 01-17-2010 08:33 AM

yes i could connect with 9.04 , when the upgrade came no connection . the router see the machine just no connection. DHCP. From googling around i have found that the net manager is bad. So i am looking for what to do next! Is it nesecary to have the make and model of net work card?

Web31337 01-17-2010 08:43 AM

it's always better to use CLI for system tweaking.
try to disable network manager and type dhclient eth0(or whatever your interface name is) from root and see if connection will appear.

Simon Bridge 01-17-2010 09:25 AM

Quote:

Is it nesecary to have the make and model of net work card?
No - it is normally of no use at all to know the make and model. Instead, you need to know the chipsets. To find out, enter

lspci

into a terminal. This will provide a lot of output. Find the line that talks about a network adapter and copy it to your reply.Also show the output of:

ifconfig

Note: network manager is almost never the problem for this sort of thing.

If you right-click on the network manager icon, there should be a check-box called "enable networking" - is it checked? There is also an option to configure network connections - have you used it?

Sometimes Windows will leave a network card in an unusable condition (it assumes that it is the only OS on your system). You may need to wake it in windows first. Possibly if you power off the computer totally, wait a bit, then boot right into linux, the card will become available.

Ant1972 01-17-2010 11:30 AM

simon bridge , i am not using windows on this at all. the machine is strickly ubuntu. The networking enabled is on.

here is the info you asked for :
lspci

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)

00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)

00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)

00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)

00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)

00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)

00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)

00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller

00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)

00:09.0 Multimedia audio controller: Ensoniq 5880B [AudioPCI] (rev 04)

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter


ifconfig

eth0 Link encap:Ethernet HWaddr 00:0d:87:ee:a0:ce

inet6 addr: fe80::20d:87ff:feee:a0ce/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:10 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:1836 (1.8 KB)

Interrupt:19 Base address:0xe000



lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:4 errors:0 dropped:0 overruns:0 frame:0

TX packets:4 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)


Thanks for the interest in my problem.

pentode 01-17-2010 12:19 PM

If you are using DCHCP on your router, just try entering "dhclient" as root from a command line. The eth0 interface is there, it just is not getting connected to your router.

If you had a fixed IP address prior to upgrading, you may need to re-configure this in /etc/network/interfaces. You may need to disable Network Manager to get these configuration settings to stick.

Ant1972 01-17-2010 12:27 PM

how do you disable network manager?

dhclient

Internet Systems Consortium DHCP Client V3.1.2

Copyright 2004-2008 Internet Systems Consortium.

All rights reserved.

For info, please visit http://www.isc.org/sw/dhcp/



can't create /var/lib/dhcp3/dhclient.leases: Permission denied

SIOCSIFADDR: Permission denied

SIOCSIFFLAGS: Permission denied

SIOCSIFFLAGS: Permission denied

Open a socket for LPF: Operation not permitted

Simon Bridge 01-17-2010 10:27 PM

I see the interface up and running - with inet6 but no inet, consistent with not contacting the dhcp server.

Stop network manager

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher

Bring the interface down, then back up.

ifconfig eth0 down
ifconfig eth0 up
dhclient

You probably don't need to go that far - if you right-click on the network manager applet, you can edit the connection information.

cantab 01-17-2010 10:33 PM

Quote:

Originally Posted by Ant1972 (Post 3829880)
can't create /var/lib/dhcp3/dhclient.leases: Permission denied

You needed to run dhclient as root. In Ubuntu, you run commands as root by typing 'sudo' and then the command, then you will be prompted for your regular password (unless you already used sudo in the last few minutes).

Ant1972 01-18-2010 05:32 PM

Quote:

Originally Posted by Simon Bridge (Post 3830394)
I see the interface up and running - with inet6 but no inet, consistent with not contacting the dhcp server.

Stop network manager

sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop
sudo /etc/dbus-1/event.d/25NetworkManager stop

Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher

Bring the interface down, then back up.

ifconfig eth0 down
ifconfig eth0 up
dhclient

You probably don't need to go that far - if you right-click on the network manager applet, you can edit the connection information.

Simon excuse me for being a newbie, i typed what you posted. and got the following.
daddy@daddy-desktop:~$ sudo /etc/dbus-1/event.d/26NetworkManagerDispatcher stop

[sudo] password for daddy:

sudo: /etc/dbus-1/event.d/26NetworkManagerDispatcher: command not found

daddy@daddy-desktop:~$ sudo /etc/dbus-1/event.d25NetworkManager stop

sudo: /etc/dbus-1/event.d25NetworkManager: command not found

daddy@daddy-desktop:~$ ifconfig eth0 down

SIOCSIFFLAGS: Permission denied

daddy@daddy-desktop:~$ ifconfig eth0 up

SIOCSIFFLAGS: Permission denied


i skipped this
Create two files with only the word 'exit' in them. These files are:

/etc/default/NetworkManager
/etc/default/NetworkManagerDispatcher

where do i put "exit"?

smeezekitty 01-18-2010 06:49 PM

Type sudo bash and then try again.
BTW i think the reason is a bug in 9.10 you may have to settle for 9.10.

Simon Bridge 01-21-2010 11:20 PM

sudo bash just opens a bash terminal as root. Putting sudo ahead of commands with "permission denied" is likely to help just the same.

echo "exit" > /etc/default/NetworkManager
echo "exit" > /etc/default/NetworkManagerDispatcher

but now you have entioned it, this may be out of date.
see:

man NetworkManager
man nm-applet

I still have seen no reason you cannot configure your network setting by right-clicking the network manager icon and proceding from there.


All times are GMT -5. The time now is 12:41 AM.