LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-19-2010, 01:43 PM   #1
johnahird
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
Question Ubuntu 9.10 'Automatic Boot' problem


I have installed Ubuntu 9.10 and it works very well. My only problem is booting up. When I turn on the computer the system stops at:
'BOOT FROM CD.'

To get round this I have to hold down key 'F12' during the boot process then in the blue menu choose 'HD' then the hard disk which contains Ubuntu.

I can't work out how to get Ubuntu to boot automatically as it did before.

Any help would be greatly appreciated.

Cheers
 
Old 08-19-2010, 02:40 PM   #2
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
Do you still have a CD inside your drive? Normally if you don't, the next available boot device should start up, namely your hard drive.

As a workaround, you can edit your BIOS settings to always boot from your hard drive first. But then you'll have to change back if you're installing a new system from CD/DVD.

-A
 
Old 08-19-2010, 03:24 PM   #3
johnahird
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Ahmed No I don't have a CD in the drive. I've always had the system configured so that it boots from the hard drive first and if a CD is in the drive it boots from that. That's normal isn't it? I can't work out what has changed. BTW Why would I have to change the bios?

Last edited by johnahird; 08-19-2010 at 03:35 PM.
 
Old 08-20-2010, 02:29 AM   #4
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
The point is, the BIOS controls the boot sequence, i.e. which drive gets checked for a bootable system first. What you had before is this: CD first, then hard drive. Every time you booted up, your PC checked the CD drive, found nothing, then went on to the hard drive automatically.

I can't imagine why installing Ubuntu would change that, but to be sure: When you boot up, it usually says "Press (Esc/F2/F8/whatever) to enter setup". Do that to access your BIOS settings (usually blue page with lots of menus). Navigate to the boot settings menu and check if the boot sequence is alright, then save and exit. As suggested, one workaround would be to place the HD on the first place, but then you can't boot from CD until you change that back.

This might be a shot in the blue, but did you install grub to the Master Boot Record or to a local partition on your hard drive?

-A
 
  


Reply

Tags
boot loader


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatic boot loader(suppressed boot menu) galapogos Linux - Software 15 11-25-2008 10:47 PM
Automatic updates with ubuntu Capt_Caveman Ubuntu 2 09-30-2007 09:21 PM
Boot problem Ubuntu on Dual Boot Mickey1 Ubuntu 3 01-29-2006 08:14 AM
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 09:20 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration