LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 03-30-2009, 01:30 PM   #16
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0

I have some vague riminiscence of dos(I know it's very different)and I am changing directory with cd /. Now: it goes into /etc but when i do cd/x11 the msg is No such file or directory. Is x11 a sub directory of/etc? I also tried to find the file/etc/x11/xorg.conf in nano environment and the answer was file not find, but I used the same command to find menu.lst and it found it. Maybe we are finally into something?????????????????????
 
Old 03-30-2009, 03:34 PM   #17
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
No, if what you typed in your message is the command you used, the problem you have is that commands and command arguments on Linux systems are all case sensitive. So "x11" is not "X11." Also, the slash (/) denotes the root directory unless it's proceeded by some other symbol. Thus cd /etc means "change the working directory to the directory etc as a sub-directory of the root of the whole file system," and cd /x11 tells the command interpreter (bash) to change your working directory to "x11" directly under the root of the whole file system. For a relative path, use cd X11.

Anyhow, there is no need to change your working directory to /etc/X11 unless you're a really poor typist. And, by making that directory you working directory whilst running with "administrative" privileges, you have "opened the door" to the possibility of making catastrophic mistakes. So, if you are a poor typist, being in a directory containing system control files is not a "good idea."

So, my suggestion is to try again, and just type nano /etc/X11/xorg.conf to see if nano is installed and if the configuration file even exists. (Sometimes it doesn't exist, since that - it not existing - tells the X-server to ask the system what hardware you have, and to use its "best guess" of which driver will work for you. And we know already how good that is for your system, eh?) By the way, the last two lines of the nano screen list the available commands (the hat (^) means "ctrl-"), and you use the arrow key so move the cursor around. (There is no "mouse" since it's not a "window" editor, just a simple "retype the screen every time" editor.)

Some other commands that are nice to know:
  1. ls - List the contents of a directory. (E.g., "ls /etc/X11/" to list the contents of the X11 sub-directory of /etc")
  2. mv - Move or rename a file
  3. pwd - Show the current working directory
  4. exit - Close your current terminal session
  5. man - Display a brief description of a command. (Note: man -k something will list all command with description containing "something.")

Last edited by PTrenholme; 03-30-2009 at 03:37 PM.
 
Old 04-01-2009, 03:52 PM   #18
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Oh,dont worry man, I know I am a very very poor typist . Anyway I hope I havent done anything so catastrophic...
But I think I found something new.I tried to use all the drivers you suggested(via,vesa,vga16 and savage) editing the xorg.conf with nano and this happened: the log in request appeared as a "command line"(not as a window) and a dialog said ubuntu found an error and has to start in low graphic mode.I press ok then it gives me different options, and i saw the error review.These are the results: from vga 16 the msg was the module does not exist; with savage the msg is no device detected; with via the msg was the module does not exist. In one of the error reports(cant remember which was of the mentioned three) there was a comment saying: Device "openchrome",Vendor"VIA technologies, Inc."BoardnameCN896/VN896. IT S THE FIRST TIME SINCE I HAVE THIS LAPTOP THAT I SEE THIS SPECS!!!I always saw S3graphic. So I googled the open chrome and the boardname and I popped in the openchrome Trac site. these guys suggest to type this source code:http://svn.openchrome.org/svn/trunk openchrome .Since it doesnt mean anything to me I will wait for help.Thank you for all this great support!!
Here is your xorg.conf Device section
Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7150M / nForce 630M"
EndSection
Mine is slightly different
Identifier "Configured Video Device"
Driver "vesa"(this is the default driver
EndSection.
Maybe it is not relevant,I just let you know
 
Old 04-01-2009, 09:25 PM   #19
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
According to that site you should get back to the command line and:
  1. Connect to the Internet
  2. Use the command apt-get install xserver-xorg-video-openchrome to install the openchrome driver from the repositories
  3. Change your xorg.conf file to read Driver "openchrome"
(I'm not on my Ubuntu system right now, so I can't verify that the openchrome driver is in the Ubuntu repositories, but that site states that it's in the Debian ones, and the Ubuntu repositories are, generally, copies of the Debian-Testing ones.)

You may need to use the sudo prefix to the the apt-get command, and the installation may automatically change the xorg.conf for you. (After asking your permission to make the change, of course.)

Note: The above is my interpretation of the line stating "Official package: xserver-xorg-video-openchrome" under the "Debian" heading here.
 
Old 04-02-2009, 12:56 AM   #20
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Ubuntu packages nvidia drivers - System > Administration > Hardware Drivers ... enable the card.
https://answers.launchpad.net/ubuntu/+question/58947

Oh - I'm messing up arn't I? This is a VIA chipset card. The xorg.conf is trying to use nvidia driver ... that won't work.

I need my evening whiskey...

Last edited by Simon Bridge; 04-02-2009 at 01:44 AM.
 
Old 04-02-2009, 04:00 PM   #21
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I am very apolegetic, I know, but I feel absolutely useless. I promise I will get into linux commands as soon as my laptop will work again!!
Do I have any chance to connect to internet from the command line? I looked for it and I only found the command ifconfig eth0(I have an ethernet connection)but I dont know if i am on line.Then I typed apt-get install xserver-xorg-video-openchrome , I was answered xserver-xorg-video-openchrome is already the newest version. 0 upgraded,0newly installed,0 to remove and 0 not upgraded. then I checked if the openchrome was in xorg.conf and typed startx and finally I see the ubuntu page for the first time!!!!!!!!!!I am almost in tears but then an error msg appears: User switcher has quit unexpectedly. and freezes. Better than nothing, I suppose........ I have just done the boot from grub(first it was from recovery mode) and it appeared again this msg and the scren goes again in fade.I am more confused than before and I have to ask again for help!
 
Old 04-02-2009, 06:01 PM   #22
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Originally Posted by marco v. View Post
I am very apolegetic, I know, but I feel absolutely useless. I promise I will get into linux commands as soon as my laptop will work again!!
When that happens, there is a crash course for Ubuntu here [pdf].

Quote:
Do I have any chance to connect to internet from the command line?
yes
Quote:
I looked for it and I only found the command ifconfig eth0(I have an ethernet connection)but I dont know if i am on line.
You can test your connection in a number of ways - popular is just to ping something -

ping www.google.com

googles servers probably get hammered by pings....
Quote:
Then I typed apt-get install xserver-xorg-video-openchrome , I was answered xserver-xorg-video-openchrome is already the newest version.
sudo apt-get update

first - but this usually means that you are online.
Quote:
0 upgraded,0newly installed,0 to remove and 0 not upgraded. then I checked if the openchrome was in xorg.conf and typed startx and finally I see the ubuntu page for the first time!!!!!!!!!!I am almost in tears but then an error msg appears: User switcher has quit unexpectedly. and freezes. Better than nothing, I suppose........ I have just done the boot from grub(first it was from recovery mode) and it appeared again this msg and the scren goes again in fade.I am more confused than before and I have to ask again for help!
Check that your changes apply to the main mode as well as rescue mode.

Quote the exact error.

If the problem remains - - -

dmesg
cat /var/log/Xorg.0.log
cat /var/log/messages
Also the contents of your /etc/rc.local file. Please do use the code tags
Can you please confirm that you have enough space on your partition? In a terminal:
df -h

I doubt the user switcher error is related to the video problem. The video is probably just the main xorg.conf not having the driver reference.

Last edited by Simon Bridge; 04-02-2009 at 06:02 PM.
 
Old 04-02-2009, 06:50 PM   #23
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Note: Please read this whole message before trying anything suggested. Some of these suggestion might take a long time and not help at all. And, once started, can't be stopped without (potentially) damaging your system.

OK, from that it seems that the openchrome driver is the one to use, and (since apt-get didn't complain) that your connection to the Internet is working.

Now, since you installed from a CD (or DVD), it's likely that your system does not include the most current versions of the software you're using. That might explain the "user switcher" error message.

For this part, I hope your Internet connection is both fast and high-bandwidth since use of the command I'll suggest may trigger a massive download - perhaps as much as two gigabytes. Anyhow, go back to the command line and try an apt-get update. That should, if all goes well, update most of our programs to the "most current" versions.

Then, after that finishes (hopefully, before next week), verify that the driver is still listed in xorg.conf. Either open the file with nano and look, or just run this command: cat /etc/X11/xorg.conf | grep openchrome (cat types the file, and | "pipes" the output of cat into the grep command, which only passes on strings containing, in this case, "openchrome.") If you don't see Driver "openchrome", then the "helpful" Ubuntu boot manager has removed it, which sometimes happens, and you need to put it back in.

Finally, try, once again, the reboot.

But, since you once again report the "fade to black" symptom, I'm beginning to suspect that you may have a real hardware problem.

<edit>
Please disregard Mr. Bridge's comment to "Check that your changes apply to the main mode as well as rescue mode." Whether or not you've booted in "single user" or "multi-user" mode does not change any software of system files, and changes to /etc/ will apply to either mode.

Note that this comment is intended to avoid confusing you with irrelevancies, not as a "dig" at Mr. Bridge.
</edit>

Last edited by PTrenholme; 04-02-2009 at 07:03 PM.
 
Old 04-02-2009, 07:14 PM   #24
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Please disregard Mr. Bridge's comment to "Check that your changes apply to the main mode as well as rescue mode." Whether or not you've booted in "single user" or "multi-user" mode does not change any software of system files, and changes to /etc/ will apply to either mode.
Ubuntu uses a different xorg.conf file for failsafe mode.

We are seeing a change take effect in failsafe which does not take effect in the normal use. From this, we cannot rule out that whatever worked was not persistent across modes.
 
Old 04-02-2009, 07:57 PM   #25
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Quote:
Originally Posted by Simon Bridge View Post
Ubuntu uses a different xorg.conf file for failsafe mode.

We are seeing a change take effect in failsafe which does not take effect in the normal use. From this, we cannot rule out that whatever worked was not persistent across modes.
No, he was running from the command prompt option, not the "failsafe" one since that option uses the vesa driver - which did not work for him (with the same symptom he has with the "correct" driver).

When, from the command line, you change xorg.conf that is, in fact, the file you change. The file used when the failsafe boot mode is selected is xorg.conf.failsafe, but that's not, as far as I know, the file he edited.

Anyhow, as I noted above, the same symptom with two (or did the vga16 driver also"fade to black?") different drivers suggests one of those fairly rare not-immediately-fatal hardware problems. Clearly his system is working in simple text mode, and even VT100 mode since nano is working, but the VGA and EVGA modes seem less stable.

Perhaps someone could suggest a method to test the SIS chip set functionality. I haven't a clue.
 
Old 04-03-2009, 02:07 PM   #26
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
New post new issue.
Just because I was curious I checked xorg.conf.failsafe and driver was still vesa.
I switched it into openchrome and edited startx. Again I see the ubuntu wallpaper and just the background of a dialogue box. then it freezes.
Internet connection from command line: I tried to ping something but the answer is unknown host. I did man ifconfig and according to to it I typed ifconfig eth0 to activate it.I did ping www.google.com again but the answer was the same. The line is up and running.
 
Old 04-03-2009, 02:10 PM   #27
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Oh I forgot to say that I tried anyway apt-get and the system said it couldnt fetch the addresses it was looking for
 
Old 04-03-2009, 05:17 PM   #28
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Just so you're clear on this: When you boot the (Recovery Mode) entry on the GRUB menu, after the system starts you will be presented with a menu offering solutions to several common problems. One of those offered solutions is to boot in "failsafe" mode. The only time the xorg.conf.failsafe configuration file is used is when you select that option from the menu. (Well, to be "technically correct" you can use that file - or any other configuration file - by passing the file name as an argument to the startx command. That's what happens when you choose the "failsafe" menu item. If you're interested in the details - which I hope you're not, but other people may read this thread - look at man startx.)

My WiFi connection failed for a while this morning, and I noticed that apt-get returns the "No updates ... Most Current" message when the connection is down, but doesn't tell you that it was unable to connect to the repositories.

So, I misspoke when I said that the message you got from apt-get suggested that your connection was working. Sorry.

When you did the ifup eth0 did you receive any error messages? Does netstat -i show any activity for eth0? (If it looks like the red line below, eth0 is not working on your system.)
Code:
# netstat -i
Kernel Interface table
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
ath0       1500 0      5824      0      0 0          3344      0      0      0 BMRU
eth0       1500 0         0      0      0 0             0      0      0      0 BMU
lo        16436 0        32      0      0 0            32      0      0      0 LRU
wifi0      1500 0     17999      0      0 0          4072      0      0      0 BMRU
Actually, the more common command used to see if an interface is working is the ifconfig command which, for a non-working connection, looks like this:
Code:
# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:1e:68:46:73:a0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:252 Base address:0x6000
So, if your Internet connection is not working, there's not much we can do.

Sometimes a dhclient eth0 will "revive" a non-working connection.
 
Old 04-05-2009, 08:01 AM   #29
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
dhclient worked and I downloaded upgrades with the apt-get command and then checked xorg.conf.
my screen does not fade to black anymore but still freezes. I see now a blurry screenshot of the desktop, the image is not loaded but I see the taskbar on the top of the screen,then the system gets stuck.
Maybe there is another problem? it seems it cannot go further than the log in.
 
Old 04-05-2009, 09:33 AM   #30
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,141

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
Well, that's somewhat better. With the dhclient getting you connected you can add a few helpful programs and, perhaps, move forward.

And the "no longer fade to black" is also perhaps a good thing.

First, though, boot again to the command prompt and use nano to change the xorg.conf.failsafe "Driver" entry bach to vesa, reboot in rescue mode, and pick the "Failsafe" option to see if you can, at least, now use the vesa driver without it doing the "fade to black" thing.

What I'm suspecting is that Ubuntu may be defaulting to using 3D graphic effects, but that the openchrome driver may not yet support those modes. In the failsafe mode, Ubuntu may not attempt to use those effects.

Anyhow, if the vesa driver now works, you can use the "failsafe" mode login to try to fix things using a GUI, and, if it doesn't work, that will tell us something interesting as well.

So, please try the vesa mode and let us know what happens.
 
  


Reply

Tags
boot, openchrome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu getting stuck sulekha Ubuntu 1 10-16-2008 01:24 PM
Ubuntu Stuck rony2 Ubuntu 6 08-07-2008 06:03 AM
Why is partitioning stuck at 0%? (Ubuntu 7.10) Herr Wolf Linux - Newbie 2 04-30-2008 06:00 PM
First Ubuntu try: Stuck on Grub svar Ubuntu 4 06-14-2006 11:12 AM
mandrake 10 command line to gui boot, then stuck at boot with hour glass chris008 Linux - Laptop and Netbook 1 11-14-2004 05:29 PM


All times are GMT -5. The time now is 02:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration