LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-26-2009, 12:48 PM   #1
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Rep: Reputation: 0
Unhappy ubuntu 8.10 stuck just after boot


Hi there!
I've just intalled Ubuntu 8.10 on my laptop(Sansui style note, 1.8 Gb cpu, 512Mb ram,VIA S3 garphic chip).For some reason I decided to wipe my previous OS out and use only ubuntu. I did the installation on simple graphic mode(the one in normal mode failed) and it went through succesfully, then when I was asked to restart the system the desktop faded in colour and got funny things like a mistuned monitor. I switched the laptop off manually and switched on again.It did the boot and loaded ubuntu, but instead of the log in page it was the same blurry screen and I can do nothing.I checked the Bios set up and it gives me the option to state the OS(Windows or other)and I chose other.
I asked an IT tech on what it could be and he said that maybe is a graphic chip issue,and suggested me to browse a forum so Here I am!
Thanx for your help!
Marco

Last edited by marco v.; 03-26-2009 at 01:28 PM.
 
Old 03-27-2009, 09:58 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Originally Posted by marco v. View Post
Hi there!
I've just intalled Ubuntu 8.10 on my laptop(Sansui style note, 1.8 Gb cpu, 512Mb ram,VIA S3 garphic chip).For some reason I decided to wipe my previous OS out and use only ubuntu.
Sounds like you had an attack of sanity.
Quote:
I did the installation on simple graphic mode(the one in normal mode failed) and it went through succesfully,
in what way did the normal mode fail?
Quote:
then when I was asked to restart the system the desktop faded in colour and got funny things like a mistuned monitor. I switched the laptop off manually and switched on again.It did the boot and loaded ubuntu, but instead of the log in page it was the same blurry screen and I can do nothing.I checked the Bios set up and it gives me the option to state the OS(Windows or other)and I chose other.
It sounds ominous that you even have an os selection in BIOS. I've never heard of this before. What happens if you try it on the "windows" setting?
Quote:
I asked an IT tech on what it could be and he said that maybe is a graphic chip issue,
It certainly sounds like it.
Your graphics card uses a VIA S3 chipset?
It can help to know the exact laptop model - can you point to a web page featuring your machine?

Can you run Ubuntu as a live distro (you may need to use safe graphics mode - explore the function-keys from the bootup menu of the live disk)?
 
Old 03-28-2009, 11:18 AM   #3
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I ran ubuntu in live cd mode and a msg appeared: Ubuntu is ruuning in low graphic mode and is not compatible with the graphic card. I have a Via S3 chipset. At the boot also appeared this msg: error 8254 timer not connected to I/O apic.I tried to find ouy about my laptop but I didnt find anything on the web.Funny eh?
Thanx for your hel[p and yes finally I ad an attack of sanity and I am very proud of myself!!!!!!!!!!!!

.
 
Old 03-28-2009, 11:22 AM   #4
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Hi Simon!
I did what you suggested and I ran Ubuntu in live mode(in a safe graphic mode), and it's been very useful. A notice window popped up saying that ubuntu is runing in low graphic mode and cannot recognise my graphic card.Then it faded to black screen and i cannot take aby action.My graphic card uses a Via S3 chpset.Unfortunately I cannot find my laptop's specs.
I also saw an error at the boot:number 8254 Timer not connected to I/O APIC
The Bios installed in my laptop is a Phoenix Bios M550SE/M540SE Revision 1.00.11, I changed the option for the Os and nothing changed.
 
Old 03-28-2009, 12:01 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
I used to have a Gateway MX6436 that poped that "timer not connected" message, and found that adding the enable_8254_timer option to the GRUB kernel line in /boot/grub/menu.lst fixed the problem. Others have suggested the more drastic noapci option.

As to your display problem, as a temporary "work around," try booting in rescue, command line, mode and using nano to change the display driver section of /etc/X11/xorg.conf to specify the vesa driver instead of the via one. vesa doesn't support any fancy graphics, but it usually works. (You could uses nano to fix /boot/grub/menu.lst at the same time.)

If the vesa driver works, your chip is probably OK. So see if you can find a different via driver (perhaps an older one?) to try.

Last edited by PTrenholme; 03-28-2009 at 12:02 PM.
 
Old 03-28-2009, 03:25 PM   #6
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I ama fraid you must very patient with me!I am in in grub,pressed c forcommand line but nano is not recognized and I dont know almost anything of linux and its commands.Has anybody a chance to guide me thru this command line, I think that giving my miserable graphic card something very simple to do could work
 
Old 03-28-2009, 05:21 PM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Ah, that's not the "Linux command line," that's the "GRUB command line."

However, you can try a few things from there or, rather, from the GRUB prompt screen.

First, either go back to the GRUB boot screen from the command prompt (by pressing the "Escape" key) or don't press "c" in the first place.

Now, using the arrow keys on the keyboard, highlight the Ubuntu boot line and press "e" to open the boot stanza in the editor. (Note that the GRUB editor only changes the RAM copy of the boot stanza, so any changes you make will be lost when it read the menu.lst file during the next boot. This is, actually, a "good thing" because you can try various settings 'till you find one that works, just rebooting if a change doesn't work.)

When you press the "e," the whole boot stanza should be displayed. It should look somewhat like this:
Code:
title           Ubuntu 8.10, kernel 2.6.27-11-generic                                 
uuid            c5774ce9-8e08-4571-bd45-c99567172463                                  
kernel          /boot/vmlinuz-2.6.27-11-generic root=UUID=c5774ce9-8e08-4571-bd45-c99567172463 ro nohpet xforcevesa quiet splash                                                                                                  
initrd          /boot/initrd.img-2.6.27-11-generic                                                               
quiet                                                                                                            
savedefault
Use the arrow keys to highlight line in the stanza that starts with the word "kernel." and, once again, press the "e" key to open that line in the editor. Note where I've emphasized the kernel option nohept in that line. That's where kernel options are normally placed, although they can be placed anywhere after the compress boot kernel image (/boot/vmlinuz-2.6.27-11-generic in the above example) location.

When the editor opens the line, your cursor will be placed at the end of the line. So you need to use the left arrow key to move back to the ro in the line. (The displayed line will shift as needed to keep the cursor approximately centered.)

Once you've got your cursor located after the ro you can enter the enable_8254_timer option and/or the noapci option. Then press the return key (anywhere in the line) to accept the changes you've made and redisplay the boot stanza.

At this point you can press the "b" key to boot from the modified stanza and see if the change you made makes any difference.

--------------------------------

To address your question about the "real" command line, you can access that be opening a terminal (which is an option in the "System" menu) or, as I suggested above, by booting in "rescue" mode and selecting the "Root terminal" option at the bottom of the list of recovery options displayed. (You may need to scroll the window to see that option.) Once Ubuntu has booted, the nano command should be available. If not, you'll need to connect to your Internet service provider and issue the command apt-get install nano. (By the way, if you're using a wireless connection and you've initialized your connection parameters, the command dhclient wlan0 will often establish the connection for you to use.)
 
Old 03-28-2009, 10:40 PM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
PTrenholme is saying what I would have - try the vesa driver. It will, at least, get you a screen you can use to do stuff with.

If you get to a terminal, you can enter lspci and copy over the line which talks about your graphics card. Googling this card with your distro can tell you what needs to be done. Probably a matter of upgrading.

@PTrenholme: thanks - when one person goes to bed another wakes up
 
Old 03-29-2009, 06:09 AM   #9
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I've just tried to insert the new commands you suggested(both of them) but didnt work.I pressed ctrl+alt+del just after the loading of ubuntuand a text mode window appeared saying that couldnt open the x server due some internal error. Should I try to open in recovery mode and enter "try to fix x server"?
 
Old 03-29-2009, 11:04 AM   #10
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Why on Earth did you press ctrl-alt-del after Ubuntu started? "Crtl-alt-del" is used to reboot the system.

Just make the change in GRUB before Ubuntu even starts to load, from the same place where you got the GRUB command line.

Then let the Ubuntu boot finish, if it does.

<edit>
Oh, you should try the changes one at a time since the noapci option will, I believe, disable the enable_8524-timer option -- as well as lots of other functionality. (That's why it's a "drastic" option to try, but it might get the VIA driver working.)
</edit>

Last edited by PTrenholme; 03-30-2009 at 11:02 AM.
 
Old 03-29-2009, 09:51 PM   #11
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
I've just tried to insert the new commands you suggested(both of them) but didnt work.
You need to be explicit - did you edit the kernel line of the installed menu.lst as advised?

If so -
then how did you determine that it did not work
(note ctrl+alt+del will erase the changes - so it won't determine anything.)

If not -

Boot off the hard drive (no live disk).
Follow the instructions to edit the kernel line.
 
Old 03-30-2009, 02:31 AM   #12
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Sorry guys I realized right now I havent been as explicit as I should. Now I have just edited the noapci command on the kernel line.The error message(error 8254)is stll there and a screen with no option and absolutely useless and then it fades to black.I am waiting ten minutes and then I will reboot the system.Irebboted an edited the command enabel_8254_timer,but nothing has changed.I can see in Ptre's quote the last command is "savedefault" which is not in mine, maybe it does not make any difference,but I need to give you all the details I can find.Grub is the only place I can do something!
 
Old 03-30-2009, 08:43 AM   #13
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,206

Rep: Reputation: 230Reputation: 230Reputation: 230
marco v.:

Boot again the live cd installer, and as instructed above, use Esc or Tab, then "e" to edit the kernel line, try adding this after the "ro" switch -- <remember put space, just space>

noapic vga=normal

hit Enter

then, press "b" to boot, find out what comes and check back.

Goodluck.

Last edited by malekmustaq; 03-30-2009 at 08:59 AM.
 
Old 03-30-2009, 11:41 AM   #14
marco v.
LQ Newbie
 
Registered: Mar 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I exactly did what you malek suggested. the error msg diappeared but the screen freezes as soon ubuntu is loaded the log in page does not even appear
 
Old 03-30-2009, 12:25 PM   #15
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,147

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
First, I should have noted that the GRUB boot commands I showed, above, were copied from my Ubuntu menu.lst file. Some of those commands are not, strictly speaking, part of the GRUB boot stanza, so GRUB doesn't bother to show then in it's "Edit" screen. When you get your system running and look at your "real" /boot/rub/menu.lst you'll probably see similar lines in it. Specifically, all the "savedefault" line does is tell GRUB to save the number of the stanza from which you're booting, and use that as the default the next time you boot. It (and any other "hidden" lines) are of no significance to your problem since the "hidden" lines control GRUB, not the system being booted by GRUB.

Now, to return to your problem:

If the enable_8254_timer kernel option had no effect, your laptop may not have the timer chip installed or the laptop's BIOS may need to be upgraded.

If the noapci option didn't fix the display problem, your technical guru may have been correct when he suggested that your laptop's main board may be damaged. Or, again, you may need to updated your BIOS.

Check on the website of your laptop's manufacturer to see if there's a BIOS update available for your system.

---

Apparently your GRUB menu doesn't have the "(Rescue mode)" option showing, since you haven't mentioned trying it.

To boot in "rescue" mode, add the word "single" at the end of the kernel line (with a preceding blank, of course) in the GRUB boot stanza.

That should give you the various "rescue" options again. If I recall correctly, you did manage to try the vesa mode once, and got the "fade to black" behaviour, but (if the "rescue" options are shown) you could try the "boot in low resolution mode" option again to see if that helps.

Anyhow, once you get to the command line in rescue mode, you can check what's in /etc/X11/xorg.conf to see what's in the driver section for your display. Here's the command I'd use (in bold) and the output I get on my laptop:
Code:
$ cat /etc/X11/xorg.conf | grep -v '^ *#' | grep -v '^ *$' | grep -A 5 'Section "Device"'
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7150M / nForce 630M"
EndSection
(The three grep commands after the cat command that actually types the file's contents does this:
  1. grep -v '^ *#' - Remove all comment lines
  2. grep -v '^ *$' - Remove all empty lines
  3. grep -A 5 '"Section "Device"' - Print the line containing Section "Device" and the next five lines.
)

If you can get to the point of seeing that section (which will, of course, be different from what I have since my laptop uses a nVidia video chip set), you can see if you have the nano editor installed and can try various drivers by changing the Driver line the the Device stanza. We've already suggested the vesa driver, but you could also try s3 or vga16, or, perhaps, savage.

After you save any change to the xorg.conf file, you can try it out by issuing the command startx to (try to) start the X-server. Note that, if the server fails to start, you should see a few error messages and then a pause of several seconds before the command input prompt is displayed. (The pause is the X-server waiting for the display to start, which it won't do because of the errors.)

Please keep us posted with your progress - if any.

Last edited by PTrenholme; 03-30-2009 at 12:27 PM.
 
  


Reply

Tags
boot, openchrome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu getting stuck sulekha Ubuntu 1 10-16-2008 01:24 PM
Ubuntu Stuck rony2 Ubuntu 6 08-07-2008 06:03 AM
Why is partitioning stuck at 0%? (Ubuntu 7.10) Herr Wolf Linux - Newbie 2 04-30-2008 06:00 PM
First Ubuntu try: Stuck on Grub svar Ubuntu 4 06-14-2006 11:12 AM
mandrake 10 command line to gui boot, then stuck at boot with hour glass chris008 Linux - Laptop and Netbook 1 11-14-2004 05:29 PM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration