LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-25-2012, 05:28 PM   #1
lavere
LQ Newbie
 
Registered: Jun 2011
Posts: 8

Rep: Reputation: Disabled
Ubuntu 12.04 LTS very slow to mount internal hard drive


I have an NTFS 500 GB internal drive on which I keep my mp3's. There are a lot of them, over 26,000 files. Ubuntu is having a really hard time with this drive. I can't access files for a long time after I mount the drive, if at all. During this time, I'm also having trouble accessing other drives, as well, as though Nautilus is busy. There isn't any disk activity (according to the drive light on the desktop), so I'm wondering what's going on.

I rebooted into the XP partition and was able to get to the files immediately. I did notice that it was very fragmented so I defragged and rebooted into Ubuntu. Access in linux was a little quicker, but still unacceptable.

Any ideas what the problem is?
 
Old 05-25-2012, 06:27 PM   #2
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,752

Rep: Reputation: 189Reputation: 189
How are you mounting that NTFS drive?
Post your /etc/fstab file or your ntfs-3g command if you are mounting it manually. Or the output of mount after the drive is mounted.

Quote:
There are a lot of them, over 26,000 files
Are they all in the same directory?

Sounds like there may be a lot of reading going on for a while. When you are having that slow down you may look at the output of top to see if it shows you any process that it running hard.

You may also try to mount the drive manually.
http://linux.die.net/man/8/ntfs-3g
 
Old 05-26-2012, 10:07 AM   #3
lavere
LQ Newbie
 
Registered: Jun 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
teckk,

Quote:
How are you mounting that NTFS drive?
I'm just using Nautilus to mount the drive from the Places drop down list on the main desktop page.

Quote:
Post your /etc/fstab file
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=7df04340-8056-4378-897f-fc54177fb953 / ext4 errors=remount-ro 0 1
# /home was on /dev/sda5 during installation
UUID=1f08ef78-060c-4af3-87f7-7f058974c0d0 /home ext4 defaults 0 2
# swap was on /dev/sda6 during installation
UUID=7d8b0d85-4805-4058-b4e5-b6a03e4bae42 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0


Quote:
Are they all in the same directory?
No, the root directory is broken down by artist, then into cd sized folders.

Quote:
When you are having that slow down you may look at the output of top to see if it shows you any process that it running hard.
top reports 96-97 %cpu time is going on during the slow time. Wow. No wonder it's taking so long to load. But why? Is there something I can do to fix it?
 
Old 05-26-2012, 04:33 PM   #4
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,752

Rep: Reputation: 189Reputation: 189
There is no mention of it in your fstab
Can you mount the drive manually? Something like
Code:
ntfs-3g /dev/sdb1 ~/folder_name
Use your own paths and device name. That's assuming that you have ntfs-3g installed. If not, install it.

http://www.swook.net/2011/10/slow-nt...h-oneiric.html
http://www.tuxera.com/community/ntfs-3g-faq/#slow
http://ubuntuforums.org/showthread.php?t=1039328

They may be something else that a buntu user can tell you.
 
Old 05-28-2012, 11:44 PM   #5
lavere
LQ Newbie
 
Registered: Jun 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
I have an update on this problem.

It got to where Ubuntu didn't even "see" the drive that the mp3 files are on. In fact, it didn't see any of the logical drives on that large physical drive.
It's a 2TB drive divided into 3 logical drives. One has data, one has mp3's and one has videos. Ubuntu lost track of the whole drive. I couldn't see it using fdisk -l, lshw, etc.

Just for kicks, I booted into an older version of Kubuntu. Bingo. All the drives are back and access is fast. Although they're still not listed in Kubuntu's fstab, they are listed in fdisk -l and lshw.

So the problem appears to be in Ubuntu 12.04 LTS.

Any ideas?
 
Old 05-31-2012, 01:08 PM   #6
lavere
LQ Newbie
 
Registered: Jun 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
After my successful experience using Kubuntu to access my mp3 drive, I decided to install the Kubuntu file browser Dolphin on my Ubuntu installation. It took a while to download (dialup) but when it was done, I was able to access that drive quickly, as it should be. Dolphin is really a KDE app, so in a gnome environment it's a little out of place but it told me what I wanted to know. Was the problem with that basic Ubuntu 12.04 LTS upgrade or something else?

Conclusion: Nautilus was the bottleneck in accessing my mp3 drive. I'm going to reinstall Nautilus and see if that will improve the situation since I really prefer it to Dolphin.

I'll report back when I know more.
 
Old 05-31-2012, 03:35 PM   #7
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,752

Rep: Reputation: 189Reputation: 189
That's why I suggested that you mount it manually instead of udev and nautilus.
 
Old 05-31-2012, 04:57 PM   #8
lavere
LQ Newbie
 
Registered: Jun 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
teckk,

If you read back through the thread, you can see that I had lost all trace of the drive. It didn't exist with gparted, lshw, fdisk -l, etc.

I couldn't mount a drive manually that linux was not "seeing".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I mount an internal hard drive on startup? Tomorrows_Gone Linux - Software 1 05-28-2011 07:15 PM
Internal Hard Drive fails to mount. Jeff91 Linux - Hardware 1 02-14-2010 06:43 PM
Need to mount second internal hard drive LinuxLiker Linux - Hardware 1 02-28-2009 08:01 AM
Howto Mount Second Internal Hard Drive GNewbie Ubuntu 5 06-20-2008 01:49 AM
Debian Cannot Mount Second Internal Hard Drive bertmag Linux - Hardware 13 01-30-2008 01:22 PM


All times are GMT -5. The time now is 09:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration