LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2011, 09:10 PM   #1
Skeeve
LQ Newbie
 
Registered: Oct 2011
Location: Washington State, USA
Distribution: Ubuntu 11
Posts: 5

Rep: Reputation: Disabled
Ubuntu 11.10: Read Only File System after update


I recently "upgraded" my system from Ubuntu 10.4 to Ubuntu 11.10. The process seemed to complete well enough, but yesterday (19 October 2011) I installed recommended updates and something went wrong. I have my installation and /home folder on a 40 GB drive with a single partition. I have been moving my data files to a 2 TB drive, also with a single partition, and I have an external 80 GB drive I use for backups.

After installing updates yesterday, I attempted to move a Thunderbird email message to the 2TB drive and was informed that the drive was in use by another process. Nothing else was running, at the time, so I looked up the properties for the folder I was attempting to use and found the permissions set to Access Files as opposed to Read/Write. When I attempted to reset the permissions I received a error message saying the File System is read only.

Since then I have discovered that my 80 GB backup drive is also listed as a Read Only File System. I have looked at a number of posts reputed to be pertinent to this issue, some quite old. However, I have not been able to find an effective solution to my problem. Any help would be appreciated.
 
Old 10-20-2011, 09:31 PM   #2
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
Check you fstab file and see that it isn't configure to mount as ro.

If it is, change it to rw.
Try to umount the filesystem and remount with -o rw.
 
Old 10-21-2011, 02:17 AM   #3
Skeeve
LQ Newbie
 
Registered: Oct 2011
Location: Washington State, USA
Distribution: Ubuntu 11
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thank you for your reply. You said:

Check you fstab file and see that it isn't configure to mount as ro.

My fstab file is not very revealing in this case. Perhaps I do not know enough to read it correctly. In the first place, neither of the drives I am concerned with seem to show up in the fstab listing. There are three devices listed: sda1, sdb1, and sdb5. sda1 and sdb5 are listed as <type> ext4. sdb1 is listed as swap. The drives I am looking for are both ntfs, if I read the fstab documentation correctly. I have an <options> on sda1 that reads "errors=remount-ro" which may have something to do with the problem, but I can't save the fstab file if I change it.

I have read through "How to edit and understand /etc/fstab" but did not find a way to actually edit the file. I can display it, but not save changes. How should I proceed?
 
Old 10-21-2011, 03:24 AM   #4
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
So unmont the devices in question and remount them.
You should use the sudo command.
Research a bit and you will learn a lot.

Last edited by hen770; 10-21-2011 at 08:50 AM.
 
1 members found this post helpful.
Old 10-21-2011, 01:09 PM   #5
Skeeve
LQ Newbie
 
Registered: Oct 2011
Location: Washington State, USA
Distribution: Ubuntu 11
Posts: 5

Original Poster
Rep: Reputation: Disabled
Hello again. You said:

So unmont the devices in question and remount them.
You should use the sudo command.

I admit I have learned a lot, but apparently not sufficient to complete the task. I managed to find a device ID to unmount by going to the /etc/fstab and /etc/mtab files. Using

sudo umount /dev/sdb1 -v

I was able to unmount the volume. However, when I attempt to use the 'mount' command using either the device ID or the device name, as listed in the mtab file while the drive is mounted, I get the following message:

mount: can't find /dev/sdd1 in /etc/fstab or /etc/mtab

The message is absolutely correct because both the fstab and mtab files are dynamic. As soon as I unmount the drive, it disappears from both tables. Further, I have not been able to find a way to edit the tables ... which makes a certain amount of sense if they are dynamic OS files. Editing them by force could be extraordinarily messy for a neophyte to Linux.

Apparently I have missed the point of the exercise. I have seen the umount - mount stuff in other forums, but I simply can't seem to get it to work. Any comments?
 
Old 10-21-2011, 07:07 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,533

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Too much confusion, not enough data to help with.
Dynamic remounting as read only is generally because of errors on the filesystem, and the mount options (in fstab as you found). Attempting to remount as writable will generally fail for the same reason.
Have you re-booted ?. Did they mount successfully ?.
After a reboot, post the output of these commands
Code:
df -hT
cat /etc/fstab
sudo parted -l
That's a lower case ell ...
 
Old 10-21-2011, 08:03 PM   #7
Skeeve
LQ Newbie
 
Registered: Oct 2011
Location: Washington State, USA
Distribution: Ubuntu 11
Posts: 5

Original Poster
Rep: Reputation: Disabled
After a reboot, post the output of these commands

df -hT:

Filesystem Type Size Used Avail Use% Mounted on
/dev/sdc6 ext4 15G 9.1G 4.5G 68% /
udev devtmpfs 1000M 4.0K 1000M 1% /dev
tmpfs tmpfs 403M 848K 402M 1% /run
none tmpfs 5.0M 0 5.0M 0% /run/lock
none tmpfs 1007M 1.6M 1006M 1% /run/shm
/dev/sdd1 ntfs 75G 25G 51G 33% /media/Ispec80GigExt
/dev/sdb1 ntfs 1.9T 11G 1.9T 1% /media/Ispec 2T

cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sdb6 during installation
UUID=f4ca3ce8-3ff9-41ca-bb0a-cb47e3f7c2f9 / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb7 during installation

On a whim I decided to list this, also:

cat /etc/mtab

/dev/sdc6 / ext4 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
sysfs /sys sysfs rw,noexec,nosuid,nodev 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
udev /dev devtmpfs rw,mode=0755 0 0
devpts /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
tmpfs /run tmpfs rw,noexec,nosuid,size=10%,mode=0755 0 0
none /run/lock tmpfs rw,noexec,nosuid,nodev,size=5242880 0 0
none /run/shm tmpfs rw,nosuid,nodev 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/stevep/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=stevep 0 0
/dev/sdd1 /media/Ispec80GigExt ntfs ro,nosuid,nodev,uid=1000,gid=1000,dmask=0077,fmask=0177,uhelper=udisks 0 0
/dev/sdb1 /media/Ispec\0402T ntfs ro,nosuid,nodev,uid=1000,gid=1000,dmask=0077,fmask=0177,uhelper=udisks 0 0

The last two entries are those which concern me. I rebooted just prior to making these extracts.

As you can see, the volumes of interest mounted ro and I really need rw.
UUID=91c8407c-17df-460a-bb79-bcc44aae5dd0 none swap sw 0 0

sudo parted -l

Model: ATA WDC WD400BB-75CA (scsi)
Disk /dev/sda: 40.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 40.0GB 40.0GB primary ext4 boot


Model: ATA ST2000DL003-9VT1 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 2000GB 2000GB primary ntfs


Model: ATA ST96812AS (scsi)
Disk /dev/sdc: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 39.9GB 39.9GB primary ext4
2 39.9GB 60.0GB 20.1GB extended
6 39.9GB 55.4GB 15.4GB logical ext4
7 55.4GB 57.5GB 2141MB logical linux-swap(v1)
5 57.5GB 60.0GB 2496MB logical linux-swap(v1)


Model: SAMSUNG HM080JI (scsi)
Disk /dev/sdd: 80.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 80.1GB 80.1GB primary ntfs
 
Old 10-21-2011, 10:14 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,533

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Looks like you're missing the ntfs-3g driver. Presumably using the in-kernel driver - hence read only.

Let me say that I abandoned upgrades for Ubuntu years ago; nothing but trouble. I dual-boot with a common (separate) /home partition.
 
Old 10-22-2011, 12:58 PM   #9
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
so install the ntfs-3g by :
Code:
sudo apt-get install ntfs-3g
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting a read only file system Ubuntu 10.04 metallica1973 Linux - General 2 01-28-2011 10:22 AM
Read-only System when update kernel from 2.6.30-r6 to 2.6.31 Danial_Feng Linux - Kernel 1 09-26-2009 08:47 PM
Read Only File System? Can't read superblock! haughjd Linux - Software 4 01-15-2008 08:27 AM
How to read variable from one file & update its value in another file minil Programming 1 03-22-2005 12:12 AM
Change from Read only to Read Write File System? justiceisblind Linux - Newbie 3 03-03-2002 07:23 PM


All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration