LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2011, 10:12 PM   #1
Chortle
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Rep: Reputation: Disabled
Ubuntu 11.04 - PyOpenCL / numbpy /


When I try to install python-pyopencl I get

Quote:
The following packages have unmet dependencies:
python-pyopencl: Depends: libboost-python1.42.0 (>= 1.42.0-1) but 1.42.0-4ubuntu2 is to be installed
Depends: libc6 (>= 2.4) but 2.13-0ubuntu13 is to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
Depends: libstdc++6 (>= 4.4.0) but 4.5.2-8ubuntu4 is to be installed
Depends: python (>= 2.6) but 2.7.1-0ubuntu5 is to be installed
Depends: python-pytools (>= 7) but 10-7 is to be installed
Same sort of conflicts for numbpy. How do I get around this sort of conflict?
 
Old 09-07-2011, 10:24 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
1)
sudo apt-get update

2)
sudo apt-get install python-numpy python-pyopencl
 
Old 09-07-2011, 10:39 PM   #3
Chortle
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Really appreciate your taking the time to reply. I didn't realise you could do that. Have a problem when I tried it
Quote:
The following packages have unmet dependencies:
python-numpy : Depends: libblas3gf but it is not going to be installed or
libblas.so.3gf or
libatlas3gf-base but it is not going to be installed
Depends: liblapack3gf but it is not going to be installed or
liblapack.so.3gf or
libatlas3gf-base but it is not going to be installed
python-pyopencl : Depends: nvidia-current but it is not going to be installed
Recommends: nvidia-opencl-icd but it is not installable
E: Broken packages

I have AMD graphics cards (2 x 6950s). I've seen this Nvidia problem pop up elsewhere when I tried installation. I will have to fiddle around to see how to proceed.

Last edited by Chortle; 09-07-2011 at 10:40 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Ubuntu live CD will let you upgrade to newer Ubuntu versions Ubuntu 11.04 Development LXer Syndicated Linux News 0 03-01-2011 04:20 PM
LXer: Ubuntu Restricted Extras - Lets Ubuntu Play Everything [Ubuntu for Beginners Sc LXer Syndicated Linux News 0 04-20-2010 01:10 AM
LXer: Upgrade Ubuntu 9.04 (Jaunty Jackalope) to Ubuntu 9.10 (Karmic Koala) Beta LXer Syndicated Linux News 0 10-12-2009 08:50 AM
ubuntu partitioning tool does not see external usb hard drive when installing ubuntu fakie_flip Linux - Software 2 07-30-2006 01:44 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration