LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-29-2011, 01:39 PM   #1
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Rep: Reputation: 0
Ubuntu 11.04 installed alongside Windows 7 resized partition now cannot access either


I have already done the installation process following the guide on Ubuntu's site, got everything up and running but the partition that I made in the installer was too small. I was then directed by a friend (a slightly less inexperienced newbie) to modify this through Easeus Partition Manager. I shrunk the Windows 7 partition to only the space that was in use, giving the newly unallocated space to the Ubuntu partition. Set the changes and rebooted the computer, then got the message "unknown filesystem, grub rescue". Now have no idea what to do with this. What happened??

I've been scouring the forums for something helpful but I can't find anything that is a comparable circumstance.

I can still access Ubuntu through my flashdrive.
 
Old 04-29-2011, 02:03 PM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
You can reinstall Grub from your usb. You did install Ubuntu from the usb? Go to the site below to Section 13.1, Reinstalling Grub from Live CD. If you have the Ubuntu Live CD on the usb and installed from it, that should work.

My understanding of the way this works is that Grub looks at a certain point at the beginning of a partition for boot information. You changed that location when you resized so reinstalling Grub to the mbr should work if you want Grub to boot both.
 
1 members found this post helpful.
Old 04-29-2011, 02:07 PM   #3
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Original Poster
Rep: Reputation: 0
sorry, which site are you referring to?
 
Old 04-29-2011, 03:12 PM   #4
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Original Poster
Rep: Reputation: 0
Yancek- "Go to the site below to Section 13.1, Reinstalling Grub from Live CD. If you have the Ubuntu Live CD on the usb and installed from it, that should work."


-So I went through the install as directed in this guide (tried all three methods) and made it through the install, I was told it was successful.
-Next the directions say to "Reboot" and "Refresh the GRUB 2 menu with sudo update-grub"
-I do this and I get the reply "error: unknown command 'sudo'"

what's up with this?
 
Old 04-29-2011, 03:36 PM   #5
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,249

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
You have to be part of the sudoers group.
Quote:
$su
passwd:
#visudo
add this line in space beneath root:
Quote:
<username> ALL=(ALL:ALL) ALL
Anyway do it the same way as root.
Atleast that's how mine is.
 
1 members found this post helpful.
Old 04-29-2011, 05:49 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,535

Rep: Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807Reputation: 1807
dual booting with win 7 ( from the OEM ) has very well known problems that are well documented
overview
-- do to MS NOT using a real install dvd ---
1) the oem's use a hidden "rescue partition" at the front of the drive
2) the windows7 bootloader is there ( on the "rescue partition" )
3) grub is setting up the boot menu for NOT USING this "rescue partition" that the OEM's are putting their
menu.lis gets set to use the rescue partition and NOT where windows is so the "other" option in the boot menu dose not work

so during install
1) -- very very very important!!! --
order a install dvd from MS !!!!!!!
2) wait until it shows up in the "snail mail" ( the postman delivers it)
3) use the dvd to reinstall in case of emergency
-- or --
wipe the drive is reinstall win7 without this "rescue partition"

linux install

when you install linux PUT grub on the FIRST LINUX partition and NOT NOT on the MBR
-- let MS have that sp1 WILL NEED IT !!! NO IF'S and ' or butts
win7 sp1 MUST have windows bootloader on the MBR!!!!!

then change the "boot" label from the mbr to the partition YOU but grub on
that way the computer will boot from grub and NOT from MS's bootloader

Last edited by John VV; 04-30-2011 at 12:58 AM.
 
Old 04-29-2011, 05:50 PM   #7
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Quote:
sorry, which site are you referring to?
My fault, forgot the link. It's here. Is this the one you used?

https://help.ubuntu.com/community/Grub2

The first option is the easiest, I've never had any problems with it. If it works and you have removed the usb so it boots the hard drive install, you should be good. Since you have another operating system, you may need to run the sudo update-grub.

Last edited by yancek; 04-29-2011 at 05:54 PM.
 
Old 04-29-2011, 06:11 PM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,249

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
@john VV
I know exactly what you're refering toI just installed wheezy on acer aspire laptop, which has 3 partitions, 1 of them hidden (PQService). Actually grub didn't want to install to it.
1stx. I gad extra space on drive, when debian installed instead of making 4th partition it resized the extended & placed itself within that partition resulting in read errors. On this 1 it installed grub.
2ndx. I wanted to reinstall wheezy the installation I erased all of the wheezy partitions including D:/ but I did it with gparted and also was able to remove the extended container as you can see it in gparted. The installation failed at grub not installing.
3rdx. I used gparted again removed all of the partitions within sda3 then removed sda3 changed boot flag to sda1 and enabled d2d in bios. D2D is supposed to be just for recovery but it allowed me to write to boot sector, thus allowing grub to install.
 
Old 04-29-2011, 06:11 PM   #9
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Original Poster
Rep: Reputation: 0
QUOTE= you may need to run the sudo update-grub.[/QUOTE]

Yes this is where my hang up is. My computer isn't recognizing Sudo as a command.

Last edited by Stuck109; 04-29-2011 at 06:44 PM.
 
Old 04-29-2011, 06:44 PM   #10
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Original Poster
Rep: Reputation: 0
Here is what I see at start up


"GNU GRUB version 1.99~rcl-13ubuntu3

Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions."

Any insights here?
 
Old 04-29-2011, 08:43 PM   #11
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,249

Rep: Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579Reputation: 579
As yancek suggested using live cd try this:
https://help.ubuntu.com/community/Grub2#Reinstalling GRUB 2
 
Old 04-29-2011, 09:21 PM   #12
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 39
Quote:
Originally Posted by Stuck109 View Post

Yes this is where my hang up is. My computer isn't recognizing Sudo as a command.

Sudo runs from a file, That lists who may and may not use the SUDO command. Shorten it to 'SU' (assuming you know what the root password is) and it will look like this:

Code:
$ su -l 
password:
root:# update-grub
You may have to add su before update-grub. And as you are typing the password, it will NOT show that you are typing(no letters and no **** to hide it, it will appear empty), so just wait for when password shows up, and type in your ROOT password, and hit enter.
note that -l is -L (not i or 1) for login ... After you're root you can run any command you need. I am about 90% sure that's right (anyone is free to correct me ), Giving it a shot shouldn't hurt though. Good luck!

Last edited by Hevithan; 04-29-2011 at 09:25 PM.
 
Old 04-29-2011, 09:33 PM   #13
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
You said in your first post you can still access Ubuntu through your flash drive. Did you have the Ubuntu Live CD on the flash drive for your installation or are you using a separate CD?

After you run the commands suggested at the web site to reinstall Ubuntu do you reboot, remove the usb/flash drive/CD or whatever you are using for the purpose? Do you then boot into the installation on your hard drive successfully? If so, are you having the problem in a terminal from the hard drive installation?

Quote:
My computer isn't recognizing Sudo as a command.
That's a typo here right? You didn't use uppercase S for sudo? You get this sudo error when you run: sudo update-grub??
You could try sudo su or the suggestions above. Don't know what the problem is?
 
1 members found this post helpful.
Old 04-29-2011, 09:40 PM   #14
Hevithan
Member
 
Registered: Apr 2011
Location: Washington State
Distribution: Zorin5-(Ubuntu 11.04) // Backtrack 5-(Ubuntu 10.04) // Dreamlinux 3.5-(Debian)
Posts: 275
Blog Entries: 5

Rep: Reputation: 39
I just read up a little on Ubuntu, and apparently su won't work, as the root password is not given to the user. I'd still try, but if it doesn't work||HERE|| is a link that explains sudo, how to use it, the downsides, etc ... hopefully you gain some insight with that.

and in case you are just skimming to the most recent posts ... Look above me as yancek points out, that if you are doing Sudo as opposed to sudo, that may be the problem.
 
Old 04-29-2011, 09:50 PM   #15
Stuck109
LQ Newbie
 
Registered: Apr 2011
Location: Canada
Posts: 12

Original Poster
Rep: Reputation: 0
is there a default password? I was never prompted to set one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu LiveCD from ext. HDD alongside Windows Owndapwn Linux - Newbie 18 02-20-2011 05:24 AM
Error msg on trying to install Ubuntu 10.4 alongside Windows ZombyWoof Ubuntu 2 01-28-2011 06:00 AM
Ubuntu says disk is full installed alongside windows and... Dygital_Karma Linux - Laptop and Netbook 2 05-17-2009 11:21 AM
Resized Existing Windows Partition Using QTParted; System now Fudged! Rott3nHippi3 Linux - Software 5 09-07-2007 03:07 PM
resized windows partition no longer accessible jboy22k MEPIS 3 01-24-2006 01:34 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration