LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-06-2012, 09:50 PM   #1
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Rep: Reputation: 16
Ubuntu 11.04 Fluxbox .xinitrc?


Hi everyone,

I have a distro based on Ubuntu 11.04, and the default window manager is OpenBox / LXDE. I want to use Fluxbox instead.

All I want to do is tell Ubuntu to use Fluxbox as the default window manager, instead of OB / LXDE. In Arch Linux, there are simple config files that you can use to accomplish this, like .xinitrc ("exec startfluxbox &") - but I don't see anything like that in Ubuntu.

Also, I don't want to use the Login screen session manager - I want to override the OpenBox / LXDE startup with a Fluxbox startup using a config file. I KNOW there is a way to do this, I just can't find the correct file.

Please help?
 
Old 08-07-2012, 06:11 AM   #2
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Any help on this? I feel like there should just be a local config file which overrides the system-wide behavior of starting OpenBox / LXDE by default.
 
Old 08-07-2012, 09:08 AM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,541

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
Run lxsession-edit and change the window manager to fluxbox.
 
Old 08-07-2012, 09:24 AM   #4
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
Well, that half-worked. Now it appears that I have two window managers running at the same time. For example, now when I right-click, I get the LXDE-OpenBox context menu, AND the Fluxbox menu, overlapping each other.
 
Old 08-07-2012, 02:00 PM   #5
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,541

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
Perhaps toggling the Show menus provided by window managers when desktop is clicked option on the advanced tab of
Code:
pcmanfm --desktop-pref
will help (or perhaps not, but it shouldn't cause any irreparable harm)
 
Old 08-07-2012, 02:18 PM   #6
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 63
Have you tried writing a ~/.xinitrc file for that? I'm pretty sure it will get read.
 
Old 08-07-2012, 02:25 PM   #7
Innervision
Member
 
Registered: Jun 2009
Posts: 75

Original Poster
Rep: Reputation: 16
As far as I can tell, X server isn't even installed on this distro. xinit and startx are unknown commands. I have no idea what is dictating the launch of OpenBox-LXDE.

@RockDoctor: That command had no effect

@bonixavier: Since X server is not installed, a custom xinitrc script won't work here.

Last edited by Innervision; 08-07-2012 at 02:26 PM.
 
Old 08-07-2012, 02:35 PM   #8
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,518

Rep: Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840Reputation: 1840
I thought it was as simple as selecting Fluxbox form the login manager, so it becomes the default for the next and subsequent sessions, then setting the login manager to log in your user automatically? Or are you trying something more specific?
 
Old 08-07-2012, 02:55 PM   #9
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 63
If you don't have xorg-server installed, how can you login to lxde?!?
 
Old 08-07-2012, 03:28 PM   #10
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,541

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
There's always
Code:
apt-get remove openbox
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fluxbox and .xinitrc littlemidget Linux - Software 18 01-02-2005 04:40 PM
.xinitrc, fluxbox, startup programs jdier Linux - Newbie 4 08-26-2004 02:41 PM
.xinitrc fluxbox question Abe_the_Man Linux - General 13 06-28-2004 07:25 AM
.xinitrc/.xsession - Where are they? Fluxbox the_rydster Slackware 3 03-07-2004 01:45 PM
xinit / .xinitrc / xdm / fluxbox kater Slackware 0 02-28-2003 06:03 PM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration