LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-26-2010, 02:20 AM   #1
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Rep: Reputation: 3
UBUNTU 10.10:Wireless modem getting reset to basic settingseverytime I restart


Hi all,


I have a Dell laptop which has braodcom wireless . After I Installed UBUNTU 10.10 my wireless drivers are automatically installed.
THE HAPPEIST PART NO NEED TO DOWNLOAD AGAIN the restricted drivers

I use a dial up broadband so i have to dial usin PPPoe top connect to internet. so when I'm using wireless modem I have to first make sure that the wifi is established and then run PPPoe. i configured the wireless eth1 thru iwconfig with difficulty as it getting the SSID and the key phrase updated to the settings only when i run the command twice.

Ok got connected to the internet and yes my work i dopne i shutdown or restart my system for somereason and here the problem starts , all the configuration done to the iwconfig eth1 is gone again my eth1 is a default one with no SSID. and i thought the problem is da hardware switch ,but NO it was not my eth1 is always ON

HELP ME SOLVE THE PROBLEM...
thankyou in advance

--sekhar
 
Old 10-26-2010, 02:27 AM   #2
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
I think it's easiest to use wicd (wicd.sourceforge.net) instead of the network manager.
 
Old 11-15-2010, 09:53 PM   #3
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
Lightbulb

Quote:
Originally Posted by prayag_pjs View Post
I think it's easiest to use wicd (wicd.sourceforge.net) instead of the network manager.


@prayag: Thnq for ur suggestion and sorry fr this late reply i was busy wid my RHCE certification so couldn't try it then .but yesterday when i tried to use wicd. I had a problem like it is trying to connect to the wifi modem and trying to obtain IP ADDR. but my broadband connection is like it has to get connected to the modem and den i have to dial up the connection using pppoeconf.



This I'm able to do it manual by making the eth1(my wireless driver) up using "ifconfig eth1 up" and then using iwconfig to set essid and key to my modem


So now I guess I'm clear with my question so if anyone feels I'm not so clear pls ask



thankyou in advance

THANKS
rajasekhar,
 
Old 11-15-2010, 10:04 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
go in to settings a set to automatically start ok. little icon bottom right or top right click it go to setting set it to start automatically.
 
Old 11-15-2010, 10:36 PM   #5
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by Drakeo View Post
go in to settings a set to automatically start ok. little icon bottom right or top right click it go to setting set it to start automatically.
THNQ sir ,

But the automatic connection is just connecting and trying to obtain ip address. I also tried da scripts tab to run pon dsl-provider after connecting
 
Old 11-16-2010, 06:19 AM   #6
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,072
Blog Entries: 3

Rep: Reputation: 323Reputation: 323Reputation: 323Reputation: 323
why don't you start over and explain your goal. connect dial up or connect wifi two different protocols. if your are connected with dial up. there is no way to connect to a IP as wifi. so far you have said connect with pppd (dial up) and pppoe (hard wire adsl ethernet card) wifi which is (wpa_supplicant)
how do you want to connect for incoming IP (Internet Provider)
 
Old 11-18-2010, 03:07 PM   #7
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
Lightbulb

Quote:
Originally Posted by Drakeo View Post
why don't you start over and explain your goal. connect dial up or connect wifi two different protocols. if your are connected with dial up. there is no way to connect to a IP as wifi. so far you have said connect with pppd (dial up) and pppoe (hard wire adsl ethernet card) wifi which is (wpa_supplicant)
how do you want to connect for incoming IP (Internet Provider)

@Drakeo : I will explain u in detatil abt the issue here ...

IN WINDOWS 7 ---> i enable my wireless adapater and then connect to my wireless modem and then i dial up dsl-connection using my username and password. and thats it i get connect to internet.

IN UBUNTU --> When i use the ethernet cable mode to connect to internet I use the pppoe command to give my username and passwd to connect to internet

When i use the wireless i have to make the wifi adapter recognise my wifi modem. So i use the "ifconfig" cmd to up the wireless adapter. Then I use the iwconfig command to edit the essid and key configuration, Which I guess is getting reset after restart or a poweroff.

I hope I"m clear now....

I dont have a problem even the solution involves editing configuration files manually.

I thought of a solution i.e., I have to set my wifi config file such that it recognises my modem at the startup and den i have to do just a simple "pon dsl-provider"


HOPE TO GET A +ve REPLY
 
Old 11-30-2010, 02:05 AM   #8
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
Solution????

Help pls ... expecting some solution here !!!!
 
Old 11-30-2010, 02:26 AM   #9
ferris_bewley
LQ Newbie
 
Registered: Dec 2009
Posts: 18

Rep: Reputation: 0
Why not save the session.

Quote:
Originally Posted by rajasekhar19489 View Post
Help pls ... expecting some solution here !!!!

Saving a session may not be ideal but it should work.... but since I do not know which version of linux... here are a couple of hints.
Debian: System> Preferences> Sessions
Ubuntu: System> Preferences> StartUp Applications> [Options Tab] Click Save my current sessions.
Others: should be placed somewhere similar.
 
Old 12-12-2010, 11:05 PM   #10
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
saving the session???

Quote:
Originally Posted by ferris_bewley View Post
Saving a session may not be ideal but it should work.... but since I do not know which version of linux... here are a couple of hints.
Debian: System> Preferences> Sessions
Ubuntu: System> Preferences> StartUp Applications> [Options Tab] Click Save my current sessions.
Others: should be placed somewhere similar.
Heyy .. help me with da session saving settings..

in the command line i have to do these to get my internet thru my my wifi modem

1. ifconfig eth1 up
2. iwconfig eth1 essid BSNL_AP
3. iwconfig eth1 key ********

(Sometimes i have to give these commands twice to make my wifi connected)

4. sudo pon dsl-provider (as i configured my modem previously wid username and passwd)


so how to make my wifi get started as i start da machine using session saving option....


Thnx in advance

sekhar
 
Old 12-21-2010, 09:20 PM   #11
rajasekhar19489
Member
 
Registered: Sep 2010
Location: hyderabad
Distribution: UBUNTU,FEDORA,RHEL5
Posts: 30

Original Poster
Rep: Reputation: 3
Solved

Thanx for all your help i searched in the ubuntu documentation about configuring interfaces which helped me in making the wifi connect in the start up.....

1. I edited the /etc/network/interfaces file setting eth1(wireless device ) to auto start up at first

2. then opened the network connections window dat gets displayed in the system tray and then configured the modem with the settings i set .

3. then used the pppoeconf to connect to my broadband

from then every time i start up i get to use pon dsl-provider only .. with some more editing of interfaces file i can be able to automatically connect to INTERNET directly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WPA2 network; ndiswrapper wireless; Ubuntu 9.04; have to reset router to get online MrCode Linux - Networking 46 04-02-2010 10:18 PM
basic program installation as applied to Wireless using Ubuntu Kitzelmcnickt Linux - Newbie 3 02-13-2009 12:02 PM
Fedora 5 reset/restart problem linuxpp Fedora 4 09-27-2006 10:43 PM
Properties get reset after restart lmetal Slackware 2 08-30-2004 12:27 PM
Configuration file I modified will be reset after restart. ICO Slackware 3 02-12-2004 09:00 PM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration