LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2011, 01:18 PM   #16
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0

OK Following on from your suggestion I read that having a root password is not advisable (certainly not until the user knows what he's doing - and I don't !)

Your thought that this may not work seems to be correct......
So using SUDO and entering password the response was:
mv: cannot stat '/etc/X11/xorg.conf': No such file or directory
 
Old 03-13-2011, 01:28 PM   #17
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Seems ubuntu doesn't use xorg.conf anymore by default.
You can however try to create the file, to see if the error goes away
Code:
cd /etc/X11
sudo X -configure
sudo mv xorg.conf.new xorg.conf
Kind regards
 
1 members found this post helpful.
Old 03-13-2011, 01:33 PM   #18
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,695
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
@ jefro - I had the explicit choice during install (I use Arch) to have sudo installed or not, I dont like the idea of "too many cooks in the kitchen" as the Flemmish saying goes...and sudo might just be a blank invitation to the "kitchen"...
@ Seniorshot

Quote:
OK Following on from your suggestion I read that having a root password is not advisable
Quite the contrary! You need the root password, but use it wisely...like spice on a dish, just enough...
Just use the day-to-day password, and the root password when need be...

Eh...you get the drift

Last edited by ButterflyMelissa; 03-13-2011 at 01:35 PM.
 
Old 03-13-2011, 02:02 PM   #19
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Ok thanks for all the comments but I'm getting a little confused here as to what I should try to do next..

Remembering my problem, and that I am currently in user mode in the terminal after booting into Recovery mode and fail safe graphic mode
Should I :

1. Create a root password is so how do I do that ?
2. How do I move from day to day User mode to root mode from my current position ?
3. Try to find the location of the xorg.conf file (bear in mind I am trying to remove this file). How do I locate it from my current position ?
 
Old 03-13-2011, 02:20 PM   #20
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
1. Create a root password is so how do I do that ?
Not needed, you can use sudo
Quote:
2. How do I move from day to day User mode to root mode from my current position ?
By using sudo
Code:
sudo <command>
Quote:
3. Try to find the location of the xorg.conf file (bear in mind I am trying to remove this file). How do I locate it from my current position ?
You posted the content of the file before.
Quote:
I have managed to review and set the /etc/X11/xorg.conf to my laptop monitor screen settings but still booting into console.
To find the file
Code:
sudo find / -name xorg.conf
Could be it's called Xorg.conf in ubuntu though
Code:
sudo find / -name Xorg.conf
Kind regards

Last edited by repo; 03-13-2011 at 02:22 PM.
 
Old 03-13-2011, 03:07 PM   #21
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,695
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Okay Seniorshot, I must apologise somewhat...repo's option is the best. The program "sudo" allows you to safely "hop" to root mode and back, but I have assumed you were familiar with that command/program. I dont have it installed for other reasons...
Sorry...
I managed to dig up some info about sudo for you, though:
http://www.linuxmanpages.com/man8/sudo.8.php
and
http://www.gratisoft.us/sudo/intro.html

The examples provided by repo should nudge this adventure in the right direction. Just...dotn give up, the pad is the destination, here!
 
Old 03-13-2011, 03:53 PM   #22
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Ok the command sudo find / -name xorg.conf returned :
/user/share/doc/xserver-xorg-video-nouveau/examples/xorg.conf

the command sudo find / -name Xorg.conf
returned me back to prompt without finding anything.
 
Old 03-13-2011, 03:55 PM   #23
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Where did you find the xorg.conf file you posted before?

Kind regards
 
Old 03-13-2011, 04:02 PM   #24
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Found this regarding your video card, you need to add some parameters to grub
Code:
sudo vi /boot/grub/menu.lst
add
Code:
irqpoll
at the end of the line containing
Code:
kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet splash
So it looks like
Code:
kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet splash irqpoll
note,
vmlinuz-2.6.15-26-386 and root=/dev/hda1 can be different at your system, just add irqpoll at the end of the line

Press
Code:
<esc> :wq
To leave vi
reboot

Kind regards

Last edited by repo; 03-13-2011 at 04:15 PM.
 
Old 03-13-2011, 04:04 PM   #25
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Please see post number 7. This was from my first attempt at installing Ubuntu where I could not boot into the GUI only into terminal.
Since then I have done a complete reinstall of both Ubuntu and Xp onto this laptop. Yes, something appears to be different on this install, (don't ask we why)
but at least I can now get into the GUI in reduced graphic mode.
 
Old 03-13-2011, 04:31 PM   #26
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Repo .....Just seen your last post so I'll try that and report back.
 
Old 03-13-2011, 04:40 PM   #27
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
AHHHHH

Entered sudo vi /boot/grub/menu.1st and it opened up a flashing cursor at the top of the screen
and the message "/boot/grub/menu.1st" [New File] at the bottom.

Is it possible to edit this grubfile any other way ?
 
Old 03-13-2011, 04:43 PM   #28
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
/boot/grub/menu.1st
It's
Code:
/boot/grub/menu.lst
l (like linux), not 1

After you made the changes,
Code:
press esc, then type :wq

Kind regards
 
Old 03-13-2011, 05:03 PM   #29
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Sorry Repo I'm having trouble with my typo

I've just entered : sudo vi /boot/grub/menu.lst

but its still saying: "/boot/grub/menu.lst" [New File]

(Note In the terminal the l character does not quite look like l but has a curly base)
 
Old 03-13-2011, 05:17 PM   #30
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Seems ubuntu uses grub2
try
Code:
sudo vi /boot/grub/grub.cfg
You can however make the changes just for 1 boot, whitout editing the file

Reboot, when grub appears, use the arrow keys to select the item you want to boot, press
Code:
ESC
to edit individual menu entries directly.
press
Code:
e
use the arrow keys to navigate to the kernel part,
press
Code:
e
and add
Code:
irqpoll
to the end of the line
press
Code:
enter
press
Code:
e
to boot with the new parameters

Kind regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
booting into console or GUI - Solaris 10 chexmix Solaris / OpenSolaris 12 06-07-2013 02:26 PM
booting from grub gives console messages chursch Ubuntu 5 09-22-2009 01:05 AM
Booting into console... where is the KDE? sherrife Linux - Newbie 4 12-03-2007 06:03 AM
Booting to console? sdouble Linux - Newbie 3 09-19-2004 12:36 PM
booting suse into console instead of x? Moses420ca Linux - Newbie 4 08-27-2003 03:26 PM


All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration