LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-09-2011, 06:55 AM   #1
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Rep: Reputation: 0
Ubuntu 10.10 booting into console


Firstly I'm a complete newbie to Linux so be gentle ! Lots of unfamilar terms being used in these forums - reminds me of my windows experience 20 years ago !!
A friend gave me a copy of Ubuntu 10.10 so I've tried loading it onto an old Compaq Nx9005 Laptop yesterday. The installation seemed to progress OK, I completed all the information prompted for and then tried a reboot- but here's the problem:

It boots into the console but before the login request there are 2 lines:-

19.840039 AC'97 1access is not valid [0xffffffff], removing mixer.
19.840228 ali mixer 1 creating error.

Anyway after trying to login with user name and password it just awaits me to input a command.

Now reading through other posts I tried a Sudo startX command, this produced a large number of additional lines:

Picking out what I think might be helpful in resolving the problem:

X.Org X Server 1.9.0
Build Operating system : Linux 2.6.24-27-server i686 Ubuntu

(EE) Vesa: Kernal modesetting driver in use, refusing to load
(EE) No devices detected

Fatal server error:
No screens found

On the face of it it looks like it could possible be something to do with video drivers and/or sound drivers but just my own very limited assessment. I'm hoping that someone on this forum can come up with a reason and more importantly a solution.!

On another similar problem thread someone suggested that they might be at Run level 2 or 3 instead of run level 5 (Whatever that means!!!!).. well after entering the command run -r it tells me that I'm at level 2 but I can't change that to run level 5 by entering sudo telinit 5 - it just resorts to a command prompt

Last edited by Seniorshot; 03-09-2011 at 07:28 AM. Reason: Additional info added
 
Old 03-09-2011, 09:01 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
Boot into rescue mode and fix X
 
Old 03-09-2011, 11:43 AM   #3
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Hey there Seniorshot,

Welcome to Linux - this reminds me of my first steps, and they were on rougher ground, mind you.

Okay. I guess the X needs to get a (gentle) nudge...read this:
http://www.freebsd.org/doc/en_US.ISO.../x-config.html and
http://www.linuxmanpages.com/man5/xorg.conf.5x.php
for completeness...
I suspect you need to edit a file called /etc/X11/xorg.conf
(by the way, you may want to get used to CaPiTalizing, as Hello is not the same as hello in Linux)
Quote:
Anyway after trying to login with user name and password it just awaits me to input a command.
Okay, so I suspect you see a black screen with (white?) lettering, if so, this is the console.
There are quite a few things you can enter here ( read this http://ss64.com/bash/ ) but possibly the most sensible would be:
- back up the xorg.conf file you have now, just in case:
Quote:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back
this effectively creates a copy (hence cp) of the file.
The Linux system has a structure, maybe a gloss-tru of this page may help http://www.tldp.org/LDP/intro-linux/...ect_03_01.html (somewhere just beyond the middle there's a picture).
Okay, the line "no screens found" means that X (the bit that makes the aim-and-click work) does not really know where to send the output to.
Enter
Quote:
vi /etc/X11/xorg.conf
(vi is a small editor - read this page if need be http://www.eng.hawaii.edu/Tutor/vi.html)
and zip to the "Screen" section. Make sure the resolutions are set/available, google your monitor to find out those details...
Alternatevely, try to make and xorg.conf that caters for VESA. Not optimally, but it is sure to work...
A (possible) setup could be

Quote:
Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection
A lot of reading, but ever so educational.

What this line means:
Quote:
On another similar problem thread someone suggested that they might be at Run level 2 or 3 instead of run level 5 (Whatever that means!!!!).. well after entering the command run -r it tells me that I'm at level 2 but I can't change that to run level 5 by entering sudo telinit 5 - it just resorts to a command promp
is quite simple. Linux can run is several "modes", one if "mode" 5" - graphically. Of course, if the machine is set up to start graphically, and X does not comply, there is no picture. Mode 3 (init 3 to be precise) is a text-only mode. Here's how you enter that mode:
enter
Quote:
vi /etc/inittab
zip to the section that cares for runlevels, comment out the one that sets the machine in X (level 5) and UNcomment the one for level 3, and you're set.

Of course, this stuff need to be done as root. In the console, enter
Quote:
su -
and supply the password as requested...
More info at http://netadmintools.com/html/5inittab.man.html ...

I hope to have "nudged" you in the right direction!

Thor

Last edited by ButterflyMelissa; 03-09-2011 at 11:53 AM. Reason: typos...
 
1 members found this post helpful.
Old 03-10-2011, 11:34 AM   #4
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Hi Thor,
Thank you for your comments.

I have managed to review and set the /etc/X11/xorg.conf to my laptop monitor screen settings but still booting into console.

My xorg.conf is :

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
End Section

Section "Monitor"
Identifier "Configured Monitor"
End Section

Section "Screen"
Identifier "Default Screen"
Monitor " Configured Monitor"
Device " Configured Video device"
Defaultdepth 24
Subsection " Display"
Depth 24
Modes "1024x768"
endsubsection
EndSection

My screen is nothing fancy so this looks quite reasonable to me but can you confirm that this should work on an ageing Laptop?
Also I'm still getting the 2 error lines regarding AC'97 before the login screen .
 
Old 03-10-2011, 11:43 AM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Code:
(EE) Vesa: Kernal modesetting driver in use, refusing to load
(EE) No devices detected
Try to rename /etc/xorg.conf
Code:
sudo mv /etc/xorg.conf /etc/xorg.conf.old
then type
Code:
startx
or
Code:
sudo startx
Kind regards
 
Old 03-10-2011, 12:09 PM   #6
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
@ repo - I concur all the way, X should be clever enuff to figure this out.
Even on a laptop...
W8ing and C-ing
 
Old 03-13-2011, 07:51 AM   #7
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Since my last post I decided to take a step backwards to confirm the CD I received was OK.
I successfully installed ubuntu 10.10 on a desktop computer no problems.
Returning to the Laptop:

I decided to do a complete reinstall of both XP and Ububtu on the Laptop.
When installing Ubuntu this time I had internet connection and the updates were loaded and installed.
Here is my problem now:

I can fire up the laptop and see the Grub Screen (1.98+20100804)
If I choose Option 1 Ubuntu Linux 2.6.35.27 Generic - it boots to the login screen box on purple background.
After logging in I hear drumbeats but I'm then left with just a purple screen - no text no image. System hangs here.
I have to force a power down to get out of this situation.

If I reboot and this time choose Option2 Ubuntu Linux 2.6.35.27 Recovery mode I eventually get a screen which has the Recovery menu BUT over the top of this is an error message in white text on black bavkground
AC'97 1 access is not valid [0xffffffff], removing mixer.
ali mixer 1 creating error.

If I ignore the error message and choose option: "Run in failsafe graphic mode" - I am presented with a GUI box "What would you like to do" - if I choose Run Ubuntu in low graphics mode for just one session - then I can progress to (after logging in ) the normal GUI desktop. (which appears to work fine) .

This leads me to believe that I have a graphics driver problem.
If I go to system>preferences>monitor My monitor preference is shown as Unknown and it will not detect a monitor.
If I go to system>Administration>additional drivers the system shows No propietary drivers are in use on this system.


My graphic driver details are ATI Radeon IGP320M. Now I have been on the ATI(AMD) site and I notice that they have Video drivers for Linux
I have downloaded Firepro_8.773.1.1_Linux_11279.zip which I believe to be the correct driver but it is a Zip file and I have no idea how to get the system to install this or even if its a good idea to install it. ?

I feel that I'm almost there with a working system but I'm not sure how to proceed without the likelyhood of me screwing the system up.

Any further advice would be greatly appreciated.
 
Old 03-13-2011, 09:22 AM   #8
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
'morning Seniorshot...

First of
Quote:
Firstly I'm a complete newbie to Linux
You started of with that remark, then some posts later you have analised the machine inside out. If that's what you are as a newbe, wow, then what follows should be pure gold. You're on the right track of "making it with Linux" - congratzz!

Okay, on to the problem(s) at hand.

Let's give the sound a go, first. I read that you CAN (somehow) get into the machine, graphically. If so, perform a system update. My (wild) guess is that if it is a bug, it'll have been fixed.

Maybe as a way of into: you can install Linux, but as soon as possible and as OFTEN as possible: do an update. Programming is PEOPLE work, and one of the most manual (if not the most manual) activity around. People glitch, that's why some Enlightened Minds came up wit updates

That said, I suspect sound to be a step closer to working.

On to the graphical side of this challenge...

Quote:
I have downloaded Firepro_8.773.1.1_Linux_11279.zip which I believe to be the correct driver but it is a Zip file and I have no idea how to get the system to install this or even if its a good idea to install it. ?
Hmm, that's a great find, but possibly not needed, look at this page ( http://manpages.ubuntu.com/manpages/.../radeon.4.html ) and you'll notice full support...so, I'd stay inside the repo...it's much safer...

What we could do is the following:

We could follow repo's suggestion and "remove" the config file altogether. The software (Xorg) should be clever enough to figure things out. To do this, enter the console, if possible. Follow "applications-accessories-terminal" in the left top menu
Enter this
Quote:
su -
(hyphen included!!!!)
supply the root password
then, enter this:
Quote:
mv /etc/xorg.conf /etc/xorg.conf.old
A small word of warning: this could fail. My xorg.conf "lives" somewhere else, I suspect yours may as well. One spot to find it could be /etc/X11/xorg.conf.
At any rate, once "removed" (we simply renamed it, actually, making it un-findable for xorg) we can give the hires a go.
I'd reboot the system, still as root in the system/terminal? Then enter
Quote:
reboot
If you feel like a read on what Ubuntu has in store for xorg:

https://help.ubuntu.com/community/XORGHardy

Let me know how this works out!

See ya!

Thor
 
Old 03-13-2011, 10:04 AM   #9
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks for your reply Thor.
(Don't be fooled by my earlier posting - I just managed to view the config file and copied the contents - I'm afraid I'm still in windows mode and it will take time the change my mode of working !!)

Ok so I have got into the GUI and opened up the terminal from Applications>Accessories>Terminal.

Now I entered su -

It requested Password ( I have only set 1 password in the whole installation procedure - this being my login password is this the same as Root password ? because
on entering this password I get :
su: Authentication failure followed by another prompt -
roger@roger-HP nx9005-DG194A:~$
 
Old 03-13-2011, 10:25 AM   #10
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Hello Seniorshot,

Okay, there is ONE password you MUST have set during install, and yes, that is the password.

Quote:
I have only set 1 password in the whole installation procedure - this being my login password is this the same as Root password
This worries me a bit...as far as I can tell, you are ONLY in root mode, not really safe.

In the console, ask the system a very existental question:

Quote:
whoami
(no need to run for "professional help" - this is a command Linux provides to find out in what "mode" you're in right now)

Chances are you ARE already Root. If so, there is obviously no need to enter the password again.

As a future precaution, do set up a "day-to-day" password on the system, as it does not have system-wide permissions, the risk of (real) damage is very limited...

I'll be following up!

Thor
 
Old 03-13-2011, 10:38 AM   #11
Seniorshot
LQ Newbie
 
Registered: Mar 2011
Posts: 16

Original Poster
Rep: Reputation: 0
Thor, thanks for your swift reply


The response to whoami is:
Roger
Roger@roger-hp-nx9005-DG194A:~$

So what mode does that tell you I'm in at the moment ?
 
Old 03-13-2011, 11:32 AM   #12
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
Helo Roger,

It means that you are in "day-to-day" user mode, the other answer would have been "root", so, a root password is in order...
You'll need to log in, let me illustrate this with some dummy data

Quote:
[Jones@Mach6 ~]$ su - (enter su-space-hyphen)
Password (whatever you enter here is invisible)
-bash-4.2# (here you are the root - just for fun, NOW enter "whoami" here...)
At the last line (the one with the word "bash") that's where you'd be in root mode, then you can actually "service" the system...

Then, from that point on, you can rename/remove the xorg.conf file as mentionned before.

See? This is the safety aspect of Linux, imagine being able to fiddle around with the system's valuables. Always keep the root password as a last resort.

Luck, and until the next post, because now I am curious as to the outcome...

Thor
 
1 members found this post helpful.
Old 03-13-2011, 01:09 PM   #13
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Since you are in ubuntu, you need to use
sudo
So that would be
Code:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
It will ask for a password, give your password.

Kind regards

Last edited by repo; 03-13-2011 at 01:11 PM.
 
1 members found this post helpful.
Old 03-13-2011, 01:20 PM   #14
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
@ repo - provided he has sudo installed, I did not even assume that. I dont have it installed...
A slight oversight from my part to make the assumption it's not intalled there either...
 
0 members found this post helpful.
Old 03-13-2011, 02:06 PM   #15
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,372

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Sudo ought to be installed but a sudoer's list or entry may be needed.

I have yet to use su -. Dunno. Always used su and return key.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
booting into console or GUI - Solaris 10 chexmix Solaris / OpenSolaris 12 06-07-2013 03:26 PM
booting from grub gives console messages chursch Ubuntu 5 09-22-2009 02:05 AM
Booting into console... where is the KDE? sherrife Linux - Newbie 4 12-03-2007 07:03 AM
Booting to console? sdouble Linux - Newbie 3 09-19-2004 01:36 PM
booting suse into console instead of x? Moses420ca Linux - Newbie 4 08-27-2003 04:26 PM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration