LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2011, 05:37 PM   #1
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Rep: Reputation: 0
(Ubuntu 10.04) Advanced Graphics Won't Work


Hello there,

I have been trying to get the advanced graphics for compiz, emerald, and cairo dock working for a few days now, but alas, I have failed horribly. I tried to uninstall compiz and emerald a few days ago (stupidly) and since then, these problems have arisen. I tried seeking help on ubuntuforums.org, but they were unable to help. You can see the entire thread at the following link: http://ubuntuforums.org/showthread.php?t=1694800&page=2

If you want a detailed list of everything I've done, you can go to that site, but here's a summary:

I entered a series of code that I was lead to believe would eradicate compiz from my system so that I could go through with a full reinstallation. However, the result was that I now can't load any advanced graphics from emerald, compiz or cairo dock. I've tried reinstalling the entire operating system, but I'm getting the same problem. I also tried a live CD for 10.10, but with the same results.

I don't know if this is a relevant piece of information, but one thing of note is that I typed "compiz --replace" into the terminal and got the following:

Code:
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
Starting gtk-window-decorator
compiz (cube) - Warn: Failed to load slide: /usr/share/gdm/themes/Human/ubuntu.png
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported!  This is an application bug!
Again, I don't know if that helps at all, but there it is...

Any help you can give would be most helpful...

-Van
 
Old 02-26-2011, 06:09 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
To help with your problem, create a script called compiz-check, chmod +x the file, and paste in the contents of the following link, and post the output of the script.

http://pastebin.com/geAguQ87

Cheers,

Josh

EDIT: To add, I know it looks like you have a working config, just a small error. I just want to make sure everything is good.

Last edited by corp769; 02-26-2011 at 06:12 PM.
 
Old 02-26-2011, 06:17 PM   #3
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
I apologize for being a bit difficult, but I'm not very experienced with Ubuntu. Could you guide me through how to do what you just requested?
 
Old 02-26-2011, 06:26 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Code:
wget http://blogage.de/files/70708/download -O compiz-check
chmod +x compiz-check
./compiz-check
Do that, and post the output.

Cheers,

Josh
 
Old 02-26-2011, 06:33 PM   #5
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
Code:
Gathering information about your system...

 Distribution:          Ubuntu 10.04
 Desktop environment:   GNOME
 Graphics chip:         Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
 Driver in use:         intel
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [ OK ]
Sorry about the problem. I just didn't understand why you wanted it posted at your link... But there it is.

-Van
 
Old 02-26-2011, 07:10 PM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
OK, looking good. Are you trying to get compiz back up and running, or just your drivers working?
 
Old 02-26-2011, 07:14 PM   #7
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by corp769 View Post
OK, looking good. Are you trying to get compiz back up and running, or just your drivers working?
Compiz is working, at least sort of. I'm able to use the cube functions and all that, but the animations like Burn can be selected but don't show up. In addition, similar animations for cairo dock are also not showing up.
 
Old 02-26-2011, 07:27 PM   #8
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
I'm starting to lean more towards your graphic card with this one....
 
Old 02-26-2011, 07:39 PM   #9
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
I don't know if you read the thread that I linked, but it might be helpful if you knew what I did to uninstall compiz initially:

Code:
sudo aptitude remove libgnome-compiz-manager0 compiz-extra  libcompizconfig0 compiz-dev compiz-gtk compiz-kde compiz-settings  libcompizconfig-backend-gconf compiz-config-ini gcompizthemer  compiz-plugins libgnome-compiz-manager-dev compizconfig-backend-kde  compizconfig-settings-manager python-compizconfig compiz-config-gnome  taskbar-compiz compizconfig-plugin compiz-freedesktop-dev  compiz-fusion-plugins-unofficial compiz-bcop compiz-ccs-settings-manager  libgnome-compiz-manager libcompizconfig0-dev compiztools  compizconfig-settings-legacy compiz-fusion-plugins-extra  compiz-compcomm-plugins-main compiz-fusion-plugins-unsupported compiz  compiz-extra-plugins compiz-fusion-plugins-main  libcompizconfig-backend-kconfig compiz-core compiz-decorator  gnome-compiz-manager compiz-fusion-plugins-main compiz-gnome  libcompizconfig-dev libgnome-compiz-manager0-dev libcompizconfig0  libcompizconfig-backend-gconf libcompizconfig0-dev  libcompizconfig-backend-kconfig libcompizconfig-dev
Before I did that, everything seemed to work fine.

But even if that didn't do it, I'm pretty sure the reason why I'm having this problem is something idiotic on my part. Feel free to mock relentlessly once you find the error...

-Van
 
Old 02-26-2011, 08:06 PM   #10
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
So if everything worked fine before you did that, have you tried installing all the above again to go back to the way it was? I don't fully understand why now, I am partially confused.
 
1 members found this post helpful.
Old 02-26-2011, 09:33 PM   #11
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by corp769 View Post
So if everything worked fine before you did that, have you tried installing all the above again to go back to the way it was? I don't fully understand why now, I am partially confused.
Yup, I thought I had reinstalled everything but I didn't. I should have double-checked...

Feel free to mock and thanks for your patience...
 
Old 02-26-2011, 09:53 PM   #12
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
So is it fixed now or not?
 
Old 02-26-2011, 10:17 PM   #13
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by corp769 View Post
So is it fixed now or not?
Yup... That simple...

*slams head against desk in disgust*
 
Old 02-26-2011, 10:31 PM   #14
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
LOL It's all good man. Mark your thread as solved and add rep if applicable

Cheers!

Josh
 
Old 02-26-2011, 10:46 PM   #15
van1017
LQ Newbie
 
Registered: Feb 2011
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by corp769 View Post
LOL It's all good man. Mark your thread as solved and add rep if applicable

Cheers!

Josh
Done and done, good sir. Take care.

-Van
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Intel 82830 CGC (830m) graphics fix for Ubuntu Lucid 10.04 just might work for LXer Syndicated Linux News 0 02-12-2010 10:10 AM
Ubuntu 9.10 Desktop, Nvidia Graphics issue (Dual screens don't work since install...) mitchell7man Linux - Hardware 2 02-02-2010 11:28 PM
3d graphics seems to work better in ubuntu jag2000 Ubuntu 8 10-20-2007 08:20 PM
How do I configure my wacom graphics tablet to work with ubuntu (inkscape,GIMP etc.) izquierdista Ubuntu 5 10-01-2007 12:05 AM
Will my graphics card work in ubuntu? BlahBlah_X Ubuntu 8 01-17-2007 12:03 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration