LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-26-2008, 05:04 AM   #1
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Rep: Reputation: 0
Ubunto 8.10 hurts my eyes


Hi!

I'm new to Ubuntu having used XP for many years. I have an 5 old GVC laptop bought in Thailand. Everything is greeat, but the resolution realy hurts my eyes. I tried different resolution settings in System options, but it either went too small on 1024x768 (4:3) 60hz or distorted on 800:600 60hz. It doesnt seem to have recognised the screen on my laptop. I do not remember what resolution i had on XP.

I did a hardware scan and it says i have:

VGA compatable controller:
- Silicon Intergrated Systems (Sis) 65x/M650/740 PCI/AGP VGA Display Adapter
- Subsytem: Uniwill Computer Corp device 5100.


I read a few forums that said I need to change things when i run "sudo gedit /etc/X11/xorg.conf"' but all it says is "#

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection
"


Someone suggested updating drivers, but when i go into the drivers in System, it says there are no prioriety drivers on my computer.

I can zoom in and out and most text is ok, but i love playing Wordscraper, a scrabble type game on facebook that runs on Adobe Flash Player. It will not enlarge in Opera/Seamonkey and in firefox it does enlarge but disctorts really badly. I have the latest flash Player downloaded.

Any ideas? I'll need walking through like a kid, as i'm still learning all the different parts.

Thank you for reading my lonnnnng post. Apologies.

J
 
Old 11-26-2008, 05:25 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Posts: 3,366
Blog Entries: 33

Rep: Reputation: 216Reputation: 216Reputation: 216
Hi. Your xorg.conf file is very minimal,

you can add things to change the way your graphics,

keyboard, mouse and touch pad as well as the screen and even fonts directories.

Have you tried to run xorgconfig or xorgcfg from a command line?

Answer the questions with care.

IF you do, you may need root access to change the file.

There is a readme for xorg.conf.

usually available from nvidia and ati, but may also be available from SiS.



But for now, type in a shell/term, cli konsole (kde)...

sudo xorgconfig

And answer the questions.

The defaults will be marked and generally all you need to do is ENTER for each one.

The old file will be saved as /etc/X11/xorg.conf~

If it does not work out you can rename that file and try again...

cp /etc/X11/xorg.conf~ /etc/X11/xorg.conf

see how you go.
 
Old 11-26-2008, 06:20 AM   #3
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Hi Glenspref,

Thanks for your tips. I opened a terminal and tried to run xorgconfig and xorgcfg but it says command not found.

I don't know what you mean on the last tip about shell/term. i've searched xorg.cfg and SiS on google, couldn't find anything i understood. The sudo xorgconfig also turns up as command not found.

I'm as rubbish as my my computer is old.

any other thoughts?
 
Old 11-26-2008, 06:46 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Try starting in recovery mode and running Xfix.
 
Old 11-26-2008, 07:11 AM   #5
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Try this to reconfigure your xorg.

dpkg-reconfigure -phigh -xserver-xorg
 
Old 11-26-2008, 08:00 AM   #6
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by linuxlover.chaitanya View Post
Try this to reconfigure your xorg.

dpkg-reconfigure -phigh -xserver-xorg

I tried this, it didnt seem to do anything. It said

"Unknown option: x
Unknown option: s
Unknown option: e
Unknown option: r
Unknown option: v
Unknown option: e
Unknown option: r
Unknown option: xorg
Usage: dpkg-reconfigure [options] packages
-a, --all Reconfigure all packages.
-u, --unseen-only Show only not yet seen questions.
--default-priority Use default priority instead of low.
--force Force reconfiguration of broken packages.
-f, --frontend Specify debconf frontend to use.
-p, --priority Specify minimum priority question to show.
--terse Enable terse mode.
"
 
Old 11-26-2008, 08:06 AM   #7
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That means it is xserver-xorg, not -xserver-xorg (mind the dash).
 
Old 11-26-2008, 08:13 AM   #8
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73 View Post
That means it is xserver-xorg, not -xserver-xorg (mind the dash).
That said "/usr/sbin/dpkg-reconfigure must be run as root".

Also, really dumb question here, how do you reboot into recovery mode. Do i press f8 or something?

Sorry, i am trying to learn, but i am a 1 day old on this.
 
Old 11-26-2008, 08:17 AM   #9
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Well, if you reboot, there should be a second bootline that boots up in recovery mode.

As for the root thing, this means that the command can only be executed by someone who has administrative powers. If the system was installed by you, that would be - errr - you. So you would place
sudo
before the command
sudo dpkg-reconfigure xserver-xorg
and it will prompt you for your password.
 
Old 11-26-2008, 08:24 AM   #10
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73 View Post
Well, if you reboot, there should be a second bootline that boots up in recovery mode.

As for the root thing, this means that the command can only be executed by someone who has administrative powers. If the system was installed by you, that would be - errr - you. So you would place
sudo
before the command
sudo dpkg-reconfigure xserver-xorg
and it will prompt you for your passwoed.
Thanks, just learnt something new. This command opened, but it asked me a lot of questions about my keyboard that i dont know the answers too. Its just a standard English laptop keyboard.

I answered the q's and it colsed and writes in terminal "xserver-xorg postinst warning: overwriting possibly-customised configuration
file; backup in /etc/X11/xorg.conf.20081126132343
.

It never mentioned monitors/resolution and there were no options to try anything else.
 
Old 11-26-2008, 08:33 AM   #11
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That is what I thought and why I suggested Xfix instead. dpkg-reconfigure is essentially a thing of the past that has lost most of its functionality (and the "xorgconfig" suggested earlier in this thread was dropped completely two years ago) .
As an alternative to Xfix, you could try editing your xorg.conf manually. I imagine that it is only missing refresh rate details or some such.
 
Old 11-26-2008, 08:49 AM   #12
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
i just used Xfix in recovery mode, it did nothing and just said:
xserver-xorg postinst warning: overwriting possibly-customised configuration
file; backup in etc.....

I wouldnt know how to change code, i'm not a technical person.
 
Old 11-26-2008, 09:18 AM   #13
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
OK, different approach: start a terminal (under Applications) and enter gksudo displayconfig-gtk.
If that still does not work, there is only one option and that would be to edit the xorg.conf file directly. Do not worry, that is nothing like editing code but you do need to know what to put in. If you do not, then there is something that appears to have worked very well for others and that is not difficult at all. Basically, you would have to burn a livecd that predates Hardy (8.04) and copy its xorg.conf to your installed system. You cannot use any 8.04 (or later) livecd because that is when they adopted the plug&play approach to xorg that is causing the confusion you are going through right now.
 
Old 11-26-2008, 09:34 AM   #14
woohoohoo
LQ Newbie
 
Registered: Nov 2008
Posts: 18

Original Poster
Rep: Reputation: 0
i trued the sudu display line, nothing happened, it just asked for password and then returned back to terminal with no message.

I can't burn a CD, i don't even have one of them! Plus, i don't know anyone called Hardy.

This isn't cool. I'm only 36 and i feel like i'm no longer "down with the youth society".
 
Old 11-26-2008, 10:02 AM   #15
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
I'm only 36 and i feel like i'm no longer "down with the youth society
LOL, the difference a year can make (I'm 35 and half on my way to 36).

Hmm, let's try this. Open your terminal again and run:
cd /etc/X11
sudo cp xorg.conf xorg.conf.bak
sudo gedit xorg.conf

Insert this line
Driver "vesa"
under the "Device" section.
Then save, close gedit and press Ctrl + alt + backspace. This may - likely will - require a bit more work but let's wait and see.

Btw, should this place you in front of a black screen, just log in at the prompt and do
sudo mv /etc/X11/xorg.conf.bak /etc/X11/xorg.conf
(confirm overwrite if prompted)
to restore your current xorg.conf and reboot.

Last edited by jay73; 11-26-2008 at 10:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installed ubunto twice by mistake now in boot up screen get 2 options for ubunto salpapa Linux - Newbie 8 06-28-2007 06:24 PM
So new it hurts dougelephant Linux - Newbie 38 03-24-2006 06:01 PM
So new it hurts TyBarton Linux - Newbie 5 10-25-2005 03:25 PM
Linux Hurts My Eyes.... Nukem Linux - General 35 01-05-2004 05:52 AM
AAAARGH! My eyes! My beautiful eyes! briancof Linux - Newbie 3 11-27-2001 07:26 AM


All times are GMT -5. The time now is 06:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration