LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2014, 08:12 AM   #1
MisterSnrub
LQ Newbie
 
Registered: Mar 2013
Posts: 6

Rep: Reputation: Disabled
typing really long commands at the prompt behaves differently


When I type a really long command in my PuTTY session, when I'm connected to one system as I type, the command wraps to the next line, like so:

[mrsnrub@my-test-site ~]$ echo "We the People

... as I keep typing more and more letters the command will scroll to the right, and a "<" sign will appear as the first character, like so:

Code:
<st-site ~]$ echo "We the People of the United States"
However, if I connect to another site, the text will wrap to the next line instead of scrolling to the right, like so:

Code:
[mrsnrub@my-other-site ~]$ echo "We the People of the United States in order to f
orm a more
Why is it different for each system? I would prefer they all scroll to the right instead of wrapping to another line.
 
Old 12-19-2014, 09:18 AM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Line wrapping depends on the ssh daemon on the other (server) side.

Edit: and the shell used by ssh daemon.

Last edited by veerain; 12-21-2014 at 04:37 AM.
 
Old 12-19-2014, 09:32 AM   #3
MisterSnrub
LQ Newbie
 
Registered: Mar 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
OK, is there any way to check that?
 
Old 12-19-2014, 09:52 AM   #4
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 9,246

Rep: Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684
I actually found the same issue at work and it was due to the way PS1 had been set
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 'source' behaves differently in RHEL 5 and 6 Jerry Mcguire Linux - Newbie 2 06-30-2014 02:47 AM
A strange Problem when typing long commands in tty spiky0011 Linux From Scratch 17 12-06-2011 12:17 PM
[SOLVED] OpenLDAP Commands Over TLS/SSL Behaves Differently? peridian Linux - Security 1 02-20-2011 02:31 PM
applet on linux server behaves differently naijaguy Programming 3 01-07-2005 03:09 PM
shell behaves differently in rl5 and rl3 Warmduvet Linux - General 22 09-22-2004 06:05 PM


All times are GMT -5. The time now is 06:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration