LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-27-2005, 01:32 PM   #1
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Rep: Reputation: 15
typing "p" gets the shell console stuck


Hi all

My problem seems unbelievable but it truly happens. Every time I type something on “Terminal Program” (=“Shell Console”) window (in KDE) it works fine until I need to use a command that has "p" letter inside. Then it gets stuck just after I type "p" - not responding on anything. It happens *always*. (My wife has just corrected me, sometimes you manage to type one “p” and get out with it).

I have managed to find a workaround, so I write all commands in other place and then I *copy* them to the terminal window. It is not a best method to work with the command line, believe me

When I type “p” in every other application it works just fine.

My keyboard is very standard, and I am using the debian linux for just 2 days.

PLEASE HELP
 
Old 04-27-2005, 03:00 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
I have not heard of this problem before, but here's some suggestions:

— Check your keyboard settings in the KDE control center, and in your system's XWindows/XOrg configuration.

— Make sure that you don't have any short-cuts or hot-keys mapped to p in control panel (khotkeys)

— Try using a different terminal like xterm, gterm or aterm. Hit Alt+F2 to get a basic "run command…" prompt.

— Switch to Gnome instead of KDE.

If you can't track down the problem, try upgrading your KDE packages to the latest available version before reporting a bug through bugs.kde.org
 
Old 04-27-2005, 03:25 PM   #3
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Original Poster
Rep: Reputation: 15
rjlee, thanks

*xterm* works fine.

I have done "apt-get upgrade" to upgrade KDE, the problem with "p" remained.

Keyboard settings in the KDE control center seem normal "Generic 105-key (Intl) PC". Please tell how to check XWindows/XOrg configuration, or where can I read about it?

My settings for short-cuts or hot-keys should be default, since I installed knoppix3.8 just 2 days ago and didn't change anything. Where are they located?

Last edited by leg_of_pinguin; 04-27-2005 at 03:26 PM.
 
Old 04-27-2005, 03:41 PM   #4
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
Does sound like a strange problem. I would have thought it was a hot-key problem as well. Does the 'p' key do anything when there is nothing running?

Also try to boot your Knoppix as LiveCD and see if the problem occurs then. If so then it may be the knoppix 3.8 CD and not the HD install.

KC
 
Old 04-27-2005, 07:29 PM   #5
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Original Poster
Rep: Reputation: 15
We have just checked.

The "p"-problem remains when one boots from Knoppix 3.8.1 CD.

What we have to do at this situation? Reporting a bug?
(Still I suspect *I* did something wrong, because I started to work with linux only 2 days ago...)
 
Old 04-27-2005, 07:50 PM   #6
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
Try checking the MD5SUM first. D/L this file:

KNOPPIX_V3.8.1-2005-04-08-EN.iso.md5

from here:
ftp://ftp.cise.ufl.edu/pub/mirrors/knoppix/

follow the instructions below before doing any bug reporting.


Q: What are these strange MD5 files that accompany the ISO CD images?

A: The files with the .md5 extension contain checksums for the actual CD
images. A checksum is a "matching number" for checking files. One can
verify that the file matches its original down to the smallest detail.
When you download both the ISO image for the CD and its corresponding .md5
file, you can verify that your download was complete and that the contents
are unchanged by typing "md5sum -c filename.md5" under Linux/Unix. Further
information about MD5 and programs for various OS's can be found at
http://www.fourmilab.ch/md5/. You can download a Windows(TM) version at
http://www.toast442.org/md5gui.shtml.

KC
 
Old 04-27-2005, 08:05 PM   #7
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Original Poster
Rep: Reputation: 15
I just have a CD, not an .iso file.
How do I run md5 on it?

My version is German one. I think the download was ok. Still I would like to verify it, if possible.
 
Old 04-28-2005, 02:37 AM   #8
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Rep: Reputation: 30
MD5 sums were ok.... (I downloaded the ISO for him )

If you don't have problems using *xterm* meanwhile you just can add shortcut button to the start panel (just drug and drop xterm I think)

Try also the older LiveCD - Knoppix 3.7 does it have same problem?
That is really really strange..........
 
Old 04-28-2005, 02:55 AM   #9
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Rep: Reputation: 30
Two more things.....
1. Can you try another keyboard (HW)?
2. Does Ctrl-Q releases it?
 
Old 04-28-2005, 03:20 PM   #10
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Original Poster
Rep: Reputation: 15
Artik, hi

Knoppix 3.7 has the same problem. A little difference - instead of getting stuck, it writes almost a random combination of symbols in the command line (a long one).

Ctrl-Q does not release the terminal

Perhaps the problem in the keyboard, however in all other application it works just fine. I don't have another keyboard, may be I will take one from TC to try it.
 
Old 04-28-2005, 05:00 PM   #11
leg_of_pinguin
LQ Newbie
 
Registered: Apr 2005
Location: Israel
Posts: 28

Original Poster
Rep: Reputation: 15
We have managed to get closer to a cause !

Typing "p" in the shell console turns on the "Scroll Lock" led.

It is not clear why it happens (in other application typing "p" do not turn on Scroll Lock),
also why Scroll Lock key makes the terminal stuck.

After pressing "Scroll Lock" we can continue writing !
 
Old 04-28-2005, 11:57 PM   #12
Artik
Member
 
Registered: Apr 2005
Location: Israel
Distribution: Debian 3.1 Sarge, Ubuntu Breezy
Posts: 223

Rep: Reputation: 30
One more thing - try to go in konsole windows Settings -> Shortcuts, also try to change Settings -> Keyboard try different types.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shell Script: Find "Word" Run "Command" granatica Linux - Software 5 07-25-2007 07:42 AM
No UTMPX entry, You must EXEC "login" for the lowest "shell" ooihc Solaris / OpenSolaris 7 03-12-2007 02:09 PM
Debian Boot Up Problem - stuck at "BR" & "I" jc70417 Debian 2 08-30-2005 04:36 PM
How to start KDE automaticlly without typing "startx" then "startkde" Jonescity Slackware 8 10-29-2004 09:32 PM
i just finished typing "./configure" and "make" in mplayer directory... kublador Linux - General 4 02-22-2003 03:12 PM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration