LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2008, 10:04 AM   #1
Quads
Member
 
Registered: Jul 2008
Location: Indiana
Distribution: Fedora, Ubuntu, Slackware
Posts: 203

Rep: Reputation: 34
Two network cards, but only one works at a time


I have my box set up with two identical network cards, one to the cable modem, and one to my other box with a crossover cable. They are both set up properly in the machine, and they both work. My first card automatically gets an ip from the cable provider, and my second card I set manually so that I can connect to the other box. The thing is, only one will work at a time. When I connect one I lose the other. Any ideas would be greatly appreciated, but dummy it down a bit because I am new to linux
 
Old 07-31-2008, 10:07 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Make sure that both interfaces are on different subnets or networks. If both are on the same subnet, you will have two routes for the same subnet.

Also check the output of "/sbin/route" and check that the cable modem's ip address is the default gateway and that there is a route to the second subnet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can i use 2 network cards at the same time? pinofiel Linux - Networking 1 04-28-2007 01:41 AM
wi-fi power management works with atheros cards? geek1234 Linux - Wireless Networking 6 04-25-2007 09:02 PM
2 netwrok cards but only 1 works Court-Jester Linux - Networking 3 10-12-2004 03:52 PM
Suse 9.1 and two video cards, it works!!! raxxal Linux - Distributions 2 09-25-2004 08:35 PM
no signal when starting xorg for the 1st time (but the second time works fine) bungalowbill Linux - Software 0 06-04-2004 10:56 AM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration