LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2004, 06:01 AM   #1
minjos
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Rep: Reputation: 0
Unhappy tv-out help redhat9+nvidia


Hello to all of you out there. I have a problem configuring x86config file to get my tv-out to work. I have a Hansol TFT monitor on nvidia ti4200 card. Last time I tried i got error message trying to start x "no screens found". my skills in console areǹt any good so I had to reinstall. I have been figting with Linux for 2 weeks and I dont plan to give up. Can somebody give me an example what to write in x86 config file. Now it looks like this:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Generic Monitor, 1280x1024 @ 60 Hz"
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 ti4200"
VideoRam 131072
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Thanx in advance.
 
Old 03-16-2004, 07:30 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Have you installed the nvidia drivers?
 
Old 03-16-2004, 09:38 AM   #3
dslboy
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Slackware -current
Posts: 157

Rep: Reputation: 30
Every time you install something, you have to use the README files.
They are really important, cuz not a installations function the same.

But remove section DRI, remove videoram from display-device section, and dpms from monitor section, and you should be good to go, if you have installed the drivers though..
 
Old 03-16-2004, 10:33 AM   #4
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
yeah.... you didnt add the TV-out "1" Option to that config.... read the readme !
 
Old 03-16-2004, 11:10 AM   #5
dslboy
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Slackware -current
Posts: 157

Rep: Reputation: 30
Hehe, sorry, forgot the tv-out thing.

add this in device section...

Section "Device"
Identifier "Nvidia"
Driver "nvidia"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x480;"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "COMPOSITE"
Option "TwinViewOrientation" "Clone"
EndSection

Option "TwinViewOrientation" "Clone"
I'm using this option cuz I had some window border problems which I just didn't want to fix.
If this option is disabled, the nvidia driver will make you're monitor and tv horizontal spanned, so some of the windows in wm will go crazy...
 
Old 03-16-2004, 01:46 PM   #6
minjos
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanx

Thanx guys. Yes I have installed drivers and they work fine. I tried on Enemy territory and they are good. Only thing I was not sure of was how to edit x86config file. Il trie your lines immediatly and come back to you if it works out.


THANX!!!!!
 
Old 03-16-2004, 02:29 PM   #7
minjos
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
It works

Thanx guys. I used your lines and typed them in x86config file, i had to take away 1024x768 in meta modes since my tv doesnt support it . It will only work in 800x600. Everything works fine now except that now on my primary monitor i have only 800X600. How can I make it back to 1280x1024 again and still keep tv out picture. My x86config file now looks like this::

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Generic Monitor, 1280x1024 @ 60 Hz"
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 70.0
EndSection

Section "Device"
Identifier "Nvidia"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 ti4200"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "800x600, 800x600; 640x480, 640x480;"
Option "TVStandard" "PAL-B"
Option "TVOutFormat" "SVIDEO"
Option "TwinViewOrientation" "Clone"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Nvidia"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Thanx again!!
 
Old 03-16-2004, 05:25 PM   #8
dslboy
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Slackware -current
Posts: 157

Rep: Reputation: 30
Its somewhere in metamodes, dont actually remember, but I think youll be fine, if you'd erase that line.. Try it...
 
Old 03-16-2004, 05:41 PM   #9
minjos
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Whole line?

Do you mean the whole line "options metamodes"?

Thanx for your time.!!!!!!!!!!!!
 
Old 03-17-2004, 02:38 AM   #10
oudent
Member
 
Registered: Jul 2001
Distribution: Ubuntu
Posts: 195

Rep: Reputation: 30
Sorry for not being helpful here but, does the NVIDIA driver not handle this automatically?

I have a GeForce FX5200 based video card...I installed the driver...got rid of the DRI line or whatever, and changed the driver name from nv to nvidia and I had full TV out support. Worked just as well as in Windows.

Only reason I'm saying this is that NVIDIA supports linux pretty well and try to make things easy.
 
Old 03-17-2004, 04:08 AM   #11
minjos
LQ Newbie
 
Registered: Mar 2004
Posts: 8

Original Poster
Rep: Reputation: 0
re

Nope it did not work for me. Maybe cause my card is older and have vivo on it. It works only if I type lines from above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
Can't build nvidia.ko on MEPIS3.3. Read /usr.../nvidia-kernelsource/README.debian digorykirke Linux - Software 0 03-16-2005 03:10 AM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 06:38 AM
nvidia gforce mx400 drivers help redhat9 konflict676 Linux - Hardware 2 01-30-2004 10:13 AM
Redhat9.1 install & nvidia acjt Linux - General 7 06-20-2003 05:22 AM


All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration