LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-18-2004, 08:04 PM   #1
pgte3
Member
 
Registered: Aug 2004
Posts: 62

Rep: Reputation: 15
Question Turn off touch pad "clicking"


Greetings,

I am new to Linux. I have just installed debian "Sarge" on my Toshiba note book A15-S157. I would like to disable touch pad "clicking". I think I can do this by using tpconfig. I have installed this package from debian. From what I have read, I should run this program at startup. Could someone provide me with an example of what I should run, and where I should run it. I am not familiar with startup scripts yet so I will need some detailed help. Thanks.

Peter
 
Old 08-19-2004, 09:56 AM   #2
littlemidget
Member
 
Registered: Aug 2004
Location: Oslo, Norway.
Distribution: Debian Sarge
Posts: 171

Rep: Reputation: 30
try to do this and read a bit;

man tpconfig

It should give you a nice file :-)

Or you could take a look in /etc/X11/XF86Config-4 and see what it says about your touchpad there :-)
 
Old 08-19-2004, 12:09 PM   #3
irlandes
Member
 
Registered: Nov 2003
Posts: 117

Rep: Reputation: 16
I hate touch pad clicking...

and I have over a period of time tried every suggestion on eliminating it. Most of the time the files I am told to edit either don't exist, or editing them does not eliminate the clicking. I will try this latest suggestion.

As fa as XFConfig-4, mine had nothing that really affects the auto- click functioning.

To make it clear, I am talking that the little square that moves the cursor on a laptop when you run a finger across it, engages in random clicking as if I had left clicked. and no matter how careful I am, it does it, in both Win and linux. i waste a lot of time with this, and it is even worse when it clicks on a POST button before I am ready.

HOwever, the really worst problem is when I am typing, and the slightest touch with my wrist on this square grabs the typing cursor and repositions it somewhere else on the page, thus typing stuff in the wrong place. CTRL-Z should hypothetically undo, but at times that eliminates a large amount of material already types.

In general auto clicking on that cursor square is a bummer.
 
Old 08-19-2004, 12:13 PM   #4
littlemidget
Member
 
Registered: Aug 2004
Location: Oslo, Norway.
Distribution: Debian Sarge
Posts: 171

Rep: Reputation: 30
I know what you mean, and I can see why this is such a big problem. I think you may have a too high tap-time. If i tap my touchpad two times, it works as a right-click on my mouse.

You could try to add the touchpad to your /etc/X11/XF86Config-4 , and then just comment the line where the tap-stuff is, or modify it.

Here is what my /etc/X11/XF86Config-4 says about my touchpad:

Code:
Section "InputDevice"
        Driver          "synaptics"
        Identifier      "touchpad"
        Option          "Device"        "/dev/psaux"
        Option          "Protocol"      "auto-dev"
        Option          "LeftEdge"      "1700"
        Option          "RightEdge"     "5300"
        Option          "TopEdge"       "1700"
        Option          "BottomEdge"    "4200"
        Option          "FingerLow"     "25"
        Option          "FingerHigh"    "30"
        Option          "MaxTapTime"    "180"
        Option          "MaxTapMove"    "220"
        Option          "VertScrollDelta" "100"
        Option          "MinSpeed"      "0.06"
        Option          "MaxSpeed"      "0.12"
        Option          "AccelFactor"   "0.0010"
#       Option          "SHMConfig"     "on"
#       Option          "Repeater"      "/dev/ps2mouse"
        Option          "CorePointer"

Last edited by littlemidget; 08-19-2004 at 12:15 PM.
 
Old 08-22-2004, 09:54 PM   #5
pgte3
Member
 
Registered: Aug 2004
Posts: 62

Original Poster
Rep: Reputation: 15
Here is a sample script I found. How and where do I run it?


#!/bin/sh
# touchpad
# description: Startup script to disable touchpad tapping
# For Synaptics or ALPS touchpads.
#
# $Log$
#
# $Id$
#
#

test -r /etc/rc.d/init.d/functions && . /etc/rc.d/init.d/functions


echo ""
echo -n "Turning off Touch-Pad 'tapping' "

if [ -f /usr/bin/tpconfig ]; then
/usr/bin/tpconfig --tapmode=0
if [ $? ]; then
echo_failure
else
echo_success
fi
else
echo_failure
fi
echo ""
exit 0
 
Old 08-22-2004, 10:48 PM   #6
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Do you have a file called /etc/rc.d/rc.local. If so then you save the script you found someplace as root, maybe /usr/bin, make the file executable chmod 755 filename. Then in your rc.local file add the line:

/usr/bin/filename

This will execute the file upon startup.

HTH
 
Old 08-24-2004, 01:46 PM   #7
pgte3
Member
 
Registered: Aug 2004
Posts: 62

Original Poster
Rep: Reputation: 15
Unhappy

Quote:
Originally posted by JayCnrs
Do you have a file called /etc/rc.d/rc.local. If so then you save the script you found someplace as root, maybe /usr/bin, make the file executable chmod 755 filename. Then in your rc.local file add the line:

/usr/bin/filename

This will execute the file upon startup.

HTH
I do not have the above file. I think in debian it is recommended that these type of scripts go into /etc/init.d/rcS. I tried the following:

In /etc/init.d/rcS I have placed /home/peter/touchpad.sh. This does not work, and gives a message seen at start up something like "/etc/init.d/rcS run line 14 /home/peter/touchpad.sh not a file or directory found".

I have actually placed the entire script in /etc/init.d/rcS. This does not work, and gives a message seen at start up something like "can not find /usr/bin/tpconfig".

(note: I see these messages at start up but not in the message or kernel logs, why?)

All this strikes me as a path problem of some sort. The path in /etc/init.d/rcS seem to include /usr/bin. Does the path change as you execute another script?

I do not know why running dpkg-reconfigure tpconfig, and setting in the options "--tapmode=0" does not work. This seems to me like it should work, with no need for this script.

If I do need to use this script I just can not seen to get it right. I sure it is some thing I am doing wrong. Suggestions welcome.

Peter
 
Old 08-25-2004, 02:59 PM   #8
pgte3
Member
 
Registered: Aug 2004
Posts: 62

Original Poster
Rep: Reputation: 15
Smile I am satisfied for now

I am satisfied for now. The following write up was able to answer my newbie type questions concerning debian start up.

http://www.aboutdebian.com/linux.htm

Thanks, Peter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disblae Touch pad *Clicking* on a laptop wh33t Linux - Hardware 6 06-03-2009 08:07 PM
Disable Touch pad *Clicking* wh33t Mandriva 20 10-27-2008 11:00 AM
Parasite in a file name with touch & ">" orgazmo Programming 25 05-24-2005 04:28 AM
Can't boot Mandrake 10.0, "Cannot touch, Read-Only File System" RasutoIbuki Mandriva 5 07-23-2004 09:57 PM
"RPM -uvh ..." vs Double Clicking 'Install' free_andrew Linux - Software 1 12-07-2003 08:28 PM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration