LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-30-2006, 12:37 PM   #1
SpiderIRE
Member
 
Registered: Jan 2005
Distribution: FC (Planet CCRMA Kernel)
Posts: 81

Rep: Reputation: 15
turn off BEEP in BASH shell


It annoys me that everytime i type something wrong or press backspace too many times my computer beeps!! I'm using a BASH shell with FC3! does anyone know how i can turn this bell off?? in the setting menubar i can only change the bell from one event to another-i want to turn it off!!

Thanks!
 
Old 04-30-2006, 01:37 PM   #2
puffinman
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Gentoo, Slackware
Posts: 217

Rep: Reputation: 30
In /etc/inputrc you can put the line "set bell-style none" to turn off the beeping from bash. Or you can use my solution and disconnect the frickin' worthless PC speaker so that nothing beeps, EVER.
 
Old 04-30-2006, 03:25 PM   #3
vls
Member
 
Registered: Jan 2005
Location: The grassy knoll
Distribution: Slackware,Debian
Posts: 192

Rep: Reputation: 30
Code:
setterm -blength 0
in /etc/profile or $HOME/.bash_profile
 
Old 09-07-2006, 09:19 AM   #4
Randux
Senior Member
 
Registered: Feb 2006
Location: Siberia
Distribution: Slackware & Slamd64. What else is there?
Posts: 1,705

Rep: Reputation: 54
Quote:
Originally Posted by vls
Code:
setterm -blength 0
in /etc/profile or $HOME/.bash_profile
It's never too late to say thank you.

Thanks!
 
Old 09-11-2006, 06:22 AM   #5
SpiderIRE
Member
 
Registered: Jan 2005
Distribution: FC (Planet CCRMA Kernel)
Posts: 81

Original Poster
Rep: Reputation: 15
oh yeah-THANKS!
 
Old 07-10-2007, 08:04 AM   #6
sghazi
LQ Newbie
 
Registered: Jul 2007
Location: Mississauga, Canada
Posts: 1

Rep: Reputation: 0
Thumbs up my first post here

I am new here but found this useful
THANKS
 
Old 10-24-2009, 04:41 PM   #7
tomz
LQ Newbie
 
Registered: Oct 2009
Location: San Diego
Distribution: ubuntu
Posts: 1

Rep: Reputation: 0
Smile

Quote:
Originally Posted by vls View Post
Code:
setterm -blength 0
in /etc/profile or $HOME/.bash_profile
On cygwin, this didn't work, but putting
Code:
set bell-style none
in ~/.inputrc did. Just thought I'd put it out there. Hey, my first post.
 
  


Reply

Tags
bash, inputrc, setterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off the annoying beep puzz_1 Linux - Hardware 3 02-22-2009 12:46 AM
How to turn off beep in vitual console abrb220 Linux - General 4 02-22-2007 05:08 AM
How do I turn off the system beep? Fasn8n Ubuntu 5 02-21-2007 06:36 PM
bash beep allelopath Linux - General 10 05-26-2005 04:08 AM
Cygwin:How do you turn the bash shell bell off? petercool Linux - Newbie 8 05-23-2003 10:48 AM


All times are GMT -5. The time now is 01:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration